Rating@Mail.ru
IPB
Etersoft - from Windows to Linux
Etersoft
решения для перехода
с Windows на Linux
Дружественные сайты: alv.me и Rus-Linux.net

Здравствуйте, гость ( Вход | Регистрация ) Поиск · 

Профиль
Фотография
Опции
Опции
О себе
Хиппи проснулись, и вот они здесь! (Д.Гайдук)
Личная информация
Komintern
Новичок
Возраст не указан
Мужской
Бобруйск
День рождения не указан
Интересы
Нет данных
Другая информация
Операционная система: Слаковод, BSDшник
JID: kwcenter@jabber.kiev.ua
Город: Киев
Статистика
Регистрация: 24-March 11
Просмотров профиля: 1142*
Последнее посещение: 10th February 2018 - в 14:36
Часовой пояс: Feb 20 2018, в 06:45
13 сообщений (0.01 за день)
Контактная информация
AIM Нет данных
Yahoo Нет данных
ICQ Нет данных
MSN Нет данных
Contact E-mail скрыт
* Просмотры профиля обновляются каждый час

Komintern

Участники


Темы
Сообщения
Друзья
Содержимое
Купили лицензию Wine@Etersoft Network 2.1.3. Получили через систему сборки/отгрузки Etersoft пакеты для Ubuntu 10.04 64 bit, установили и работали.

Возникла необходимость обновления ОС до Ubuntu 14.04. При попытке получения пакетов от того же Etersoft обнаружилось что часть пакетов отгружается для amd64, часть пакетов для i386.
Обращение в поддержку привело к переписке в 10 писем-отказов исправления бага и сборки необходимых пакетов.

Итого:

Мы не можем установить на Ubuntu 14.04 64-bit отгруженные нам пакеты для i386 из за ошибок зависимостей:
Spoiler:

$ sudo dpkg -i wine-etersoft_2.1.3-eter9ubuntu_i386.deb

...
Unpacking wine-etersoft (2.1.3-eter9ubuntu) ...
dpkg: зависимости пакетов не позволяют настроить пакет wine-etersoft:
wine-etersoft зависит от libasound2.
wine-etersoft зависит от libc6.
wine-etersoft зависит от libcups2.
wine-etersoft зависит от libdbus-1-3.
wine-etersoft зависит от libfontconfig.
wine-etersoft зависит от libfreetype6.
wine-etersoft зависит от libglib2.0-0.
wine-etersoft зависит от libgnutls26.
wine-etersoft зависит от libgstreamer-plugins-base0.10-0.
wine-etersoft зависит от libgstreamer0.10-0.
wine-etersoft зависит от libice6.
wine-etersoft зависит от libieee1284-3.
wine-etersoft зависит от libjpeg8.
wine-etersoft зависит от liblcms1.
wine-etersoft зависит от libmpg123-0.
wine-etersoft зависит от libncurses5.
wine-etersoft зависит от libopenal1.
wine-etersoft зависит от libpng12-0.
wine-etersoft зависит от libsm6
dpkg: error processing package wine-etersoft (--install):
проблемы зависимостей — оставляем не настроенным
...

$ dpkg -l | grep libasound2
ii libasound2:amd64 1.0.27.2-3ubuntu7 amd64 shared library for ALSA applications
ii libasound2-data 1.0.27.2-3ubuntu7 all Configuration files and profiles for ALSA drivers
ii libasound2-plugins:amd64 1.0.27-2ubuntu2 amd64 ALSA library additional plugins
...
$ $ dpkg -l | grep libc6
ii libc6:amd64 2.19-0ubuntu6.3 amd64 Embedded GNU C Library: Shared libraries
ii libc6-dbg:amd64 2.19-0ubuntu6.3 amd64 Embedded GNU C Library: detached debugging symbols
ii libc6-dev:amd64 2.19-0ubuntu6.3 amd64 Embedded GNU C Library: Development Libraries and Header Files
ii libc6-i386 2.19-0ubuntu6.3 amd64 Embedded GNU C Library: 32-bit shared libraries for AMD64

Мы не можем установить на Ubuntu 14.04 64-bit отгруженные нам пакеты для amd64, но для Ubuntu 10.04 опять же из за ошибок зависимостей.

Соответственно мы не можем использовать Wine@Etersoft Network на Ubuntu 14.04 и производителю ПО на нас наплевать:

Spoiler:

Нам нужен 64-битный, он СУЩЕСТВУЕТ для Ubuntu 10.04, вот эти пакеты:

$ dpkg -I wine-etersoft_2.1.3-eter9ubuntu_amd64.deb

Package: wine-etersoft
Version: 2.1.3-eter9ubuntu
Architecture: amd64
Maintainer: System Administrator <Система отгрузки Etersoft <support@etersoft.ru>>

$ dpkg -I wine-etersoft-network_2.1.3-eter5ubuntu_amd64.deb

Package: wine-etersoft-network
Version: 2.1.3-eter5ubuntu
Architecture: amd64
Maintainer: builder <builder@builder64.office.etersoft.ru>

Нам нужны ЭТИ ЖЕ 2 (два) 64-битных пакета собранные для Ubuntu 14.04 64-bit.

32-битные пакеты выдают при установке на 64-битной Ubuntu 14.04 ошибки по зависимостям.
64-битные пакеты от Ubuntu 10.04 выдают при установке на 64-битной Ubuntu 14.04 ошибки по зависимостям.

Вы можете собрать 64 битные пакеты для 64-битной Ubuntu 14.04 (да/нет)?


[b]> Вы можете собрать 64 битные пакеты для 64-битной Ubuntu 14.04
> (да/нет)?

Нет.


Если мы не можем получить тот же продукт который работал на Ubuntu 10.04 (и за который заплачены деньги) работающим на Ubuntu 14.04, вывод может быть только один - такой продукт не нужен. А нам придётся искать другие пути решения проблемы.
Просмотры


9 Nov 2014 - 8:02


8 Oct 2014 - 15:08


7 Oct 2014 - 16:44


15 Sep 2012 - 14:28


15 Sep 2012 - 12:35


Друзья
Друзей нет.
RSS Текстовая версия Сейчас: 20th February 2018 - в 06:45




Rating@Mail.ru