Rating@Mail.ru
IPB
Etersoft - from Windows to Linux
Etersoft
решения для перехода
с Windows на Linux
Дружественные сайты: alv.me и Rus-Linux.net

Здравствуйте, гость ( Вход | Регистрация ) Поиск · 

Профиль
Фотография
Опции
Опции
О себе
Kopilov не указал(а) ничего о себе.
Личная информация
Kopilov
Знаток линукса
28 от роду
Мужской
Санкт-Петербург
Дата рождения: Март-27-1988
Интересы
Нет данных
Другая информация
Операционная система: Gentoo, Debian
JID: Нет данных
Город: Санкт-Петербург
Статистика
Регистрация: 3-July 08
Просмотров профиля: 52196*
Последнее посещение: Сегодня, в 00:31
Часовой пояс: Feb 22 2017, в 00:54
511 сообщений (0.16 за день)
Контактная информация
AIM Нет данных
Yahoo Нет данных
ICQ Нет данных
MSN Нет данных
* Просмотры профиля обновляются каждый час

Kopilov

Участники


Темы
Сообщения
Друзья
Содержимое
16 Sep 2016
Внезапно обнаружил, что не работает клавиша PrintScreen по привычному назначению (SysRQ -- без проблем smile.gif).
Оказалось, что пакета kde-apps/ksnapshot с некоторого момента не существует. Новости о том, что саму программу KSnapshot похоронили не нашёл (может, плохо искал). Стал искать, какой пакет надо поставить, чтобы эта замечательная программа была в нём -- безрезультатно.
Попробовал пробежаться grep-ом по /usr/portage -- вылезло, что теперь данную роль играет kde-apps/spectacle, причём он уже установлен, только по PrintScreen почему-то не вызывается. Наверно, потому, что в "параметрах системы" осталась старая настройка, а программа поменялась -- пришлось подкрутить, используя руководство KSnapshot-a:
Цитата
If not already configured you can set the global shortcut on System settings Shortcut and Gestures -> Global -> Global Keyboard Shortcuts -> khotkeys -component -> PrintScreen-action.

В общем, починил. Может, пригодится кому. Непонятно только, кому потребовалось этот "спектакль" затевать.
Когда-то я упоминал перевод Experience API, написанный в рамках моей исследовательской работы в магистратуре. Пора представить его общественности!

PDF-версию выкладываю тут, а скоро она должна будет появиться на http://books.ifmo.ru/. PDF-ка делалась для сдачи в печать, нормального оглавления в ней, к сожалению, нет (может, кто подскажет, как оно создаётся).

Есть онлайн-версия на гитхабе, но там переведено около половины: то, что писал я. Вторую часть делал руководитель, и он писал сразу в текстовом процессоре. В дальнейшем постараюсь привести онлайн-версию к актуальному состоянию, если кто-то ещё заинтересован -- буду рад.
Прикрепленные файлы
Прикрепленный файл  xAPI_ru_1.0.1.pdf ( 959.93 килобайт ) Кол-во скачиваний: 9
 
10 Feb 2015
Мы тут клином сошлись на внедрении Systemd в Debian и не только и на том, что нас лишают права выбора системы инициализации. Но есть ещё такая важная вещь, как ядро. Конечно, ставить GNU Hurd или BSD я не собираюсь, однако и Linux Kernel существует не единственной версии.

Недвно попробовал поставить Debian Jessie. (Помимо прочего, оно не встало на мою старую DOS-разметку, а на созданной инсталлятором GPT не удалось загрузить развёрнутый позже бекап Gentoo, но оставим это в стороне. Это был мой первой опыт с GPT.)
Главная проблема: перестали работать USB-порты. Вообще. А ещё при загрузке выскакивала какая-то ошибка про ACPI -- и при выключении приходилось удерживать кнопку Power.
Spoiler:
На соседнем форуме это оказалось очень к месту: http://forum.sources.ru/index.php?showtopi...p;#entry3568965

Пишут, что проблема началась с версии ядра 3.14 и типа "Acer и AMD опять в своём репертуаре" (у меня Aspire 5560G).
Для исправления предлагают попробовать версию 3.17. В Debian её нет (даже в SID) -- ладно, ещё не внедрили. Но ПОЧЕМУ из более старых (что Image, что Source) есть только 3.2 из старого релиза? А если кому-то нужно поновее, но не самое последнее -- руками с kernel.org качать?
Вот в Gentoo есть из чего выбирать: только стабильных на сегодня 4 штуки. И, что символично, не только 3.2 (уже устарело), но и глючного 3.16 в списке нет вообще.

Что с моей системой (если кому интересно): собрал новую Gentoo на ядре 3.17, переразметив диск обратно в DOS -- всё работает. Заодно выкинул сразу два BLOB-драйвера: BroadcomSTA и FGLRX.
Все любители конфигурации USE="-semantic-desktop" (по крайней мере, те, кто следит за новостями или ставит KDE полным метапакетом) обратили внимание, что этот фокус больше не пройдёт так легко. На форуме дистрибутива пишут, что причина: невозможность оторвать новую версию kdepimlibs от nepomuk (который, собственно, и есть semantic-desktop). Но удалить kdepimlibs целиком никто не мешает! Конечно, если не используются программы, которым он необходим.

equery d kdepimlibs подскажет, каким программам нужна эта библиотека, опционально (по флагу semantic-desktop) или обязательно. Если среди жёстко зависящих от kdepimlibs пакетов нет необходимых вам -- можно двигаться дальше.

Все KDE-приложения (по крайней мере, в моём случае) были установлены с помощью пакета kde-base/kde-meta. Теперь, чтобы удалить pim-приложения и только их (ну, может, ещё малость ненужного), не нарушая структуру зависимостей, придётся отказаться от kde-meta и создать новый метапакет, включив в него то и только то, что нам надо. Простейшим инструментом для создания индивидуальных метапактов в portage являются множества (sets).

Создаём, если не существует, каталог /etc/portage/sets, а в нём -- файл с произвольным именем, например, kde-nopim. Заполняем его следующим содержимым:
Код
kde-base/kate
#kde-base/kdeadmin-meta removed
kde-base/kdeartwork-meta
kde-base/kdebase-meta
kde-base/kdeedu-meta
kde-base/kdegames-meta
kde-base/kdegraphics-meta
kde-base/kdemultimedia-meta
#kde-base/kdenetwork-meta removed
kde-base/kdeplasma-addons
kde-base/kdetoys-meta
kde-base/kde-l10n

#kde-base/kdeutils-meta
kde-base/ark
kde-base/filelight
kde-base/kcalc
kde-base/kcharselect
kde-base/kdf
#kde-base/kgpg removed
kde-base/ktimer
kde-base/kwallet
kde-base/superkaramba
kde-base/sweeper
kde-base/print-manager
Тут перечислено всё содержимое (при моих use-флагах) kde-meta, за исключением двух ненужных мне метапакатов (имевших в том числе pim-программы) и kdeutils-meta, за исключением kgpg.

Теперь удаляем kde-meta emerge --depclean kde-base/kde-meta и ставим вместо него kde-nopim emerge @kde-nopim.
Чистим систему emerge --depclean -- ненужные пакеты, включая kdepimlibs, должны удалиться. Если kdepimlibs ещё жив -- проверяем через equery d, кому он ещё нужен, пробуем удалить, редактируем множество.
После того, как kdepimlibs удалён, можно убрать из /etc/portage/package.use запись
Код
# required by kde-base/kdepimlibs
kde-base/kdelibs semantic-desktop
, пересобрать kdelibs emerge --oneshot kde-base/kdelibs, вызвать emerge --depclean ещё раз.

Прощай, nepomuk!
15 Oct 2013
Пример тут
Это хроническая болезнь движка IPB или излечимо?
Просмотры


3 Feb 2017 - 9:42


20 Jan 2017 - 17:49


18 Dec 2016 - 10:41


11 Dec 2016 - 19:12


8 Nov 2016 - 1:14


30 Oct 2016 - 20:51


18 Oct 2016 - 12:50


13 Oct 2016 - 5:25


16 Sep 2016 - 10:34


3 Sep 2016 - 10:44


Друзья
Друзей нет.
RSS Текстовая версия Сейчас: 22nd February 2017 - в 00:54




Rating@Mail.ru