Rating@Mail.ru
IPB
Etersoft - from Windows to Linux
Etersoft
решения для перехода
с Windows на Linux
Дружественные сайты: alv.me и Rus-Linux.net

Здравствуйте, гость ( Вход | Регистрация ) Поиск · 

> Онлайн

Конференции форума в Jabber: linuxforum@conference.jabber.ru, unixforum@conference.jabber.ru

3 страниц V  < 1 2 3  
Reply to this topic Start new topic
> Стандартизация в Линукс
chitatel
bookmark
gyfbbdvkffmrljmmmwd
Feb 24 2017, в 15:04
Сообщение #61


Не ходи по косогору, сапоги стопчешь!
Иконка группы

Сообщений: 1415

Вставить имя   :   Цитата

Группа: Участники

Цитата(Kopilov @ Feb 24 2017, в 05:45) *
программисты и близкие к ним по умосложению люди

программисты и близкие к ним по телосложению люди smile.gif

Варез сейчас это прежде всего, наверное, игры "таблэтка внутри". Да и раньше так было.

Вот я использую GIMP и его вполне хватает для моих любительских задач. Зачем мне Потожоп? Профессионалу, возможно, нужен, хотя зависит от задачи. И LibreOffice устраивает мои потребности процентов на 90%, M$Office не нужен.

И вот так постепенно привыкаешь жить в безварезном мире. Но если сделать шаг в сторону Уиндоус - без вареза почти никак. sad.gif Ну, или использовать только легальный софт, но жить придётся без штанов и впроголодь. И это в наши-то тяжёлые времена борьбы с мировой закулисой!



--------------------
Новые сапоги всегда жмут.


Спасибо сказали:
Go to the top of the page
 
+Quote Post
Bizdelnick
bookmark
gyfbbdvkffmrljmmmwd
Feb 24 2017, в 19:47
Сообщение #62


grammatikführer
Иконка группы

Сообщений: 12802

Вставить имя   :   Цитата

ОС: Debian GNU/Linux
Город: Санкт-Петербург

Группа: Модераторы разделов

Цитата(UriyZenkov @ 23rd February 2017 - в 20:59) *
Я три дня мучился с этим драйвером, после чего просто сказал что Linux не поддерживает такое старьё.

Ну и зачем же было лгать? Признались бы честно, что не осилили. Впрочем, тут вся тема о том же...


--------------------
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик


Спасибо сказали:
Go to the top of the page
 
+Quote Post
UriyZenkov
bookmark
gyfbbdvkffmrljmmmwd
Feb 25 2017, в 17:21
Сообщение #63


Завсегдатай
Иконка группы

Сообщений: 249

Вставить имя   :   Цитата

ОС: Devuan GNU/Linux
Город: Смела.

Группа: Участники

Цитата(NickLion @ Feb 23 2017, в 22:34) *
UriyZenkov
Драйвера. У меня была web-камера и сетевая карта, дрова только под XP и 32 бита. В Linux проблем не было.

gstreamer 0.10 никому не нужен, вот его и выкидывают из дистров. Всё равно никто его не проверяет на работоспособность, зачем только время тратить. И не надо про совместимость в windows мне рассказывать, уж сколько игр на DirectX 5-7 не запускалось в новых виндах.
Для вашей проприетарной программы можно решить разными способами, если вам нужно.

Решил установкой 32-битны либ: http://libreportal.net/proprietary/etxt-an...uks-64-bit.html
Под Вин все эти либы в комплекте с программой!

Цитата(NickLion @ Feb 23 2017, в 22:34) *
notepadqq в официальном репозитории openSUSE Tumbleweed есть, неужели в Debian хуже? А переход к AkelPad в WINE вообще не логичный. Чем AkelPad лучше, например, Kate?

То есть вы признаёте проблему в стандартах Линукса ?
------------------------
Смотрите какие требования у Kate:

Spoiler:
apt install kate
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
accountsservice apache2-bin apg cheese-common cracklib-runtime crda
cups-pk-helper dh-python dleyna-server dns-root-data dnsmasq-base gdebi-core
gir1.2-gnomekeyring-1.0 gir1.2-packagekitglib-1.0 gkbd-capplet
gnome-control-center-data gnome-online-accounts gstreamer1.0-clutter
gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly iputils-arping iw
libaccountsservice0 libapache2-mod-dnssd libapr1 libaprutil1
libaprutil1-dbd-sqlite3 libaprutil1-ldap libcheese-gtk23 libcheese7
libcolord-gtk1 libcrack2 libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3
libfluidsynth1 libgee-0.8-2 libgeocode-glib0 libgmime-2.6-0
libgnome-bluetooth13 libgnomekbd-common libgnomekbd8 libgoa-backend-1.0-1
libgrilo-0.2-1 libgstreamer-plugins-bad1.0-0 libgtkglext1 libgupnp-av-1.0-2
libgupnp-dlna-2.0-3 libgweather-3-6 libgweather-common libibus-1.0-5
libmjpegutils-2.1-0 libmpdec2 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libndp0
libnetfilter-conntrack3 libnm-glib-vpn1 libnm-glib4 libnm-gtk-common
libnm-gtk0 libnm-util2 libnss-myhostname libopencore-amrnb0
libopencore-amrwb0 libopencv-calib3d2.4 libopencv-contrib2.4
libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4
libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
libopencv-ml2.4 libopencv-objdetect2.4 libopencv-video2.4
libpackagekit-glib2-18 libpwquality-common libpwquality1 libpython3-stdlib
libpython3.4-minimal libpython3.4-stdlib libreadline6:i386
librygel-core-2.4-2 librygel-renderer-2.4-2 librygel-server-2.4-2 libsbc1
libsidplay1 libsrtp0 libtbb2 libteamdctl0 libtelepathy-glib0
libtotem-plparser18 libupower-glib3 libwacom-common libwacom2 libxklavier16
lsb-release mobile-broadband-provider-info mousetweaks packagekit
packagekit-tools python-apt-common python-cups python-cupshelpers
python-libxml2 python-pycurl python-smbc python3 python3-apt python3-chardet
python3-debian python3-minimal python3-pkg-resources python3-six python3.4
python3.4-minimal realmd rygel system-config-printer
system-config-printer-udev wireless-regdb
Для его удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data
kdelibs5-plugins kdoctools libattica0.4 libclucene-core1 libdbusmenu-qt2
libdlrestrictions1 libfam0 libgpgme++2 libiodbc2 libkactivities-bin
libkactivities-models1 libkactivities6 libkateinterfaces4
libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4
libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4 libnepomukcore4
libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libphonon4
libplasma3 libpolkit-qt-1-1 libqca2 libqjson0 libqt4-qt3support libsolid4
libsoprano4 libssh-gcrypt-4 libstreamanalyzer0 libstreams0 libthreadweaver4
libutempter0 nepomuk-core-data ntrack-module-libnl-0 oxygen-icon-theme
phonon phonon-backend-vlc plasma-scriptengine-javascript soprano-daemon
vlc-plugin-pulse
Предлагаемые пакеты:
khelpcenter4 konsole djvulibre-bin finger icoutils libcanberra-pulse
sound-theme-freedesktop fam iodbc hspell libqca2-plugin-cyrus-sasl
libqca2-plugin-gnupg libqca2-plugin-ossl media-player-info
phonon-backend-gstreamer phonon-backend-mplayer virtuoso-minimal
НОВЫЕ пакеты, которые будут установлены:
kate kate-data katepart kde-runtime kde-runtime-data kdelibs-bin
kdelibs5-data kdelibs5-plugins kdoctools libattica0.4 libclucene-core1
libdbusmenu-qt2 libdlrestrictions1 libfam0 libgpgme++2 libiodbc2
libkactivities-bin libkactivities-models1 libkactivities6 libkateinterfaces4
libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4
libkrosscore4 libktexteditor4 libkxmlrpcclient4 libnepomuk4 libnepomukcore4
libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libphonon4
libplasma3 libpolkit-qt-1-1 libqca2 libqjson0 libqt4-qt3support libsolid4
libsoprano4 libssh-gcrypt-4 libstreamanalyzer0 libstreams0 libthreadweaver4
libutempter0 nepomuk-core-data ntrack-module-libnl-0 oxygen-icon-theme
phonon phonon-backend-vlc plasma-scriptengine-javascript soprano-daemon
vlc-plugin-pulse

обновлено 0, установлено 71 новых пакетов, для удаления отмечено 0 пакетов, и 28 пакетов не обновлено.
Необходимо скачать 60,6 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 145 MB.
Хотите продолжить? [Д/н]

Цитата(NickLion @ Feb 23 2017, в 22:34) *
reboot. 1. Эта команда в пакете вроде systemd-sysvinit должна быть.
2. Кто сказал, что это какая-то универсальная команда? Лучше shutdown -r now использовать.

Про яндексбраузер тоже не понятно при чём тут стандартизация? Прогу собирали с какими-то новыми либами, которых нет в Debian Stable.
Да это так повсеместно в Линуксе, яндексбраузер - всего лишь один пример для вас.

shutdown -r now - это тоже вводил - нуль реакции. В общем я на сервере заменил systemd на systemv, а на ноутбуке просто перешел с Debian на Devuan
Go to the top of the page
 
+Quote Post
UriyZenkov
bookmark
gyfbbdvkffmrljmmmwd
Feb 25 2017, в 17:28
Сообщение #64


Завсегдатай
Иконка группы

Сообщений: 249

Вставить имя   :   Цитата

ОС: Devuan GNU/Linux
Город: Смела.

Группа: Участники

Цитата(Bizdelnick @ Feb 24 2017, в 19:47) *
Цитата(UriyZenkov @ 23rd February 2017 - в 20:59) *
Я три дня мучился с этим драйвером, после чего просто сказал что Linux не поддерживает такое старьё.

Ну и зачем же было лгать? Признались бы честно, что не осилили. Впрочем, тут вся тема о том же...


В новых Альтлинуксах LiveCD/USB этот драйвер тоже не запускается (а в старых версиях запускался), так что не осилили разработчики Линукс и разработчики драйверов под Линукс. В других дистрибутивах не проверял. Вот эта тема: Geforce 5500 FX
Go to the top of the page
 
+Quote Post
NickLion
bookmark
gyfbbdvkffmrljmmmwd
Feb 25 2017, в 19:26
Сообщение #65


аватар-невидимка
Иконка группы

Сообщений: 3113

Вставить имя   :   Цитата

ОС: openSUSE Tumbleweed x86_64
Город: Львів

Группа: Участники

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
Решил установкой 32-битны либ: http://libreportal.net/proprietary/etxt-an...uks-64-bit.html
Под Вин все эти либы в комплекте с программой!

И кто мешал разрабам поместить эти либы для Linux? Почему же Linux виноват?

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
То есть вы признаёте проблему в стандартах Линукса ?

Не вижу никакой проблемы стандартизации. В одном дистрибутиве решили, что прорамму можно включить, в другом не включили. Просто удивился.

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
Смотрите какие требования у Kate:

Там что-то не то у вас, там и пакеты для KDE4 и KDE5 версий. Что-то точно не то.

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
shutdown -r now - это тоже вводил - нуль реакции. В общем я на сервере заменил systemd на systemv, а на ноутбуке просто перешел с Debian на Devuan

А вот это уже странно. Тут бы подробности.
Go to the top of the page
 
+Quote Post
alv
bookmark
gyfbbdvkffmrljmmmwd
Feb 26 2017, в 00:07
Сообщение #66


Пенсионер в законе
Иконка группы

Сообщений: 7116

Вставить имя   :   Цитата

ОС: Cintu

Группа: Бывшие модераторы

Цитата(UriyZenkov @ 25th February 2017 - в 18:21) *
shutdown -r now - это тоже вводил

Вообще-то в системах с systemd штатный способ перезапуска и выключения машины, соответственно:
Код
systemctl reboot

и
Код
systemctl halt

Но работают (пока?) и reboot, и halt, и shutdown. Да, требуют каких-то пакетов из серии sysvinit, но они обычно устанавливаются по умолчанию
Вот только в чистом Debian'е, если не изменяет память, все варианты команд перезапуска и останова требуют прав root'а. Вы про это, случаем, не забыли?


--------------------
Go to the top of the page
 
+Quote Post
Bizdelnick
bookmark
gyfbbdvkffmrljmmmwd
Feb 26 2017, в 14:06
Сообщение #67


grammatikführer
Иконка группы

Сообщений: 12802

Вставить имя   :   Цитата

ОС: Debian GNU/Linux
Город: Санкт-Петербург

Группа: Модераторы разделов

Цитата(UriyZenkov @ 25th February 2017 - в 17:28) *
В новых Альтлинуксах LiveCD/USB этот драйвер тоже не запускается (а в старых версиях запускался), так что не осилили разработчики Линукс и разработчики драйверов под Линукс.

Разработчики linux тут абсолютно ни при чём. Виноват исключительно разработчик драйвера, который не собирает его под новые версии Xorg. А разработчик кто? Правильно, nvidia. К ним претензии и адресуйте. Или используйте свободные драйверы, и как бы плохо с ними ни обстояло, vesa будет работать при любой погоде. А проблемы с nouveau с высокой долей вероятности могли возникнуть из-за некорректного удаления проприетарного драйвера (а если он поставлен из run'а, корректного способа его удаления просто нет). Да, Вы угадали, претензии надо снова адресовать nvidia. Впрочем, это только предположение, логов ведь Вы не показали, а вместо этого пошли дезинформировать владельца.


--------------------
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Go to the top of the page
 
+Quote Post
Kopilov
bookmark
gyfbbdvkffmrljmmmwd
Feb 27 2017, в 01:26
Сообщение #68


Знаток линукса
Иконка группы

Сообщений: 523

Вставить имя   :   Цитата

ОС: Gentoo, Debian
Город: Санкт-Петербург

Группа: Участники

Цитата(Bizdelnick @ 26th February 2017 - в 14:06) *
Виноват исключительно разработчик драйвера, который не собирает его под новые версии Xorg. А разработчик кто? Правильно, nvidia.

А nvidia нужно что? Правильно, продать новую видеокарту под новую систему.
Go to the top of the page
 
+Quote Post
UriyZenkov
bookmark
gyfbbdvkffmrljmmmwd
Feb 28 2017, в 15:41
Сообщение #69


Завсегдатай
Иконка группы

Сообщений: 249

Вставить имя   :   Цитата

ОС: Devuan GNU/Linux
Город: Смела.

Группа: Участники

Цитата(Bizdelnick @ Feb 24 2017, в 19:47) *
Цитата(UriyZenkov @ 23rd February 2017 - в 20:59) *
Я три дня мучился с этим драйвером, после чего просто сказал что Linux не поддерживает такое старьё.

Ну и зачем же было лгать? Признались бы честно, что не осилили. Впрочем, тут вся тема о том же...


Я сказал то что есть: в выпусках Дебиана 6 и 7 у меня легко получалось установить этот блоб из офф-сайта и из хранилищь Дебиана. Логи не предоставил давно: Geforce 5500 FX
В той же теме мне сказали, что в Линуксе поменялся ABI и теперь эти видеокарты не поддерживаются. На компиляцию ядра у меня уйдет минимум один день, так как надо еще вспомнить как и как обычно пару раз собрать не правильно. Пользуйтесь старым Дебианом или компиляйте старое ядро или пользуйтесь глючным nouveau. А если я установлю старый Дебиан, а потом понадобятся новые версии программ ?

Видите ли, линуксов много и разрабы Nvidia просто выкладывают файл run, который первым делом ищет компиляторы с исходниками потом компилирует под конкретный Линукс и устанавливает. А кстати, файла xorg.conf уже нет в современных дистрах, а установщик nvidia (как с офф-сайта, так и из репов) все равно его создает и у простого пользователя могут быть проблемы с запуском иксов после перезагрузки компа. Установщик Nvidia сам предлагает пользователю выбрать: устанавливать xorg.conf или нет, но откуда недавний пользователь винды знает что выбрать ? Я позавчера установил Nvidia, но уже на новый компьютер: http://libreportal.net/advice/debiandevuan...tel-nvidia.html (если есть ошибка, пожалуйста укажите мне (можно в грубой форме), чтобы другие пользователи не мучились.

Цитата(NickLion @ Feb 25 2017, в 19:26) *
Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
Решил установкой 32-битны либ: http://libreportal.net/proprietary/etxt-an...uks-64-bit.html
Под Вин все эти либы в комплекте с программой!

И кто мешал разрабам поместить эти либы для Linux? Почему же Linux виноват?

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
То есть вы признаёте проблему в стандартах Линукса ?

Не вижу никакой проблемы стандартизации. В одном дистрибутиве решили, что прорамму можно включить, в другом не включили. Просто удивился.

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
Смотрите какие требования у Kate:

Там что-то не то у вас, там и пакеты для KDE4 и KDE5 версий. Что-то точно не то.

Цитата(UriyZenkov @ Feb 25 2017, в 16:21) *
shutdown -r now - это тоже вводил - нуль реакции. В общем я на сервере заменил systemd на systemv, а на ноутбуке просто перешел с Debian на Devuan

А вот это уже странно. Тут бы подробности.


1. Потому что линуксов много и оoочень сложно поддерживать весь спектр дистрибутивов А вы пробовали устанавливать программу не из диристрибутива, сколько компиляторов и библиотек установили, у вас уже есть весь набор gcc с гигом всяких исходников ? Это получается что Линукс за меня решает какими линуксовыми программами мне пользоваться. Нормально, да ?

А еще меня бесит один момент. Рядом стоит родительский компьютер с Win7 где установлены последние версии линуксовых программ, которые кстати я советовал. А я крутой с линуксом, вынужден пользоваться не самыми последними стабильными выпусками этих программ, которые просто подогнали под мой дистрибутив.

2. Сервер с systemd я пытался перезагрузить через ssh. Systemd мне сразу не понравился его отказом от стандартов UNIX, а отказ в перезагрузке был последней каплей терпения. Теперь я ним не пользуюсь вообще (на сервере и на десктопе: Linux без systemd

Цитата(Bizdelnick @ Feb 26 2017, в 14:06) *
А проблемы с nouveau с высокой долей вероятности могли возникнуть из-за некорректного удаления проприетарного драйвера (а если он поставлен из run'а, корректного способа его удаления просто нет). Да, Вы угадали, претензии надо снова адресовать nvidia.


Настраивал гибридную графику на новом ноутбуке: http://libreportal.net/advice/debiandevuan...tel-nvidia.html
Сначала установил nouveau, посмотреть что там улучшилось - optirun вывалился с ошибками, свидетельствующими о неработоспособности драйвера.
Go to the top of the page
 
+Quote Post
Bizdelnick
bookmark
gyfbbdvkffmrljmmmwd
Feb 28 2017, в 15:57
Сообщение #70


grammatikführer
Иконка группы

Сообщений: 12802

Вставить имя   :   Цитата

ОС: Debian GNU/Linux
Город: Санкт-Петербург

Группа: Модераторы разделов

Цитата(UriyZenkov @ 28th February 2017 - в 15:41) *
Я сказал то что есть: в выпусках Дебиана 6 и 7 у меня легко получалось установить этот блоб из офф-сайта и из хранилищь Дебиана.

Вы не это сказали, а
Цитата(UriyZenkov @ 28th February 2017 - в 15:41) *
что Linux не поддерживает такое старьё.


Цитата(UriyZenkov @ 28th February 2017 - в 15:41) *
В той же теме мне сказали, что в Линуксе поменялся ABI и теперь эти видеокарты не поддерживаются. На компиляцию ядра у меня уйдет минимум один день, так как надо еще вспомнить как и как обычно пару раз собрать не правильно.

Кто сказал? Плюньте ему в рожу. Не в линуксе дело, а в Xorg, и соответственно не в открытом под GPL модуле, который можно пересобрать самому, а в закрытой части драйвера, которую пересобрать может только разработчик.

Цитата(UriyZenkov @ 28th February 2017 - в 15:41) *
Видите ли, линуксов много и разрабы Nvidia просто выкладывают файл run, который первым делом ищет компиляторы с исходниками потом компилирует под конкретный Линукс и устанавливает. А кстати, файла xorg.conf уже нет в современных дистрах, а установщик nvidia (как с офф-сайта, так и из репов) все равно его создает и у простого пользователя могут быть проблемы с запуском иксов после перезагрузки компа. Установщик Nvidia сам предлагает пользователю выбрать: устанавливать xorg.conf или нет, но откуда недавний пользователь винды знает что выбрать ?

Проприетарный драйвер от nvidia неюзабелен, свободных nvidia не делает, а виноват во всём линукс?


--------------------
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик


Спасибо сказали:
Go to the top of the page
 
+Quote Post
NickLion
bookmark
gyfbbdvkffmrljmmmwd
Mar 1 2017, в 00:18
Сообщение #71


аватар-невидимка
Иконка группы

Сообщений: 3113

Вставить имя   :   Цитата

ОС: openSUSE Tumbleweed x86_64
Город: Львів

Группа: Участники

Цитата(UriyZenkov @ Feb 28 2017, в 14:41) *
1. Потому что линуксов много и оoочень сложно поддерживать весь спектр дистрибутивов А вы пробовали устанавливать программу не из диристрибутива, сколько компиляторов и библиотек установили, у вас уже есть весь набор gcc с гигом всяких исходников ? Это получается что Линукс за меня решает какими линуксовыми программами мне пользоваться. Нормально, да ?

И что, что Linux'ов очень много? Отдельный пакет с программой сделать можно и включить туда именно нужные библиотеки нужных версий сделав зависимости по минимальным libc. Просто обычно сами авторы это не делают. По разным причинам, популярные программы и так в дистрибутивах уже есть, кто-то считает, что сами скомпилят, кому надо, кто-то (как автор приведенной вами ранее программы) просто Linux не использует и не хочет разобраться в теме. Лично мне уже надоело повторять, поэтому это мой ПОСЛЕДНИЙ пост в данной теме. И последний раз повторю: нет каких-то особых проблем стандартизации Linux, есть просто нежелание авторов программ собирать большие пакеты, потому что пользователи Linux просто обычно всё равно это не используют. Кто хочет, тот проблему решает, как авторы QupZilla, Krita, Skype, etc.

Цитата(UriyZenkov @ Feb 28 2017, в 14:41) *
А еще меня бесит один момент. Рядом стоит родительский компьютер с Win7 где установлены последние версии линуксовых программ, которые кстати я советовал. А я крутой с линуксом, вынужден пользоваться не самыми последними стабильными выпусками этих программ, которые просто подогнали под мой дистрибутив.

Потому что дистрибутив — это не просто набор ПО, а набор протестированного стабильного в комплекте ПО. Хочется последних версий? Ставьте rolling дситрибутив, вроде openSUSE Tumbleweed, Arch.

UPD забыл сказать про драйвера, можно подумать в Windows кто-то заботится о совместимости драйверов, драйвера Win98 не совместимы с драйверами WinXP, драйвера WinXP (особенно видео) не совместимы с WinVista, те в свою очередь ограниченно совместимы с Win7/8/8.1 (и между собой) и снова не совместимы с Win10. Теперь всё.
Go to the top of the page
 
+Quote Post
yamah
bookmark
gyfbbdvkffmrljmmmwd
Mar 3 2017, в 17:43
Сообщение #72


Свой человек
Иконка группы

Сообщений: 1094

Вставить имя   :   Цитата

ОС: Rosa Fresh, Debian, RELS
Город: Барнаул

Группа: Участники

Цитата(alv @ Feb 26 2017, в 03:07) *
Цитата(UriyZenkov @ 25th February 2017 - в 18:21) *
shutdown -r now - это тоже вводил

Вообще-то в системах с systemd штатный способ перезапуска и выключения машины, соответственно:
Код
systemctl reboot

и
Код
systemctl halt

Но работают (пока?) и reboot, и halt, и shutdown. Да, требуют каких-то пакетов из серии sysvinit, но они обычно устанавливаются по умолчанию
Вот только в чистом Debian'е, если не изменяет память, все варианты команд перезапуска и останова требуют прав root'а. Вы про это, случаем, не забыли?

А это случаем на альяс на новые команды?


--------------------
Понимание - это меч с тремя кромками: ваша правда, наша правда и Истина.
Жизнь - игра: сюжет задуман фигова, но графика хорошая...
Лучший игровой сервер - Земля: карта всего одна, но на 7 миллиардов игроков; читеров нет, админ терпеливый, но если уж забанит...
Go to the top of the page
 
+Quote Post

3 страниц V  < 1 2 3
 Reply to this topic Start new topic
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 19th October 2017 - в 02:53




Rating@Mail.ru