Rating@Mail.ru
IPB
Etersoft - from Windows to Linux
Etersoft
решения для перехода
с Windows на Linux
Дружественные сайты: alv.me и Rus-Linux.net

Здравствуйте, гость ( Вход | Регистрация ) Поиск · 

Профиль
Фотография
Опции
Опции
О себе
Bizdelnick не указал(а) ничего о себе.
Личная информация
Bizdelnick
grammatikführer
33 от роду
Мужской
Место жительства не указано
Дата рождения: Апр-11-1984
Интересы
Нет данных
Другая информация
Операционная система: Debian GNU/Linux
JID: nebotanik@jabber.ru
Город: Санкт-Петербург
Статистика
Регистрация: 11-February 08
Просмотров профиля: 200928*
Последнее посещение: Сегодня, в 19:07
Использование поиска
Часовой пояс: Jul 20 2017, в 19:20
12553 сообщений (3.64 за день)
Контактная информация
AIM Нет данных
Yahoo Нет данных
ICQ Нет данных
MSN Нет данных
Contact E-mail скрыт
* Просмотры профиля обновляются каждый час

Bizdelnick

Модераторы разделов


Темы
Сообщения
Друзья
Содержимое
Сабж, настроенный по документации, работает почему-то не для всех окон. Например в случае с claws-mail не работает:
Код
set $ws2 "2:mail"
assign [class="claws-mail"] $ws2

Класс вроде правильный:
Код
WM_CLASS(STRING) = "claws-mail", "Claws-mail"

Но при запуске окно открывается на текущем воркспейсе. В чём может быть дело, и как исправить?
10 May 2017
Вознамерился поставить Slackware64 14.2 на виртуалку, а именно на qemu/kvm с virtio-диском. Скачал исошник, загрузился — устройства /dev/vda нет, модули virtio* не подгружены. Пытаюсь загрузить вручную — получается только с virtio_input, а остальные не хотят. modprobe ругается на "Exec format error", insmod — на "Invalid module format". Пробовал распаковывать модули virtio*.ko.gz, но ничего не меняется. Нагуглились костыли типа пересобрать ядро со вкомпиленными драйверами, пересобрать initrd с ними или выдрать модули из пакета. Но — вот же они лежат, значит в initrd их уже засунули. Почему не цепляются-то?

Upd. Уточнение: virtio_input подгружается только через insmod, а через modprobe тоже не хочет, потому что тот пытается сперва загрузить проблемный virtio_ring.
29 Mar 2017
Мне никогда не нравились сборочные системы, позволяющие жёстко привязаться к конкретной версии какой-то зависимости. Наверное, одной из первых таких, и точно одной из самых популярных является Maven. И вот свежая новость о том, к чему это приводит. TL;DR: исправленная уязвимость в библиотеке приводит к тому, что все проекты, где забыли поднять версию зависимости, остаются уязвимыми. Если таким образом уязвимость распространяется рекурсивно на другие библиотеки и фреймворки, в итоге она попадает в программы, зависящие от уязвимой библиотеки только опосредованно, для разработчиков которых может вообще оказаться полной неожиданностью, что данная уязвимость может иметь к ним какое-то отношение. Итог — куча дырявого софта, использующегося повсеместно, в данном случае — 2600 только открытых проектов. От взлома пострадало, в частности, муниципальное транспортное агентство Сан-Франциско — год спустя после обнародования информации об уязвимости.
Вот так вот, дорогие любители maven/pip/node/godep/cargo/что-там-вы-используете.
26 Mar 2017
https://bugzilla.mozilla.org/show_bug.cgi?id=1247056
https://bugzilla.mozilla.org/show_bug.cgi?id=1345661
Прелестно. Теперь не осталось ни одного браузера, в котором бы всё работало, можно было бы отключить шпионские фичи, и который не был бы собран с дырявым вебкитом.
24 Mar 2017
Сегодня внезапно psi-plus отказался соединяться с некоторыми серверами, в том числе гугловскими, заявляя, что не доверяет сертификатам, потому что они якобы самоподписанные. При этом к jabber.ru подключается. Проверил сертификаты openssl'ем, цепочки в порядке. Последнее обновление было таким:
Код
Start-Date: 2017-03-24  06:42:46
Commandline: /usr/bin/unattended-upgrade
Upgrade: python-samba:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), winbind:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba-dsdb-modules:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), libnss-winbind:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba-common-bin:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba-libs:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), smbclient:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), libpam-winbind:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), libwbclient0:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba-vfs-modules:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), samba-common:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4), libsmbclient:amd64 (4.2.14+dfsg-0+deb8u2, 4.2.14+dfsg-0+deb8u4)
End-Date: 2017-03-24  06:43:14
Тут всё связано только с самбой. Пакет ca-certificates не обновлялся с декабря. В чём может быть дело? Кто-нибудь ещё такое наблюдает?
Просмотры


Сегодня, в 14:52


Вчера, в 10:32


15 Jul 2017 - 1:04


10 Jun 2017 - 14:02


3 Jun 2017 - 0:51


Друзья
Друзей нет.
RSS Текстовая версия Сейчас: 20th July 2017 - в 19:20




Rating@Mail.ru