BCI в шрифтах (конфликт BCI и Subpixel?)

Модераторы: broom, aim

NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

BCI в шрифтах

Сообщение NickLion » 19.12.2008 07:18

Давно интересует решение проблемы, но все никак не могу найти причину. Есть шрифты от МС (привожу их, т.к. на них больше всего заметно) - Calibri, Consolas и др. В винде с ClearType'ом все гладенько и хорошо. В линуксе проблема - при обычном сглаживании почти все хорошо, при субпиксельном - такое впечатление, что autohint включен на полную. Вот скрины для сравнения (g - gray, s - subpixel, 0 - нет хинтинга, 1 - легкий, 3 - полный):

g0:
g1:
g3:

s0:
s1:
s3:


// В гимпе сравнил s3 и s1 - совпадают с точностью до пикселя, впрочем даже сами файлы одинаковые :).
В чем может быть причина? Конфликт BCI и Subpixel?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: BCI в шрифтах

Сообщение romuil » 19.12.2008 08:11

Все дело в патчах xorg. Насколько мне известно использование bci нелегально и в openSUSE скорее всего просто не включено.
P.S. Если ты в Макеевке - приезжай на сборище LUG - поможем, сусеводы есть.
Спасибо сказали:

Аватара пользователя
sda
Сообщения: 419
ОС: SuSE

Re: BCI в шрифтах

Сообщение sda » 21.12.2008 00:30

imho - субпиксельное сглаживание есть зло. если надо с bci+subpixel rendering - то ставь отсель freetype2+freetype2-devel (и запрети после установки их апдейт):

корневое репо

если довольно только bci (что собственно есть правильно, поскольку нет разноцветных размытых краёв на шрифтах с плохим bci), то ставь отсель:

корневое репо

надеюсь, что настроить шрифты в ~/.fonts.conf и /etc/fonts вы в состоянии самостоятельно...
А форумокъ всёжъ таки с гнiльцой...©
Спасибо сказали:

NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: BCI в шрифтах

Сообщение NickLion » 21.12.2008 09:25

sda, огромное спасибо. Я просто очень сильно протупил... :wallbash:. Пакеты я себе патчил, с ними все в порядке было. Все дело именно в ~/.fonts.conf. Добавил autohint = true, и естесственно, все стало нормально.
Это видимо просто где-то КДЕ4 немного проглюкивает, при сером сглаживании автохинт включается по умолчанию, а вот при субпиксельном все несколько сложнее, детальный анализ приложений показал: в не кде приложениях (Gtk/Cairo) все нормально (например firefox), в некоторых Qt приложениях (Opera, QtCreator) тоже все нормально, пишу свое приложение на Qt, делаю предпросмотр в QtCreator'e - все нормально, запускаю - коряво, вот для сравнения - слева запущенное, справа предпросмотр. (размер шрифта 10, 11, 12).
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали: