Беда с сетью (Xen)

Модератор: Модераторы разделов

Serega955
Сообщения: 35

Беда с сетью

Сообщение Serega955 »

Приветствую! Взял OpenSUSE 12.2, установил Xen, в него я запилил Win2008R2.
В конфиге ксена:
(network-script 'network-bridge netdev=eth0')
(vif-script vif-bridge)
В конфиги виртуальной машины:
vif=[ 'mac=00:16:3e:0b:60:21,model=rtl8139,bridge=eth0', ]

По итогам проделанного - виртуальная машина грузится с нормально работающей сетью, а на реальной интернет ложится. Если мы уничтожим мост, и сделаем рестарт сети, то проблема уходит. Подскажите, если не сложно, куда копать.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 19302
Статус: nulla salus bello
ОС: Debian GNU/Linux

Re: Беда с сетью

Сообщение Bizdelnick »

Сразу предупреждаю: с Xen не возился. Но исходя из общих соображений в качестве моста надо указывать таки интерфейс моста, привязанного к eth0, а не сам eth0.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Serega955
Сообщения: 35

Re: Беда с сетью

Сообщение Serega955 »

Все дело в том, что после установки ксена, в результате сетевой интерфейс переименовывается, так что в системе он теперь называется peth0. Brctl show показывает что eth0 это именно мост.
Спасибо сказали:

Serega955
Сообщения: 35

Re: Беда с сетью

Сообщение Serega955 »

Все оказалось просто. Проблема была видимо с маршрутизацией.
route del default gw 192.168.1.1 dev peth0
route del -net 192.168.1.0 netmask 255.255.255.0 dev peth0
route add -net 192.168.1.0 netmask 255.255.255.0 dev eth0
route add default gw 192.168.1.1 dev eth0

peth0 - реальный интерфейс
eth0 - сетевой мост
Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 874
ОС: gentoo

Re: Беда с сетью

Сообщение vr13 »

Serega955 писал(а):
27.10.2012 15:21
По итогам проделанного - виртуальная машина грузится с нормально работающей сетью, а на реальной интернет ложится. Если мы уничтожим мост, и сделаем рестарт сети, то проблема уходит. Подскажите, если не сложно, куда копать.

можно тут подробнее? что значит "грузится с нормально работающей сетью, а на реальной интернет ложится"? виртуальная машина "видит" локальную сеть и не "видит" интернет? также покажите вывод команд:

uname -a
ip link list
ip route list
brctl show
xm info

upd: не успел ответить :)
вопросы снимаются
Спасибо сказали:

Tokra
Сообщения: 399

Re: Беда с сетью

Сообщение Tokra »

А не проще руками создать мост, средствами ОС.
Потом в конфиге ксена /etc/xen/xend-config.sxp коментим строчку
#(network-script 'network-bridge').

В конфиге виртуалки указываем мост, который Вы создали.
Спасибо сказали: