Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Обсудить вопросы и проблемы с видео

Модератор: Модераторы разделов

Аватара пользователя
ironcam
Сообщения: 600
Статус: Ave Satan
ОС: Ubuntu 14.10 x64

Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение ironcam »

Не работают сабы в SMPlayer.
Без разницы, вшитые, или внешние. Просто ничего не отображается...
В настройках, сабы включены.
вКонтакте
ОСь указана под аватаркой.
Вот скажите, я один такой? У меня всегда уникальные проблемы. Гугл о них ничего не знает, и другие линуксойды тоже...
Если проблемы решаются, только методом тыка...
Спасибо сказали:

Аватара пользователя
sspphheerraa
Сообщения: 1375
ОС: Gentoo

Re: Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение sspphheerraa »

А если в терминале открыть:

Код: Выделить всё

$ mplayer [file] -sid 0 -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,

Чего получается?
Sspphheerraa
Спасибо сказали:

Аватара пользователя
ironcam
Сообщения: 600
Статус: Ave Satan
ОС: Ubuntu 14.10 x64

Re: Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение ironcam »

sspphheerraa писал(а):
02.01.2012 19:40
А если в терминале открыть:

Код: Выделить всё

$ mplayer [file] -sid 0 -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,

Чего получается?

Не работает...
вКонтакте
ОСь указана под аватаркой.
Вот скажите, я один такой? У меня всегда уникальные проблемы. Гугл о них ничего не знает, и другие линуксойды тоже...
Если проблемы решаются, только методом тыка...
Спасибо сказали:

Аватара пользователя
sspphheerraa
Сообщения: 1375
ОС: Gentoo

Re: Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение sspphheerraa »

ironcam писал(а):
03.01.2012 04:27
Не работает...

Жесть! Ты хоть бы вывод в консоли показал. По твоему тут сидят телепаты. Или оно тебе так нужно...
Sspphheerraa
Спасибо сказали:

Аватара пользователя
ironcam
Сообщения: 600
Статус: Ave Satan
ОС: Ubuntu 14.10 x64

Re: Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение ironcam »

SMplayer(мне именно он нужен, сабов нет)

Код: Выделить всё

iron_cam@ubuntu:~$ smplayer /home/iron_cam/Видео/Season6_Addons_BDrip_xVid/LOST.S06.Bloopers.BDRip.CEZAR.avi -sid 0 -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,
SMPlayer v. 0.6.9+SVN-r0UNKNOWN запущен в Linux


Mplayer(мне он НЕ нужен, но там сабы есть)

Код: Выделить всё

iron_cam@ubuntu:~$ mplayer /home/iron_cam/Видео/Season6_Addons_BDrip_xVid/LOST.S06.Bloopers.BDRip.CEZAR.avi -sid 0 -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,
MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/iron_cam/Видео/Season6_Addons_BDrip_xVid/LOST.S06.Bloopers.BDRip.CEZAR.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  720x400  12bpp  29.970 fps  1892.0 kbps (231.0 kbyte/s)
Load subtitles in /home/iron_cam/Видео/Season6_Addons_BDrip_xVid/
SUB: Added subtitle file (1): /home/iron_cam/Видео/Season6_Addons_BDrip_xVid/LOST.S06.Bloopers.BDRip.CEZAR.srt
==========================================================================
Forced video codec: ffmpeg12vdpau
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.80:1 - prescaling to correct movie aspect.
VO: [vdpau] 720x400 => 720x400 Planar YV12
A:   4.1 V:   4.1 A-V:  0.000 ct: -0.033 124/124  7%  7%  0.4% 1 0

Exiting... (Quit)
iron_cam@ubuntu:~$
вКонтакте
ОСь указана под аватаркой.
Вот скажите, я один такой? У меня всегда уникальные проблемы. Гугл о них ничего не знает, и другие линуксойды тоже...
Если проблемы решаются, только методом тыка...
Спасибо сказали:

Аватара пользователя
sspphheerraa
Сообщения: 1375
ОС: Gentoo

Re: Ubuntu+SMPlayer+vdpau=отсутствие субтитров

Сообщение sspphheerraa »

Открою тебе страшную тайну, SMPlayer всего лишь графическая морда к консольному MPlayer'у.
И когда ты запускаешь видео в SMPlayer'е, - на проигрывание запускается тот же MPlayer :)
Просто морда за тебя "дописывает" в консольную комманду разные опции.
По умолчанию она "дописывает" вот это:

Код: Выделить всё

$ mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 50331989 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles ~/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 50 -nocache -osdlevel 0 -vf-add screenshot -slices -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 Video.avi


Если с "чистым" mplayer'ом у тебя сабы показываются, а с теми опциями, что дописывает SMPlayer - нет, значит проблема где-то в них. Проверяй кодировку, шрифт (и поддерживает ли сам шрифт эту кодировку), начертания...etc
Для начала можешь попробовать просто удалить ~/.config/smplayer
Sspphheerraa
Спасибо сказали: