Java-complete

и другие vi-подобные редакторы

Модератор: /dev/random

Аватара пользователя
UnixNoob
Сообщения: 210
ОС: Slackware

Java-complete

Сообщение UnixNoob »

Привет. В силу маленького опыта не могу разобраться, почему плагин не хочет работать.
Сам плагин находится вот здесь.
В .vimrc добаавлено следующее:

Код: Выделить всё

filetype plugin indent on

autocmd FileType java setlocal omnifunc=javacomplete#Complete
Он или ругается на неопределенные переменные или на другой машине никак не реагирует на плагин.
У меня единственная идея что требования к JDK жесткие, т.е нужна конкретная 8я версия,это так? Или проблема в другом?
Не могу понять хотя бы в каком направлении смотреть.

upd. Кажется понял, ему нужна поддержка Python3 у Vim.
Спасибо сказали: