vim, проблема с ruby (Vi не проходит проверку на has("ruby"))

и другие vi-подобные редакторы

Модератор: /dev/random

petrushka_sch2
Сообщения: 252
ОС: Mandriva 2007.1

vim, проблема с ruby

Сообщение petrushka_sch2 »

[petrushka@localhost ~]$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i586-linux]
[petrushka@localhost ~]$ echo $PATH
/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt4/bin:/home/petrushka/bin
[petrushka@localhost ~]$ whereis ruby
ruby: /usr/bin/ruby /usr/lib/ruby
[petrushka@localhost ~]$ vim --v
VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Mar 4 2009 18:01:01)

Установлен gem vim-ruby.

При попытке выполнить
:echo has("ruby")
Ответ: 0

Есть несколько плагинов, у которых стоит проверка
if has("ruby")
И, соответственно, они не работают.

Подскажите, пожалуйста, куда копать. Что именно сделать с vim, ruby или ещё чем-то, чтобы решить вопрос?
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 5105
ОС: Gentoo

Re: vim, проблема с ruby

Сообщение /dev/random »

Полагаю, он должен быть _скомпилирован_ с поддержкой ruby.
Спасибо сказали:

petrushka_sch2
Сообщения: 252
ОС: Mandriva 2007.1

Re: vim, проблема с ruby

Сообщение petrushka_sch2 »

/dev/random писал(а):
13.08.2009 12:55
Полагаю, он должен быть _скомпилирован_ с поддержкой ruby.


А как понять скомпилирован ли он с поддержкой ruby?

И ещё вопрос: существует ли способ отличный от пересборки добавить поддержку ruby?
Спасибо сказали:

Аватара пользователя
Atragor
Сообщения: 681
Статус: ...

Re: vim, проблема с ruby

Сообщение Atragor »

vim --version, в списке Features included должно быть +ruby.
If you were MEANT to understand it, we wouldn't have called it 'code' © bash.org
Спасибо сказали:

petrushka_sch2
Сообщения: 252
ОС: Mandriva 2007.1

Re: vim, проблема с ruby

Сообщение petrushka_sch2 »

[root@localhost ~]# vim --version | grep ruby
+printer +profile +python +quickfix +reltime +rightleft -ruby +scrollbind

Есть ли способ без пересборки?
А то бинарный дистрибутив (Mandriva 2009.1), из сорцов не очень удобно
Спасибо сказали:

Аватара пользователя
Atragor
Сообщения: 681
Статус: ...

Re: vim, проблема с ruby

Сообщение Atragor »

В Mandriva вроде есть vim-enhanced, с поддержкой Python, Perl и Ruby, попробуйте его поставить.
If you were MEANT to understand it, we wouldn't have called it 'code' © bash.org
Спасибо сказали:

petrushka_sch2
Сообщения: 252
ОС: Mandriva 2007.1

Re: vim, проблема с ruby

Сообщение petrushka_sch2 »

В том-то и проблема
[root@localhost bombila]# vim-enhanced --version | grep rub
+printer +profile +python +quickfix +reltime +rightleft -ruby +scrollbind
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 5105
ОС: Gentoo

Re: vim, проблема с ruby

Сообщение /dev/random »

Либо пересборка, либо долгий и упорный поиск неофициального пакета с поддержкой ruby.
Спасибо сказали: