Не работает расширение LanguageTool для LibreOffice

Модератор: /dev/random

MiK13
Сообщения: 956
ОС: Linux Debian

Не работает расширение LanguageTool для LibreOffice

Сообщение MiK13 »

На одном телеграм-канале, связанном с русским языком, увидел сообщение
У меня сейчас Linux стоит. Там Либре-офис. Поставила расширение к этому офису. Оно проверяет стилистику, пунктуацию и всякое такое. Мощное приложение. Я как глянула, что мне там наподчёркивали...
Заинтересовался. Спросил, что за приложение. Ответила, что LanguageTool.
Нашёл. Попробовал поставить. Через Сервис -> Управление расширениями... Ctrl+Alt+E
С первого раза поставить не получилось -- не было места на /home. Освободил. Запустил установку ещё раз.
Смутило, что при установке прогресс-бар довольно долго был очень коротким. А потом, вдруг, всё установилось.
В меню Сервис появился пункт Грамматика - LangusgeTool с подпунктами:
Проверка грамматики F7
Перепроверить документ
Выключить/включить
Конфигурация
О программе LangageTool

Решил проверить на контроль запятых. Набрал фразу
Сейчас светло то есть день и я там где светит солнце.
И никакой реакции. То есть никаких предупреждений про отсутствующие запятые нет.
Хотя в настройках в группе "Пунктуация" отмечены пункты Запятая перед «то есть» и Запятая перед союзом «где»
Орфография по-прежнему проверяется.
В чём может быть проблема?
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Не работает расширение LanguageTool для LibreOffice

Сообщение Bizdelnick »

Так F7-то нажали?
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

gabix
Сообщения: 337
ОС: openSUSE Leap 15.1

Re: Не работает расширение LanguageTool для LibreOffice

Сообщение gabix »

F7 жать не обязательно, поскольку LT работает и в автоматическом режиме, с синеньким подчёркиванием.

Для начала убедитесь, что в Сервис → Параметры → Настройки языка → Лингвистика → Доступные языковые модули, во-первых, есть LT и, во-вторых, стоит соответствующая отметка.

P. S. Проверил предложенную фразу в LO 7.0 beta 2 / LT 4.8. Проверка производится, но вылавливается только первая из пропущенных запятых.
Спасибо сказали:

MiK13
Сообщения: 956
ОС: Linux Debian

Re: Не работает расширение LanguageTool для LibreOffice

Сообщение MiK13 »

gabix писал:
25.06.2020 21:17
Для начала убедитесь, что в Сервис → Параметры → Настройки языка → Лингвистика → Доступные языковые модули, во-первых, есть LT и, во-вторых, стоит соответствующая отметка.
Проверил. Всё есть. И на работе не раз смотрел -- всё стояло.
Но вот пришёл домой, поставил этот расширение -- стало подчёркивать "неправильные места".
В приведённой выше фразе предложило поставить запятую только после "светло"
После "Пожалуйста" тоже предложило поставить запятую. А вот перед "где" не предлагает.
Может быть у меня на работе в Stretch какие-то более серьёзные проблемы, которых нет дома в Buster...
gabix писал:
25.06.2020 21:17
P. S. Проверил предложенную фразу в LO 7.0 beta 2 / LT 4.8. Проверка производится, но вылавливается только первая из пропущенных запятых.
У меня дома аналогично. Перед "то есть" предлагает запятую, после "Пожалуйста". А вот перед "где" не предлагает. Хотя в настройках соответствующие "птички" стоят.

P.S. Что нового в LO 7.0? Стоит ли его пробовать?
И почему-то на сервере, откуда я обычно ставлю пакеты есть только в разделе /pub/tdf/libreoffice/testing/7.0.0/deb/x86_64/ файлы LibreOfficeDev_7.0.0.0.beta1_Linux_x86-64*. 32-битной версии вообще нет.
Спасибо сказали:

gabix
Сообщения: 337
ОС: openSUSE Leap 15.1

Re: Не работает расширение LanguageTool для LibreOffice

Сообщение gabix »

Так, вроде, 32-разрядные сборки где-то в районе 6.0.4 исчезли. Только если мейнтейнеры какого-нибудь дистрибутива озаботятся.
Спасибо сказали:

MiK13
Сообщения: 956
ОС: Linux Debian

Re: Не работает расширение LanguageTool для LibreOffice

Сообщение MiK13 »

gabix писал:
25.06.2020 22:43
Так, вроде, 32-разрядные сборки где-то в районе 6.0.4 исчезли. Только если мейнтейнеры какого-нибудь дистрибутива озаботятся.
Посмотрел на белорусском сервере.
Каталог /pub/tdf/libreoffice/stable/6.3.6/deb/x86/ пустой. /pub/tdf/libreoffice/stable/6.4.4/deb/x86/ тоже. Для rpm аналогично.
Но я когда-то скачивал LibreOffice_6.2.5_Linux_* как x86, так и x86-64.
В каталоге /pub/tdf/libreoffice/testing/7.0.0/win/x86/ полный набор файлов *.msi.
Правда думаю, что мне уже и не понадобится 32-битная версия LO
Спасибо сказали: