[Решено] Jessie. Перестало выставляться разрешение 1920х1080 при загрузке

Knoppix

Модераторы: Warderer, Модераторы разделов

VasVovec
Сообщения: 121
ОС: Debian Jessie/Sid [amd64]

[Решено] Jessie. Перестало выставляться разрешение 1920х1080 при загрузке

Сообщение VasVovec » 16.04.2018 12:22

Приветствую.
Видеокарта у меня встроенная (intel).
После сегодняшнего нештатного выключения системы (отключили свет) при загрузке перестало выставляться нормальное разрешение экрана, начиная с консоли. Т.е. раньше в процессе загрузки еще в консоли разрешение устанавливалось в 1920х1080. Т.е. у меня проблема не в иксах, а на более ранней(низкоуровневой) стадии. В KDE теперь тоже показывает максимально возможное разрешение 1024х768.
Сначало подозрение пало на незапуск KMS. Т.к. в логах иксов нет строки подобной:

Код: Выделить всё

intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
P.S. Почему-то у меня не получается мой файл Xorg.0.log приложить.

С другой стороны в этой статье http://tdkare.ru/sysadmin/index.php/Intel_82845G прочитал, что

Код: Выделить всё

# dmesg | grep drm | grep fb0     - проверка разрешения KMS в ядре для видеокарты
    fb0: inteldrmfb frame buffer device        - наличие это строки подтверждает что KMS загружен
У меня выдает:

Код: Выделить всё

$ dmesg | grep drm | grep fb0
[    9.329293] fbcon: inteldrmfb (fb0) is primary device
[    9.366112] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Т.е. тут показывает, что у меня KMS загружен?

Переустановка пакета xserver-xorg-video-intel не помогла.

1. В каком порядке производить диагностику причины проблемы?
2. Какие нужно выполнить шаги для исправления?

P.P.S. Чтение данного очень интересного мануала KMS UXA DRM OMG WTF BBQ?https://keyj.emphy.de/files/linuxgraphics_en.pdf тоже не прояснило для меня картины.
Последний раз редактировалось VasVovec 16.04.2018 20:37, всего редактировалось 1 раз.
Спасибо сказали:

VasVovec
Сообщения: 121
ОС: Debian Jessie/Sid [amd64]

Re: Jessie. Перестало выставляться разрешение 1920х1080 при загрузке

Сообщение VasVovec » 16.04.2018 20:36

Вопрос снимается. Отгадка оказалась простой, но странной.
Проблема была вызвана тем, что до вчерашнего отключения электричества коллега взял VGA-кабель от моего компьютера на тест другого компьютера(выключив питание моего монитора, но не выключая компьютер), а мне после теста поставил другой VGA-шный кабель. Видимо этот другой кабель оказался каким-то неполноценным. Но его неполноценность сказывается только после загрузки компьютера с ним. Когда я после теста коллеги вернулся за свой компьютер - все работало нормально. А потом было отключение электричества, загрузка компьютера с новым ущербным кабелем и целый день гугления и ломания головы.
После того, как я вспомнил об этом тесте, позвонил коллеге и узнал у него о такой подмене, я поставил другой VGA-кабель, и неполадка с недостаточным разрешением исчезла.
Спасибо сказали: