Не могу установить notepadqq на raspbian

Для новичков как вообще в Linux, так и в конкретной теме, к которой относится вопрос.

Модератор: Bizdelnick

azsx
Сообщения: 3642
ОС: calculate linux, debian, ubuntu

Не могу установить notepadqq на raspbian

Сообщение azsx »

Попробовал на raspbian установить notepadqq через snap. Очень долго запускался, потом сломались права к файлам и как то это совсем не то, что я хотел. Хочу скомпилировать notepadqq на raspbian. Вроде уже всё установил. Всё равно не может найти библиотеки:
Qt5WebEngine
Qt5WebEngineWidgets

Shell

./configure --prefix /usr --qmake /usr/lib/arm-linux-gnueabihf/qt5/bin/qmake
checking for QT5 qmake... /usr/lib/arm-linux-gnueabihf/qt5/bin/qmake
checking for lrelease... /usr/bin/qtchooser -run-tool=lrelease -qt=5
checking for c++... /usr/bin/c++
checking whether c++ compiler builds test program... ok
checking whether c++ compiler supports -std=c++0x... ok
checking whether compiled test program works... ok
checking for make... /usr/bin/make
checking for pkg-config... /usr/bin/pkg-config
checking for Qt5Core library... -lQt5Core
checking for Qt5Gui library... -lQt5Gui -lQt5Core
checking for Qt5Network library... -lQt5Network -lQt5Core
checking for Qt5WebEngine library... not found!
checking for Qt5Widgets library... -lQt5Widgets -lQt5Gui -lQt5Core
checking for Qt5WebEngineWidgets library... not found!
checking for Qt5PrintSupport library... -lQt5PrintSupport -lQt5Widgets -lQt5Gui -lQt5Core
checking for Qt5Svg library... -lQt5Svg -lQt5Widgets -lQt5Gui -lQt5Core
checking for Qt5WebSockets library... -lQt5WebSockets -lQt5Network -lQt5Core
checking for Qt5WebChannel library... -lQt5WebChannel -lQt5Qml -lQt5Network -lQt5Core
checking for uchardet library... -luchardet
generate Makefile... Info: creating stash file /home/pi/notepadqq/.qmake.stash
done
Делаю по инструкции:
https://www.linuxbabe.com/desktop-linux/compile-notepadqq-debian-ubuntu-raspbian
Вопрос.
Как установить эти библиотеки? Вроде уже поставил всё, что мог.
Спасибо сказали:

Аватара пользователя
ormorph
Сообщения: 1770
ОС: Gentoo

Re: Не могу установить notepadqq на raspbian

Сообщение ormorph »

Команда:

Shell

$ apt search qtwebengine
Ни чего не выводит?
Добавлено (18:32):
Посмотрел, тут довольно грустно все на raspberrypi os. Смотрю тем кому надо сами собирают qtwebengine. Как вариант можно попробовать собрать более старую версию notepadqq, так как libqt5webkit5 устарел, они перешли на qtwebengine. В какой-нибудь да соберётся.
Добавлено (19:07):
Если интересует я конечно могу сделать образ моей сборки Genpi64 с пульсой и выложить, там у меня уже присутствует собранный qtcreator с qtwebengine, правда для сборки dev-qt/qtwebsockets, пришлось сделать и добавить патч в autopath, для сборки gcc-11. Но это пару дней придётся подождать. Но я так понял Gentoo на rpi4 вас не интересует.
Спасибо сказали: