Amarok нет звука (Phonon не распаралеливает звук)

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Amarok нет звука

Сообщение Archangel »

Заметил, что звук выводиться только в одно из приложений. Амарок вообще звук не выдает, audacious падает часто. Запустил Амарок из консоли, а там пишут:

Код: Выделить всё

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
phonon-xine does not support splitting of audio or video streams into multiple outputs. The sink node is already connected to AudioDataOutput(0xb06350)
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
amarok(18172)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(18172)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(18172)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
QWidget::insertAction: Attempt to insert null action
amarok(18172)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter

Как починить phonon? Почему он не поддерживает параллельный звук?
Спасибо сказали:

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Re: Amarok нет звука

Сообщение Archangel »

Решил, сменой xine на gstreamer и установкой пакетов к gstreamer.
Спасибо сказали: