Не работает ТАП на тачпаде (после обновления X-сервера перестало работать)

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Не работает ТАП на тачпаде

Сообщение Archangel »

Обновил X-сервер и теперь не могу заставить работать ТАП на тачпаде. Пробовал и через 11-x11-synaptics.fdi и через cd /etc/X11/xorg.conf.d/10-synaptics.conf.

Код: Выделить всё

bash-4.2$ synclient -l
Parameter settings:
    LeftEdge                = 1748
    RightEdge               = 5640
    TopEdge                 = 1274
    BottomEdge              = 4752
    FingerLow               = 24
    FingerHigh              = 29
    FingerPress             = 255
    MaxTapTime              = 1
    MaxTapMove              = 29
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 1
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 280
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 100
    HorizScrollDelta        = 100
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 1
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.00995223
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 29
    EdgeMotionMaxZ          = 159
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 401
    EdgeMotionUseAlways     = 0
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 0
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 2
    TapButton3              = 3
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 1
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 2
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 199
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 29
    PressureMotionMaxZ      = 159
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 0
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 25
    VertHysteresis          = 25
    ClickPad                = 0

Synclient вроде говорит, что тап работает, судя по опции "TapButton1 = 1", а на деле - не хочет.
Спасибо сказали:

Аватара пользователя
bormant
Сообщения: 1337

Re: Не работает ТАП на тачпаде

Сообщение bormant »

Нет ли чего странного в /var/log/Xorg.0.log, например сообщений о выборе другого драйвера вместо synaptics, или чего-то иного из ряда вон?
Вот там http://www.linuxquestions.org/questions/sl...ics-4175482618/ тоже пишут про проблемы, но там synclient -l говорит об отсутствующем драйвере, так что , скорее всего, проблемы другого рода.

В 14.0 избавились от HAL
("slackware-14.0/CHANGES_AND_HINTS.TXT") писал(а):l/hal-info - obsolete; replaced by various udev components
l/hal - obsolete; replaced by upower, udisks, various others
если не принесли со стороны, *.fdi вряд ли способен на что-то повлиять.
Спасибо сказали:

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Re: Не работает ТАП на тачпаде

Сообщение Archangel »

В логе видно вот такое:

Код: Выделить всё

[  1137.075] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  1137.098] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input7/event7"
[  1137.098] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[  1137.098] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  1137.098] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[  1137.098] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.010
[  1137.098] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  1137.098] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  1137.099] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  1137.099] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  1137.099] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  1137.099] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  1137.099] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[  1137.099] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  1137.100] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  1137.100] (**) Option "Device" "/dev/input/mouse0"
[  1137.115] (EE) synaptics: SynPS/2 Synaptics TouchPad: Synaptics driver unable to detect protocol
[  1137.115] (EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"
[  1137.115] (II) UnloadModule: "synaptics"
Спасибо сказали: