Новый skype -4.3 на системе x64 c multilib (Как его заставить работать)

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Новый skype -4.3 на системе x64 c multilib

Сообщение Archangel »

Обновил систему неглядя(каюсь). Теперь этот жуткий скайп не хочет работать без установленного pulse-audio. Раньше прекрасно без него жил и все было в шоколаде. Ладно, попробовал поставить этот pulse - стал получать ошибку:

Код: Выделить всё

/usr/lib/libX11-xcb.so: could not read symbols: File in wrong format

Эту беду вылечил, как Боб велел:
I have problems compiling with my unofficial and unsupported multilib setup.
If you are using multilib packages from somewhere and also have some 32bit packages installed, then you might run into problems with the build process trying to link 32bit libraries instead of 64bit libraries. If this occurs, it can probably be solved by placing the following line:
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
after the lines for CFLAGS and CXXFLAGS passed to the configure script. In other words, make it look something like this:
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
./configure \
Beyond that, you are on your own. This is an unsupported setup.

Теперь сборка вываливается с руганью:

Код: Выделить всё

checking build system type... Invalid configuration `make': machine `make' not recognized
configure: error: /bin/sh build-aux/config.sub make failed

Как его победить? Скайп без звука - не прикольно.
Спасибо сказали:

Аватара пользователя
bormant
Сообщения: 1337

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение bormant »

Откатиться на старый скайп не вариант?
Если что, см. http://slackware.org.uk/slacky/slackware64...tatic/4.2.0.13/

PS. Приведенный выше вариант лечения -- это для другого случая, чтобы 64-битная сборка не пыталась использовать 32-битные библиотеки.
PPS. Скайп 32-разрядный (или я что-то пропустил), захочет 32-разрядные библиотеки pulse-audio. Проще собирать в 32-разрядной системе (в отдельной установке на железе или в ВМ) и преобразовать в compat32. Вот только зависимости пульсы позволят ли иметь ее в 32-битном варианте на 64-битной системе, тот ещё вопрос...
Спасибо сказали:

Аватара пользователя
eddy
Сообщения: 3321
Статус: Красный глаз тролля
ОС: ArchLinux

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение eddy »

А ему разве не требуется пульса? А то что-то я слышал, что на новые версии скайпа уже можно забить, т.к. их просто невозможно использовать (они без пульсы не работают).
RTFM
-------
KOI8-R - патриотичная кодировка Изображение
Спасибо сказали:

Аватара пользователя
Archangel
Сообщения: 431
ОС: Slackware64-14.1

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение Archangel »

Ну в том-то и проблема, что не могу собрать пульсу для нового скайпа. А без нее новый скайп разговаривать не умеет.
Спасибо сказали:

Аватара пользователя
bormant
Сообщения: 1337

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение bormant »

Похоже, решение найдено:
http://www.linuxquestions.org/questions/sl...tml#post5213511
Спасибо сказали:

Аватара пользователя
yars
Сообщения: 1144
Статус: Slacker!
ОС: Slackware64-current

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение yars »

bormant писал(а):
14.07.2014 09:58
Если что, см. http://slackware.org.uk/slacky/slackware64...tatic/4.2.0.13/

Так старые версии же вроде все, того -- не подключаются.
Slackware64-current/Xfce 4.12/Acer TravelMate 5760
-------------
Registered Linux User #557010
Спасибо сказали:

Аватара пользователя
eddy
Сообщения: 3321
Статус: Красный глаз тролля
ОС: ArchLinux

Re: Новый skype -4.3 на системе x64 c multilib

Сообщение eddy »

Очень даже подключаются. Когда перестанут — придется забить на эту поделку. Лучше не пользоваться скайпом, чем в систему всякое говно вроде pulseaudio тащить!
RTFM
-------
KOI8-R - патриотичная кодировка Изображение
Спасибо сказали: