Можно ли установить make версии 3.79?

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

Аватара пользователя
жучара
Сообщения: 663
ОС: астралинукс

Можно ли установить make версии 3.79?

Сообщение жучара »

Друзья! Командую:

Код: Выделить всё

make --version
GNU make 3.82

А нужно установить версию 3.79. Возможно ли это? Необходимо по таким причинам: во-первых, прочесть эту книжку:
Программа управления компиляцией GNU make Версия 3.79
А во-вторых, ради интереса. Я ведь радоваться буду как ребёнок если ЧТО-НИБУДЬ установлю стороннее из интернета. Это нетрудно, наверное, да ведь? Нашёл где-нибудь, скачал, ткнул install-> next-> next... Гм. В общем, как-то так должно быть. Спасибо, кто откликнется.
Я просто читаю маны.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18650
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Можно ли установить make версии 3.79?

Сообщение Bizdelnick »

Чем небольшое отличие версии мешает читать книжку? Версия 3.82 умеет всё то же, что и 3.79 (может быть, чуть больше, хотя сомневаюсь).

жучара писал(а):
01.05.2017 23:12
Я ведь радоваться буду как ребёнок если ЧТО-НИБУДЬ установлю стороннее из интернета. Это нетрудно, наверное, да ведь? Нашёл где-нибудь, скачал, ткнул install-> next-> next...

Это нетрудно, но нет, совсем не так. Если очень хочется, скачайте исходники и соберите, но не устанавливайте.

Код: Выделить всё

wget -O - https://ftp.gnu.org/gnu/make/make-3.79.1.tar.gz | tar -xzf -
cd make-3.79.1
./configure
make
./make -v
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
yars
Сообщения: 1144
Статус: Slacker!
ОС: Slackware64-current

Re: Можно ли установить make версии 3.79?

Сообщение yars »

жучара писал(а):
01.05.2017 23:12
Нашёл где-нибудь, скачал, ткнул install-> next-> next...

Это не наш метод :) Возьмите в каталоге source/d/make дерева каталогов дистрибутива, например, с DVD или с FTP слакбилд make.SlackBuild и slack-desc, а сам исходник make и цифровую подпись возьмите отсюда. Поправьте слакбилд, изменив опции configure, указывающие на /usr, на /usr/local и добавив перед ней --program-transform-name=make-$VERSION,соберите пакет с помощью этого слакбилда: # VERSION=3.79 ./*Build, далее установите пакет обычным образом и вызывайте по имени make-3.79. Но вариант Bizdelnick-а проще :)
Slackware64-current/Xfce 4.12/Acer TravelMate 5760
-------------
Registered Linux User #557010
Спасибо сказали:

Аватара пользователя
жучара
Сообщения: 663
ОС: астралинукс

Re: Можно ли установить make версии 3.79?

Сообщение жучара »

Я глупость сделал, мне нужно было установить Slackware 8.1 там есть make-3.79.1-i386-1.tgz, железо у меня старое, авось потянуло бы. Но как бы то ни было:

Bizdelnick а дальше что делать? Я так понимаю, команда installpkg мне не поможет теперь, ибо ей нужен файл *.txz

Так, а я вот определил такие пакеты, которые у меня установлены

Код: Выделить всё

www@qqq:~/make-3.79.1$ ls /var/log/packages | grep make
automake-1.11.5-noarch-1
cmake-2.8.12-i486-1
gccmakedep-1.0.2-noarch-2
imake-1.0.5-i486-1
make-3.82-i486-4
makedepend-1.0.4-i486-1
pmake-1.111-i486-4
windowmaker-0.95.5-i486-1
www@qqq:~/make-3.79.1$


То есть мне сначала нужно убрать пакет make-3.82-i486-4, а потом устанавливать make-3.79.1, так? Я думаю, что я сумею нажать на OK, выбрав нужный пункт в pkgtool -> remove; за результат не ручаюсь, правда. Пробовать удалять? Я почему не могу сам попробовать- сейчас удалю, к примеру make-3.82-i486-4, ОШИБОЧНО, потом буду два дня его восстанавливать...

Я просто читаю маны.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18650
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Можно ли установить make версии 3.79?

Сообщение Bizdelnick »

жучара писал(а):
02.05.2017 18:46
а дальше что делать?

Ничего. Использовать, если очень хочется, а если не очень — удалить.

жучара писал(а):
02.05.2017 18:46
То есть мне сначала нужно убрать пакет make-3.82-i486-4, а потом устанавливать make-3.79.1, так?

Не советую. Если будете действовать без понимания процесса, закончите тем, что вообще ничего установить в системе будет нельзя. Если точно знаете, что Вам нужен установленный 3.71, делайте так, как посоветовал yars. Но я не понимаю, зачем.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали: