ATI не ставятся

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

severenok
Сообщения: 2

ATI не ставятся

Сообщение severenok »

Здравствуйте !
От этого вопроса наверно всех тошнит уже, но я не как не могу установить ATI драйвера на слаку 9.0 ! Моя видюха АТИ 9200СЕ !
Качаю драйвер с ати.ком, потом преобразую его rpm2tgz->installpkg->cd lib/modules/fglrx/build
-> make.sh
Тут у меня вылетают ошибки!

ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
agpgart_be.c: In function `agp_find_supported_device':
agpgart_be.c:6526: warning: unused variable `cap_ptr'
agpgart_be.c: At top level:
agpgart_be.c:6507: warning: `agp_check_supported_device' defined but not used
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
firegl_public.c:207:1: warning: "pte_unmap" redefined
firegl_public.c:140:1: warning: this is the location of the previous definition
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================

->cd ..
->make_install.sh

- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o
- trying a sample load of the kernel module
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol mtrr_add
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol mtrr_del
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

Опять ошибки !!!!

->fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

Помогите по братски, я просто не знаю уже где копать !
Спасибо сказали:

Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: ATI не ставятся

Сообщение sash-kan »

(severenok @ Понедельник, 06 Июня 2005, 21:49) писал(а):and then call ./make_install.sh in order to install the built module.


(severenok @ Понедельник, 06 Июня 2005, 21:49) писал(а):->make_install.sh

может быть, все-таки
./make_install.sh
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:

severenok
Сообщения: 2

Re: ATI не ставятся

Сообщение severenok »

Извените но я ети скрипты правильно запускаю
./make.sh
./make_install.sh
просто записал в сообщении не так ак нужно !
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

версия XFree какая ?
и какой версии драйвер взят ?
без иксов устанавливаете ?
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

у меня другая проблема(Slackware 10.0) с видюхой ATI Radeon 9000 mobility
скачал дрова fglrx_6_8_0-8.12.10-1.i386.rpm, патч к ним fglrx-8.12.10-2_6_11.patch....
rpm2tgz->installpkg
make.sh и make_install.sh делают своё дело, вроде всё устанавливается...
конфигурирую....
но иксы не загружаются выдавая десяток строк вида:
Simbol <имя> in <путь к модулю> is unresolved
вот такая проблемма, в нете ничего не нашел по этому поводу...
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
Marduk
Сообщения: 247

Re: ATI не ставятся

Сообщение Marduk »

(severenok @ Понедельник, 06 Июня 2005, 21:49) писал(а):/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

Очень может быть ядро скомпилировано с CONFIG_DRM_RADEON=y, тогда придется перекомпилить его с CONFIG_DRM_RADEON=m, ведь установщик драйвера должен выгрузить старый drm-драйвер...
Уже обсуждали установку драйвера на ATI здесь: http://lafox.net/support/index.php?showtopic=4118 и здесь: http://lafox.net/support/index.php?showtopic=4354
Там и пару полезных ссылок есть.
[ Arch Linux || xmonad || dzen2 ]
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

(Marduk @ Среда, 08 Июня 2005, 9:15) писал(а):
(severenok @ Понедельник, 06 Июня 2005, 21:49) писал(а):/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

Очень может быть ядро скомпилировано с CONFIG_DRM_RADEON=y, тогда придется перекомпилить его с CONFIG_DRM_RADEON=m, ведь установщик драйвера должен выгрузить старый drm-драйвер...
Уже обсуждали установку драйвера на ATI здесь: http://lafox.net/support/index.php?showtopic=4118 и здесь: http://lafox.net/support/index.php?showtopic=4354
Там и пару полезных ссылок есть.


:thumbsup: однозначно ,спасибо ,как раз искал эти ссылки
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

а с моей проблемой что можно сделать???
или мне можно забыть про 3д в линухе???
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: ATI не ставятся

Сообщение sash-kan »

(silverstranger @ Четверг, 09 Июня 2005, 21:24) писал(а):а с моей проблемой что можно сделать???
или мне можно забыть про 3д в линухе???

можешь смело писать в техподдержку ati
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:

Аватара пользователя
clx
Сообщения: 3121
Статус: Think Different !
ОС: Mac OS X

Re: ATI не ставятся

Сообщение clx »

(Sash Kan @ Пятница, 10 Июня 2005, 9:58) писал(а):
(silverstranger @ Четверг, 09 Июня 2005, 21:24) писал(а):а с моей проблемой что можно сделать???
или мне можно забыть про 3д в линухе???

можешь смело писать в техподдержку ati



А это зачем ? 3Д с АТи в Линухе работает, стоит лишь настроить.
iMac 20" Core Duo.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

(clx @ Пятница, 10 Июня 2005, 11:57) писал(а):А это зачем ? 3Д с АТи в Линухе работает, стоит лишь настроить.

меня соственно и интересует как настроить..... точнее что я делаю не так...
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
clx
Сообщения: 3121
Статус: Think Different !
ОС: Mac OS X

Re: ATI не ставятся

Сообщение clx »

(silverstranger @ Пятница, 10 Июня 2005, 14:24) писал(а):
(clx @ Пятница, 10 Июня 2005, 11:57) писал(а):А это зачем ? 3Д с АТи в Линухе работает, стоит лишь настроить.

меня соственно и интересует как настроить..... точнее что я делаю не так...



Попробуй поискать в поиске, т.к это оч много раз обсуждалось, в частности установку на Slackware.
iMac 20" Core Duo.
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

(silverstranger @ Пятница, 10 Июня 2005, 10:24) писал(а):
(clx @ Пятница, 10 Июня 2005, 11:57) писал(а):А это зачем ? 3Д с АТи в Линухе работает, стоит лишь настроить.

меня соственно и интересует как настроить..... точнее что я делаю не так...


просто для начала опубликуй конфиг иксов здесь ,может что придумаем .
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

скачал последние (8.14.13) дрова...
трабла остается...
конфиг -

лог иксов -
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

у вас написанно :
X Protocol Version 11, Revision 0, Release 6.7


тут - http://www2.ati.com/drivers/linux/linux_8.14.13.html написанно :

Minimum System Requirements
X.org 6.8
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

(wolf_black @ Пятница, 10 Июня 2005, 18:14) писал(а):у вас написанно :
X Protocol Version 11, Revision 0, Release 6.7


тут - http://www2.ati.com/drivers/linux/linux_8.14.13.html  написанно :

Minimum System Requirements
X.org 6.8


я это уже понял....только для X.org 6.7 их на сайте нету....
что тогда делать???иксы обновлять???
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

да обновить иксы , с www.linuxpackages.net
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали:

Аватара пользователя
silverstranger
Сообщения: 37

Re: ATI не ставятся

Сообщение silverstranger »

(wolf_black @ Пятница, 10 Июня 2005, 19:39) писал(а):да обновить иксы , с www.linuxpackages.net

спасибо, после обновления иксов всё заработало :D
кто силён умом тот, как правило молчит...
Спасибо сказали:

Аватара пользователя
zenwolf
Бывший модератор
Сообщения: 3138
Статус: Страшный и злой
ОС: Slackware..Salix..x86_64

Re: ATI не ставятся

Сообщение zenwolf »

(silverstranger @ Суббота, 11 Июня 2005, 7:31) писал(а):
(wolf_black @ Пятница, 10 Июня 2005, 19:39) писал(а):да обновить иксы , с www.linuxpackages.net

спасибо, после обновления иксов всё заработало :D


вуаля ! ,мы за вас рады :)
Quae videmus quo dependet vultus. (лат) - То, что мы видим, зависит от того, куда мы смотрим.
Спасибо сказали: