Для OpenBSD 6.1 и 6.2 выпущенны Meltdown-пачти (ну наконец-то....)

FreeBSD, NetBSD, OpenBSD, DragonFly и т. д.

Модератор: arachnid

Аватара пользователя
Stauffenberg
Сообщения: 2017
Статус: ☮ PEACE ☮
ОС: открытая и свободная

Для OpenBSD 6.1 и 6.2 выпущенны Meltdown-пачти

Сообщение Stauffenberg » 01.03.2018 11:46

Errata patches for a speculative execution flaw in Intel CPUs have been
released for OpenBSD 6.2 and 6.1.

Intel CPUs contain a flaw called "Meltdown" which allows userspace programs
to access kernel memory.

Binary updates for the amd64 platform are available via the syspatch utility.
Source code patches can be found on the respective errata pages:


https://www.openbsd.org/errata61.html => https://ftp.openbsd.org/pub/OpenBSD/patches...tdown.patch.sig
https://www.openbsd.org/errata62.html => https://ftp.openbsd.org/pub/OpenBSD/patches...tdown.patch.sig

As these affect the kernel, a reboot will be needed after patching.
Labor omnia vincit

"Debugging is twice as hard as writing the code in the first place.
Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it.” (Brian Kernighan)
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14940
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Для OpenBSD 6.1 и 6.2 выпущенны Meltdown-пачти

Сообщение Bizdelnick » 01.03.2018 13:35

Я так понял, там по сути тот же KPTI? Ничего принципиально нового они не придумали?
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали: