Установка VSCode

Sabayon, Calculate, Funtoo, Exherbo

Модератор: /dev/random

gudzik
Сообщения: 3
ОС: Gentoo

Установка VSCode

Сообщение gudzik »

Привет.
Сразу скажу что в UNIX системах я полный нумб.
Недавно я стал обладателем Raspberry PI 4. После тестирования разных систем остановился на Gentoo, так как она оказалась наиболее стабильной, все остальные просто падали после некоторого времени использования.

Но тут я столкнулся с проблемами при установках стограмм.
Мне нужно установить VSCode. Его в репозиториях Gentoo нет, или я не нашел.
Решил ставить с помошью RPM. Загуглил несколько статей но конечного ответа так и не нашел...

Делаю я так:
Скачал файл с расширением rpm по 64 битную систему.
Захожу в папку со скачаным файлом и выполняю команду
rpm -i code-1.50.1-1602600714.el7.aarch64.rpm
или
rpm -Uvh code-1.50.1-1602600714.el7.aarch64.rpm

получаю ошыбку
error: Failed dependencies:
/bin/sh is needed by code-1.50.1-1602600714.el7.aarch64
libX11.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXcomposite.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXcursor.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXdamage.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXext.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXfixes.so.3()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXi.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXrandr.so.2()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXrender.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXss.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libXtst.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libasound.so.2()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libatk-1.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.11)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.2.5)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.3)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.3.2)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.3.4)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.4)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.6)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.7)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libc.so.6(GLIBC_2.9)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libcairo.so.2()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libcups.so.2()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libdbus-1.so.3()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libdl.so.2()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libexpat.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libfontconfig.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libfreetype.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgcc_s.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgcc_s.so.1(GCC_3.0)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgcc_s.so.1(GCC_4.0.0)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgdk-x11-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgdk_pixbuf-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgio-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libglib-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgmodule-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgobject-2.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libgtk-3.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libm.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libm.so.6(GLIBC_2.2.5)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libnspr4.so()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libnss3.so()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libnssutil3.so()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpango-1.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpangocairo-1.0.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpthread.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpthread.so.0(GLIBC_2.2.5)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpthread.so.0(GLIBC_2.3.2)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libpthread.so.0(GLIBC_2.3.3)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
librt.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libsecret-1.so.0()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libsmime3.so()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4.10)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4.11)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4.14)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4.15)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libstdc++.so.6(GLIBCXX_3.4.9)(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libxcb.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64
libxkbfile.so.1()(aarch64) is needed by code-1.50.1-1602600714.el7.aarch64

я понимаю что все модули должны быть установлены, но они вроде как бы есть в системе
в какалоге /bin есть @sh
в каталоге /usr/lib64 - @libX11.so.6
и так далее...

подскажите пожалуста, как мне все же установить VSCode?
Спасибо сказали:

Аватара пользователя
devilr
Сообщения: 3138
ОС: Mandriva => Gentoo (~amd64)

Re: Установка VSCode

Сообщение devilr »

app-editors/visual-studio-code
Не оно?
Мудрость приходит с возрастом.
Иногда возраст приходит один.
Спасибо сказали:

gudzik
Сообщения: 3
ОС: Gentoo

Re: Установка VSCode

Сообщение gudzik »

emerge --search app-editors/visual-studio-code

Local copy of remote index is up-to-date and will be used.

[ Results for search key : app-editors/visual-studio-code ]
Searching...

[ Applications found : 0 ]


вот что получилось...


или я что не так делаю??? :(
Спасибо сказали:

Аватара пользователя
devilr
Сообщения: 3138
ОС: Mandriva => Gentoo (~amd64)

Re: Установка VSCode

Сообщение devilr »

Ну, такой штуки среди стандартных и не будет. Оно в оверлее dotnet.
Мудрость приходит с возрастом.
Иногда возраст приходит один.
Спасибо сказали:

Аватара пользователя
ormorph
Сообщения: 1770
ОС: Gentoo

Re: Установка VSCode

Сообщение ormorph »

Официальной сборки VSCode под rpi4 не существует, однако есть свободная сборка code-oss - что одно и то же, делал ебилд для установки под gentoo для rpi4 тыц.
Spoiler
ИзображениеИзображение
Так же добавил ебилд с питоновскими играми которые присутствуют Raspberrypi OS по умолчанию тыц.
Как создать локальный оверлей тыц.
Спасибо сказали:

gudzik
Сообщения: 3
ОС: Gentoo

Re: Установка VSCode

Сообщение gudzik »

спасибочки, буду пробовать...
Спасибо сказали: