Помощь новичку с Gentoo (Вопросы различной тематики, возникающие по мере использования системы.)

Sabayon, Calculate, Funtoo, Exherbo

Модератор: /dev/random

Аватара пользователя
Brainsburn
Сообщения: 949
Статус: /
ОС: LFS,Gentoo

Re: Помощь новичку с Gentoo

Сообщение Brainsburn » 10.03.2012 13:36

Я кроме eselect locale set 576 ничего не делал :)
Спасибо сказали:

Аватара пользователя
Dreamer77
Сообщения: 202
ОС: Debian, openSUSE, Mac OS X

Re: Помощь новичку с Gentoo

Сообщение Dreamer77 » 17.03.2012 01:29

не только Кеды, но и иксы, и целиком перезагружал компьютер. Несколько раз проделывал (генерировал, перезагружал), но безрезультатно.
только Перекомпиляция glibc давала результат.

Подобная проблема была и в Арче месяц тому назад при установке кед 4.8.0. Тем не менее на прошлой версии КДЕ такого не наблюдалось.

В Генту такое поведение требовалось мне с самого начала (перешел на Генту когда КДЕ 4.3 было)
Ubuntu-->Debian-->Gentoo-->openSUSE-> Mac OS X
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 29.08.2012 00:25

Добрый вечер господа (и дамы).

Собственно говоря после установки возникла проблема - нет интернета. По видимости - не загружается драйвер устройства. (При ifconfig eth0 или eth1, (на компе два интерфейса, второй не используется), пишет что Device not found. Net-setup при установке естественно увидел оба) Сетевушка самая обычная Realtek RTL 8169/8110(не используемая - какая-то VIA).
Ядро собирал вручную, но там мне помнится стояли отмеченными нужные драйвера, но не суть, допустим я что-то попутал. Пытался пересобрать ядро как указано тут http://www.gentoo.org/doc/en/faq.xml#bootrescue. У меня архитектура x86-64, соответственно ядро должно было собраться в папку arch/x86-64/(как и было при первичной установке), но оно почему-то собирается в папку arch/x86/, это нормально? Что делать чтобы заработало? Может где еще рыть?
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 4891
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение /dev/random » 29.08.2012 00:41

В первую очередь попробуйте загрузиться с ядром, с которым вы загружались для установки (скопируйте в бинарном виде). Если поможет, значит, вы действительно что-то не то выключили при сборке ядра.
Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 872
ОС: gentoo

Re: Помощь новичку с Gentoo

Сообщение vr13 » 29.08.2012 01:32

Verb писал(а):
29.08.2012 00:25
arch/x86-64/(как и было при первичной установке), но оно почему-то собирается в папку arch/x86/, это нормально?

обратите внимание на это:

Код: Выделить всё

$ ls -l /usr/src/linux/arch/x86_64/boot/bzImage
lrwxrwxrwx 1 root root 22 Aug 28 06:15 /usr/src/linux/arch/x86_64/boot/bzImage -> ../../x86/boot/bzImage

помещается туда по причине того, что ядро - действительно является 32битным при начале загрузки:

Код: Выделить всё

$ file `readlink /usr/src/linux/arch/x86_64/boot/bzImage`
../../x86/boot/bzImage: Linux kernel x86 boot executable bzImage, version 3.4.9-gentoo (root@gentoo) #1 SMP Tue Aug 28 06:15:15 MSK 2012, RO-rootFS, swap_dev 0x1, Normal VGA

в 64битный режим оно переходит позже. еще детальнее - bzImage это маленький 32битный исполнимый модуль, запускаемый загрузчиком, к которому статически прицеплен runtime unzip (того типа, что вы выбрали в параметрах - gzip, xz), и далее сжатый этим самым zip elf /usr/src/linux/vmlinux - который уже настоящий 64-битный:

Код: Выделить всё

$ file /usr/src/linux/vmlinux
/usr/src/linux/vmlinux: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), statically linked, BuildID[sha1]=0x63bbcc5263361b67f9a0e9934ebc39c0d07d852b, not stripped

если интересно, почитайте в для начала простое описание, типа книжки understanding linux kernel (в приложении достаточно наглядно), а потом, через Documentation/x86/boot.txt, - исходные коды

а по существу вопроса, вам выше рассказали: нужно искать, что вы пропустили в конфигурации: обычно, путем копания в выводе lspci -vv, понимается точно название устройства, а потом - ищется соответствующий ему драйвер в конфигурации
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 29.08.2012 22:56

Благодарю откликнувшихся!
Пересобрал ядро и пошел дальше. Вобщем установил иксы и гном. Но когда захожу в иксы - все загружается но ни мышка ни клавиатура не работают. Не могу понять что делать.
Спасибо сказали:

Kopilov
Сообщения: 665
ОС: Gentoo, Debian

Re: Помощь новичку с Gentoo

Сообщение Kopilov » 29.08.2012 23:37

Пакет xf86-input-evdev стоит? Если нет -- поставь, а лучше -- задай параметр INPUT_DEVICES="evdev" в /etc/make.conf, сделай emerge -DN world -- должен подтянуться, как зависимость.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 29.08.2012 23:38

Verb писал(а):
29.08.2012 22:56
Благодарю откликнувшихся!
Пересобрал ядро и пошел дальше. Вобщем установил иксы и гном. Но когда захожу в иксы - все загружается но ни мышка ни клавиатура не работают. Не могу понять что делать.


Xorg.0.log

Код: Выделить всё

(WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(EE) [drm] No DRICreatePCIBusID symbol

Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 872
ОС: gentoo

Re: Помощь новичку с Gentoo

Сообщение vr13 » 29.08.2012 23:39

  • в ядре подключить evdev (drivers -> input devices). лучше - модулем
  • в /etc/make.conf установить INPUT_DEVICES=evdev
  • emerge -1 xorg-server
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 29.08.2012 23:42

Kopilov писал(а):
29.08.2012 23:37
Пакет xf86-input-evdev стоит? Если нет -- поставь, а лучше -- задай параметр INPUT_DEVICES="evdev" в /etc/make.conf, сделай emerge -DN world -- должен подтянуться, как зависимость.


Да стоит. В make.conf так все и прописано. :rolleyes:
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 00:03

vr13 писал(а):
29.08.2012 23:39
  • в ядре подключить evdev (drivers -> input devices). лучше - модулем


я вот глянул input devices support но ничего похоже на evdev не увидел.
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 4891
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение /dev/random » 30.08.2012 00:49

Verb писал(а):
30.08.2012 00:03
я вот глянул input devices support но ничего похоже на evdev не увидел.

"Event interface".

А вообще, если вы не уверены, что можете правильно собрать ядро с нуля, может, лучше воспользоваться genkernel? Там довольно универсальная дефолтная конфигурация.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 01:01

/dev/random писал(а):
30.08.2012 00:49
Verb писал(а):
30.08.2012 00:03
я вот глянул input devices support но ничего похоже на evdev не увидел.

"Event interface".

А вообще, если вы не уверены, что можете правильно собрать ядро с нуля, может, лучше воспользоваться genkernel? Там довольно универсальная дефолтная конфигурация.


не помучаешься не порадуешься. но вообще я какбудто скажем обтекаемо компьютерщик. так что полезно.

И да, ивэнт интерфейс отмечен по умолчанию. так что я пребываю в замешательстве незнаю куда смотреть.
Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 872
ОС: gentoo

Re: Помощь новичку с Gentoo

Сообщение vr13 » 30.08.2012 08:26

Verb писал(а):
30.08.2012 01:01
не помучаешься не порадуешься. но вообще я какбудто скажем обтекаемо компьютерщик. так что полезно.

безусловно полезно. в целях самообразования - особенно
И да, ивэнт интерфейс отмечен по умолчанию. так что я пребываю в замешательстве незнаю куда смотреть.

на самом деле, не много мест, где это видно:

1. убедиться что в ядре это действительно сконфигурировано - grep -i evdev /usr/src/linux/.config - должно ответить похожим на CONFIG_INPUT_EVDEV=m. модуль ядра evdev, если собрано как модуль, есть в памяти - lsmod|grep evdev

2. правила udev в /lib/udev/rules.d/60-persistent-input.rures, когда видят наличие клавиатуры и мыши, в /dev/input создают визуально понятную структуру того, что система "понимает" как устройства ввода, например:

Код: Выделить всё

ls -lR /dev/input
/dev/input:
total 0
drwxr-xr-x 2 root root     80 Aug 28 06:19 by-id
drwxr-xr-x 2 root root    100 Aug 28 06:19 by-path
crw-r----- 1 root root 13, 64 Aug 28 10:19 event0
crw-r----- 1 root root 13, 65 Aug 28 10:19 event1
crw-r----- 1 root root 13, 66 Aug 28 10:19 event2
crw-r----- 1 root root 13, 67 Aug 28 06:19 event3
crw-r----- 1 root root 13, 63 Aug 28 10:19 mice
crw-r----- 1 root root 13, 32 Aug 28 06:19 mouse0

/dev/input/by-id:
total 0
lrwxrwxrwx 1 root root 9 Aug 28 06:19 usb-Dell_Dell_USB_Optical_Mouse-event-mouse -> ../event3
lrwxrwxrwx 1 root root 9 Aug 28 06:19 usb-Dell_Dell_USB_Optical_Mouse-mouse -> ../mouse0

/dev/input/by-path:
total 0
lrwxrwxrwx 1 root root 9 Aug 28 06:19 pci-0000:00:1d.2-usb-0:2:1.0-event-mouse -> ../event3
lrwxrwxrwx 1 root root 9 Aug 28 06:19 pci-0000:00:1d.2-usb-0:2:1.0-mouse -> ../mouse0
lrwxrwxrwx 1 root root 9 Aug 28 10:19 platform-i8042-serio-0-event-kbd -> ../event0

в случае ноутбука (и поддержки ядром wmi оного) или наличии в системе другого поддерживаемого HID-оборудования, список будет больше

3. /var/log/Xorg.0.log подробно рассказывает что увиделось и/или добавилось в конфигурацию системы при старте Xorg - начиная примерно с этого места:

Код: Выделить всё

...
[    39.610] (II) config/udev: Adding input device...
...
[    39.671] (II) XINPUT: Adding extended input device...
...

тут же будут ошибки, если чего-то непонятно системе

вообще, тема "в x11 пропала клавиатура и мышь" в gentoo популярна, и популярность возрастает после обновления версии Xorg. стандартный совет - пересобрать драйверы xorg как-то так: emerge -1 `eix -I x11-drivers/`
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 11:25

vr13 писал(а):
30.08.2012 08:26
на самом деле, не много мест, где это видно:
1. убедиться что в ядре это действительно сконфигурировано - grep -i evdev /usr/src/linux/.config - должно ответить похожим на CONFIG_INPUT_EVDEV=m. модуль ядра evdev, если собрано как модуль, есть в памяти - lsmod|grep evdev


Проверил: CONFIG_INPUT_EVDEV=y

vr13 писал(а):
30.08.2012 08:26
2. правила udev в /lib/udev/rules.d/60-persistent-input.rures, когда видят наличие клавиатуры и мыши, в /dev/input создают визуально понятную структуру того, что система "понимает" как устройства ввода, например:

Код: Выделить всё

ls -lR /dev/input
/dev/input:
total 0
drwxr-xr-x 2 root root     80 Aug 28 06:19 by-id
drwxr-xr-x 2 root root    100 Aug 28 06:19 by-path
crw-r----- 1 root root 13, 64 Aug 28 10:19 event0
crw-r----- 1 root root 13, 65 Aug 28 10:19 event1
crw-r----- 1 root root 13, 66 Aug 28 10:19 event2
crw-r----- 1 root root 13, 67 Aug 28 06:19 event3
crw-r----- 1 root root 13, 63 Aug 28 10:19 mice
crw-r----- 1 root root 13, 32 Aug 28 06:19 mouse0

/dev/input/by-id:
total 0
lrwxrwxrwx 1 root root 9 Aug 28 06:19 usb-Dell_Dell_USB_Optical_Mouse-event-mouse -> ../event3
lrwxrwxrwx 1 root root 9 Aug 28 06:19 usb-Dell_Dell_USB_Optical_Mouse-mouse -> ../mouse0

/dev/input/by-path:
total 0
lrwxrwxrwx 1 root root 9 Aug 28 06:19 pci-0000:00:1d.2-usb-0:2:1.0-event-mouse -> ../event3
lrwxrwxrwx 1 root root 9 Aug 28 06:19 pci-0000:00:1d.2-usb-0:2:1.0-mouse -> ../mouse0
lrwxrwxrwx 1 root root 9 Aug 28 10:19 platform-i8042-serio-0-event-kbd -> ../event0

в случае ноутбука (и поддержки ядром wmi оного) или наличии в системе другого поддерживаемого HID-оборудования, список будет больше


На команду ls -lR /dev/input выдало такую строчку

event0 event1 event2 event3 mice mouse0

я так полагаю что здесь все так как надо?!


vr13 писал(а):
30.08.2012 08:26
3. /var/log/Xorg.0.log подробно рассказывает что увиделось и/или добавилось в конфигурацию системы при старте Xorg - начиная примерно с этого места:

Код: Выделить всё

...
[    39.610] (II) config/udev: Adding input device...
...
[    39.671] (II) XINPUT: Adding extended input device...
...

тут же будут ошибки, если чего-то непонятно системе


Тут я вот предлагаю поглядеть весь лог Xorg.0.log. У меня, видимо все как-то слишком криво. :unsure:
Spoiler
[ 611.110]
X.Org X Server 1.12.2
Release Date: 2012-05-29
[ 611.111] X Protocol Version 11, Revision 0
[ 611.111] Build Operating System: Linux 3.4.9-gentoo x86_64 Gentoo
[ 611.112] Current Operating System: Linux tiger 3.4.9-gentoo #3 SMP Thu Aug 30 00:29:26 NOVT 2012 x86_64
[ 611.112] Kernel command line: root=/dev/sda4
[ 611.113] Build Date: 30 August 2012 10:04:48AM
[ 611.113]
[ 611.114] Current version of pixman: 0.26.0
[ 611.115] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 611.115] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 611.117] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug 30 21:10:22 2012
[ 611.117] (II) Loader magic: 0x7d0ae0
[ 611.117] (II) Module ABI versions:
[ 611.117] X.Org ANSI C Emulation: 0.4
[ 611.117] X.Org Video Driver: 12.0
[ 611.117] X.Org XInput driver : 16.0
[ 611.117] X.Org Server Extension : 6.0
[ 611.119] (--) PCI:*(0:1:0:0) 10de:0641:105b:0f2c rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000d800/128, BIOS @ 0x????????/524288
[ 611.137] List of video drivers:
[ 611.137] nouveau
[ 611.138] (II) LoadModule: "nouveau"
[ 611.140] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 611.171] (II) Module nouveau: vendor="X.Org Foundation"
[ 611.171] compiled for 1.12.2, module version = 0.0.16
[ 611.171] Module class: X.Org Video Driver
[ 611.171] ABI class: X.Org Video Driver, version 12.0
[ 611.171] (II) NOUVEAU driver
[ 611.171] (II) NOUVEAU driver for NVIDIA chipset families :
[ 611.171] RIVA TNT (NV04)
[ 611.171] RIVA TNT2 (NV05)
[ 611.171] GeForce 256 (NV10)
[ 611.171] GeForce 2 (NV11, NV15)
[ 611.171] GeForce 4MX (NV17, NV18)
[ 611.171] GeForce 3 (NV20)
[ 611.171] GeForce 4Ti (NV25, NV28)
[ 611.171] GeForce FX (NV3x)
[ 611.171] GeForce 6 (NV4x)
[ 611.171] GeForce 7 (G7x)
[ 611.171] GeForce 8 (G8x)
[ 611.171] GeForce GTX 200 (NVA0)
[ 611.171] GeForce GTX 400 (NVC0)
[ 611.232] (++) Using config file: "/root/xorg.conf.new"
[ 611.232] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 611.241] (==) ServerLayout "X.org Configured"
[ 611.241] (**) |-->Screen "Screen0" (0)
[ 611.241] (**) | |-->Monitor "Monitor0"
[ 611.241] (**) | |-->Device "Card0"
[ 611.241] (**) |-->Input Device "Mouse0"
[ 611.241] (**) |-->Input Device "Keyboard0"
[ 611.241] (==) Automatically adding devices
[ 611.241] (==) Automatically enabling devices
[ 611.273] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 611.273] Entry deleted from font path.
[ 611.273] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 611.273] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 611.273] Entry deleted from font path.
[ 611.273] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 611.273] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 611.273] Entry deleted from font path.
[ 611.273] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 611.273] Entry deleted from font path.
[ 611.273] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 611.273] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 611.273] Entry deleted from font path.
[ 611.273] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 611.273] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/misc/
[ 611.273] (**) ModulePath set to "/usr/lib64/xorg/modules"
[ 611.273] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 611.273] (WW) Disabling Mouse0
[ 611.273] (WW) Disabling Keyboard0
[ 611.273] (EE) [drm] No DRICreatePCIBusID symbol
[ 611.274] Number of created screens does not match number of detected devices.
Configuration failed.


vr13 писал(а):
30.08.2012 08:26
вообще, тема "в x11 пропала клавиатура и мышь" в gentoo популярна, и популярность возрастает после обновления версии Xorg. стандартный совет - пересобрать драйверы xorg как-то так: emerge -1 `eix -I x11-drivers/`

Ну так как я ничего не обновлял, а ставил начисто, то думаю это пока не про меня или тоже так попытаться пересобрать?
Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 872
ОС: gentoo

Re: Помощь новичку с Gentoo

Сообщение vr13 » 30.08.2012 11:37

[ 611.241] (**) |-->Input Device "Mouse0"
[ 611.241] (**) |-->Input Device "Keyboard0"

предлагаю из xorg.conf удалить все, что касается мыши и клавиатуры, а также убедиться, что есть такое: /usr/share/X11/xorg.conf.d/10-evdev.conf (вообще-то это часть инсталляции x11-base/xorg-server, т.е быть должен, если xorg-server, кажется, собран с USE=+udev)

на самом деле, сейчас /etc/X11/corg.conf по большому случаю вообще не нужен, разве какая необычность с конфигурацией видеокарты и/или экрана
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 12:24

Отчитываюсь.

vr13 писал(а):
30.08.2012 11:37
[ 611.241] (**) |-->Input Device "Mouse0"
[ 611.241] (**) |-->Input Device "Keyboard0"

предлагаю из xorg.conf удалить все, что касается мыши и клавиатуры, а также убедиться, что есть такое: /usr/share/X11/xorg.conf.d/10-evdev.conf (вообще-то это часть инсталляции x11-base/xorg-server, т.е быть должен, если xorg-server, кажется, собран с USE=+udev)

на самом деле, сейчас /etc/X11/corg.conf по большому случаю вообще не нужен, разве какая необычность с конфигурацией видеокарты и/или экрана


Я бы с радостию. Но ведь в /etc/X11/ нет xorg.conf. Изменял /root/xorg.conf.new, но ведь это не то, потому и ничего особенного не случалось.

Еще кое-что сообщу. Во-первых, при загрузке пишет что sysfs failed to start и после этого что-то udev пишет), типа не смонтировался он.
Во-вторых, когда загрузил иксы и смотрел на рабочий стол :-) с неоткликающимися мышкой и клавой, припомнилось мне одно действие Alt+PrtScr+R. Клава откликнулась - побегал между терминалами. В том из которого запускал иксы была интересная запись.

nautilus:1944 GLib_Gobject_CRITICAL **: g_object_unref: assertion "G_IS_OBJECT(object)' failed (могу чуть буквы попутать ибо почерк как у врача)

Такие дела.
Спасибо сказали:

Аватара пользователя
vr13
Сообщения: 872
ОС: gentoo

Re: Помощь новичку с Gentoo

Сообщение vr13 » 30.08.2012 12:30

Verb писал(а):
30.08.2012 12:24
Еще кое-что сообщу. Во-первых, при загрузке пишет что sysfs failed to start и после этого что-то udev пишет), типа не смонтировался он.

отсюда подробнее, пожалуйста - скорее всего проблема тут. а на то что написал nautilus можно не обращать внимания - на связано
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 14:25

vr13 писал(а):
30.08.2012 12:30
Verb писал(а):
30.08.2012 12:24
Еще кое-что сообщу. Во-первых, при загрузке пишет что sysfs failed to start и после этого что-то udev пишет), типа не смонтировался он.

отсюда подробнее, пожалуйста - скорее всего проблема тут. а на то что написал nautilus можно не обращать внимания - на связано


Я не знаю пишется ли тот лог куда-нибудь :unsure: Только нашел dmesg

Выкладываю весь. Я ничего не увидел подозрительного.

http://pastie.org/4615634
http://pastie.org/4615638

:rolleyes:
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 30.08.2012 15:29

vr13 писал(а):
30.08.2012 12:30
отсюда подробнее, пожалуйста - скорее всего проблема тут. а на то что написал nautilus можно не обращать внимания - на связано


таки да, сделал rc log

Spoiler

rc boot logging started at Fri Aug 31 01:22:30 2012

* Setting system clock using the hardware clock [UTC] ...
[ ok ]
* Loading module \&{modules} ...
* Failed to load \&{modules}
[ !! ]
* Loading module nouveau ...
[ ok ]
* Autoloaded 1 module(s)
* Checking local filesystems ...
/dev/sda4: clean, 293906/1868640 files, 1173319/7473376 blocks
/dev/sda3: clean, 34/25688 files, 11663/102400 blocks
[ ok ]
* Remounting root filesystem read/write ...
[ ok ]
* Updating /etc/mtab ...
[ ok ]
* Mounting local filesystems ...
[ ok ]
* Configuring kernel parameters ...
[ ok ]
* Creating user login records ...
[ ok ]
* Cleaning /var/run ...
[ ok ]
* Wiping /tmp directory ...
[ ok ]
* Setting hostname to tiger ...
[ ok ]
* Setting terminal encoding [UTF-8] ...
[ ok ]
* Setting keyboard mode [UTF-8] ...
[ ok ]
* Loading key mappings [ru] ...
[ ok ]
* Bringing up interface lo
* 127.0.0.1/8 ...
[ ok ]
* Adding routes
* 127.0.0.0/8 via 127.0.0.1 ...
[ ok ]
* Mounting USB device filesystem [usbfs] ...
[ ok ]
* Mounting misc binary format filesystem ...
[ ok ]
* Loading custom binary format handlers ...
[ ok ]
* Activating swap devices ...
[ ok ]
* Mounting cgroup filesystem ...
mount: wrong fs type, bad option, bad superblock on cgroup_root,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)
In some cases useful info is found in syslog - try
dmesg | tail or so

[ !! ]
* ERROR: sysfs failed to start
* ERROR: cannot start udev as sysfs would not start
* Initializing random number generator ...
[ ok ]

rc boot logging stopped at Fri Aug 31 01:22:33 2012


rc default logging started at Fri Aug 31 01:22:33 2012

* Starting D-BUS system messagebus ...
[ ok ]
* Bringing up interface eth0
* dhcp ...
* Running dhcpcd ...
dhcpcd[1642]: version 5.2.12 starting
dhcpcd[1642]: eth0: waiting for carrier
dhcpcd[1642]: eth0: carrier acquired
dhcpcd[1642]: eth0: rebinding lease of 192.168.100.3
dhcpcd[1642]: eth0: acknowledged 192.168.100.3 from 192.168.100.1
dhcpcd[1642]: eth0: checking for 192.168.100.3
dhcpcd[1642]: eth0: leased 192.168.100.3 for 259200 seconds
dhcpcd[1642]: forked to background, child pid 1672
[ ok ]
* received address 192.168.100.3/24
[ ok ]
* Mounting network filesystems ...
[ ok ]
* Starting syslog-ng ...
[ ok ]
* Starting sshd ...
[ ok ]
* Starting vixie-cron ...
[ ok ]
* Starting local
[ ok ]
* Mounting cgroup filesystem ...
mount: wrong fs type, bad option, bad superblock on cgroup_root,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)
In some cases useful info is found in syslog - try
dmesg | tail or so

[ !! ]
* ERROR: sysfs failed to start
* ERROR: cannot start udev as sysfs would not start

rc default logging stopped at Fri Aug 31 01:22:46 2012


// на дату не обращаем внимания оказалось вместо нужного времени +7

Я как-то не представляю что нужно поправить или пересобрать чтобы заработало. Посмотрел хэндбук, вроде все сделано как там написано и даже никакой этап не приходит в голову переделывать.
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 4891
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение /dev/random » 31.08.2012 00:09

По-моему, вы выключили в ядре tmpfs.

Да, и если это не поможет, либо если появятся ещё проблемы, приложите свой конфиг ядра.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 31.08.2012 10:59

/dev/random писал(а):
31.08.2012 00:09
По-моему, вы выключили в ядре tmpfs.

Да, и если это не поможет, либо если появятся ещё проблемы, приложите свой конфиг ядра.


Да-да, небыло в ядре tmpfs! Очень вам благодарен! (интересно как вы догадались)

И вообще, если вы видите это сообщение - значит что я пишу из Gentoo :)
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 4891
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение /dev/random » 31.08.2012 11:19

Verb писал(а):
31.08.2012 10:59
интересно как вы догадались

* Mounting cgroup filesystem ...
mount: wrong fs type, bad option, bad superblock on cgroup_root,
...
[ !! ]
* ERROR: sysfs failed to start

Т.е. проблемы при монтировании cgroup_root, из-за которых не отработал init-скрипт sysfs.
cgroup_root - это в данном случае фальшивое имя устройства, указанное потому, что mount требует указать какое-нибудь устройство даже для файловых систем, с устройствами не связаных. Смотрим в /etc/init.d/sysfs, ищем команду mount с указанием этого имени. Находим, это tmpfs. Никаких необычных опций нет, единственное, почему команда могла провалиться - это потому, что tmpfs не поддерживается.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 31.08.2012 15:14

/dev/random писал(а):
31.08.2012 11:19
Verb писал(а):
31.08.2012 10:59
интересно как вы догадались

* Mounting cgroup filesystem ...
mount: wrong fs type, bad option, bad superblock on cgroup_root,
...
[ !! ]
* ERROR: sysfs failed to start

Т.е. проблемы при монтировании cgroup_root, из-за которых не отработал init-скрипт sysfs.
cgroup_root - это в данном случае фальшивое имя устройства, указанное потому, что mount требует указать какое-нибудь устройство даже для файловых систем, с устройствами не связаных. Смотрим в /etc/init.d/sysfs, ищем команду mount с указанием этого имени. Находим, это tmpfs. Никаких необычных опций нет, единственное, почему команда могла провалиться - это потому, что tmpfs не поддерживается.


Понятно! Мастерство!

Итак, Господа, я снвоа в теме) У меня вопрос по звуку его нет. На gentoo.org пишут, что надо дрова собирать модулем. Но я как-то не пойму: если они встроенные в ядро не работают, то зачем делать такую возможность?
Спасибо сказали:

Аватара пользователя
bars
Сообщения: 165
Статус: Великая Россия!
ОС: BSD/LINUX

Re: Помощь новичку с Gentoo

Сообщение bars » 31.08.2012 15:16

Verb писал(а):
31.08.2012 15:14
/dev/random писал(а):
31.08.2012 11:19
Verb писал(а):
31.08.2012 10:59
интересно как вы догадались

* Mounting cgroup filesystem ...
mount: wrong fs type, bad option, bad superblock on cgroup_root,
...
[ !! ]
* ERROR: sysfs failed to start

Т.е. проблемы при монтировании cgroup_root, из-за которых не отработал init-скрипт sysfs.
cgroup_root - это в данном случае фальшивое имя устройства, указанное потому, что mount требует указать какое-нибудь устройство даже для файловых систем, с устройствами не связаных. Смотрим в /etc/init.d/sysfs, ищем команду mount с указанием этого имени. Находим, это tmpfs. Никаких необычных опций нет, единственное, почему команда могла провалиться - это потому, что tmpfs не поддерживается.


Понятно! Мастерство!

Итак, Господа, я снвоа в теме) У меня вопрос по звуку его нет. На gentoo.org пишут, что надо дрова собирать модулем. Но я как-то не пойму: если они встроенные в ядро не работают, то зачем делать такую возможность?

# lspci
покажи.
Настройка BSD систем
Знание сила, незнание Рабочая сила! Изображение
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 31.08.2012 15:37

Verb писал(а):
31.08.2012 15:14
Итак, Господа, я снвоа в теме) У меня вопрос по звуку его нет. На gentoo.org пишут, что надо дрова собирать модулем. Но я как-то не пойму: если они встроенные в ядро не работают, то зачем делать такую возможность?


Ну после пересборки ядра звук заработал и флеш, но мне не ясно зачем есть возможность встраивания в ядро?

Да и еще, после установки adobe-flash стало писать
* IMPORTANT: config file '/etc/portage/package.license' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

или так
* IMPORTANT: 6 config files in '/etc' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

вроде не мешает но как-то неприятно.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 31.08.2012 15:45

bars писал(а):
31.08.2012 15:16
# lspci
покажи.

после пересборки ядра, это наверное уже не имеет смысла. но так карту определяло правильно.
Спасибо сказали:

Аватара пользователя
Brainsburn
Сообщения: 949
Статус: /
ОС: LFS,Gentoo

Re: Помощь новичку с Gentoo

Сообщение Brainsburn » 31.08.2012 16:00

Verb писал(а):
31.08.2012 15:37
Да и еще, после установки adobe-flash стало писать
* IMPORTANT: config file '/etc/portage/package.license' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

или так
* IMPORTANT: 6 config files in '/etc' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

вроде не мешает но как-то неприятно.

Это вам etc-update или dispatch-conf. Очень советую сперва понять, что эти утилиты делают, иначе не удивляйтесь, почему настройки чего-либо слетели :)
Спасибо сказали:

Аватара пользователя
/dev/random
Администратор
Сообщения: 4891
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение /dev/random » 31.08.2012 16:00

Verb писал(а):
31.08.2012 15:37
Да и еще, после установки adobe-flash стало писать
* IMPORTANT: config file '/etc/portage/package.license' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

или так
* IMPORTANT: 6 config files in '/etc' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

Это есть в хендбуке, который следовало прочитать, но кратко перескажу: gentoo при обновлении пакета не заменяет конфиги, чтобы не испортить пользовательские настройки, но и оставлять их как есть нельзя: новые программы могут не работать со старыми конфигами. Поэтому оставляются обе версии. Вам нужно запустить etc-update или dispatch-conf (немного отличается интерфейс), чтобы выбрать для каждого конфига старый вариант, новый или собрать вручную "гибрид".

А хендбук всё-таки прочитайте.

PS: опередили.
Спасибо сказали:

Verb
Сообщения: 58
ОС: Gentoo

Re: Помощь новичку с Gentoo

Сообщение Verb » 31.08.2012 16:18

/dev/random писал(а):
31.08.2012 16:00
А хендбук всё-таки прочитайте.

PS: опередили.


Благодарю) Я вот хотел смотреть его, просто пока тут смотрю одну трансляцию, а оно вот как.

Brainsburn писал(а):
31.08.2012 16:00
Это вам etc-update или dispatch-conf. Очень советую сперва понять, что эти утилиты делают, иначе не удивляйтесь, почему настройки чего-либо слетели :)


Аха, запускал dispatch-conf. Ничччего не понял. Отложил на потом. Благодарю.
Спасибо сказали: