VirtualBox

Модератор: Skull

Аватара пользователя
mbI4uHKa
Сообщения: 210

VirtualBox

Сообщение mbI4uHKa » 03.10.2009 15:45

Скачал с virtualbox.org установщик.
1)

Код: Выделить всё

# sh VirtualBox-3.0.6-52128-Linux_x86.run


Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.........
VirtualBox Version 3.0.6 r52128 (2009-09-09T17:46:30Z) installer
Please install the build and header files for your current Linux kernel.
The current kernel version is 2.6.25-std-def-alt8.M41.4
Problems were found which would prevent VirtualBox from installing.
Please correct these problems and try again.

2) Установил
apt-get install kernel-headers-std-def kernel-headers-modules-std-def
, тем не менее, проблема осталась.

Как решить?
Спасибо сказали:

Аватара пользователя
HAW
Сообщения: 1321
ОС: ALT 4.1branch

Re: VirtualBox

Сообщение HAW » 03.10.2009 21:53

update-kernel
хочется вывести в чисто поле,
поставить лицом к стенке
и выстрелить в лоб,
что бы поняли!!!
Спасибо сказали:

Аватара пользователя
lava
Сообщения: 155
ОС: archer

Re: VirtualBox

Сообщение lava » 03.10.2009 22:02

mbI4uHKa писал(а):
03.10.2009 15:45
ОС: Opensuse 11.1, KDE 4.1
mbI4uHKa писал(а):
03.10.2009 15:45
apt-get install
mbI4uHKa писал(а):
03.10.2009 15:45
sh VirtualBox-3.0.6-52128-Linux_x86.run

?
Ubuntu 9.04 ("Jaunty Jackalope") i386 | AMD64
Ubuntu 8.10 ("Intrepid Ibex") i386 | AMD64
Ubuntu 8.04 LTS ("Hardy Heron") i386 | AMD64
Debian 5.0 ("Lenny") i386 | AMD64
Debian 4.0 ("Etch") i386 | AMD64
openSUSE 11.1 i386 | AMD64
openSUSE 11.0 i386 | AMD64
openSUSE 10.3 i386 | AMD64
SUSE Linux Enterprise Server 10 (SLES10) i386 | AMD64
Fedora 11 ("Leonidas") i386 | AMD64
Fedora 9 ("Sulphur") / 10 ("Cambridge") i386 | AMD64
Fedora 8 ("Werewolf") i386 | AMD64
Mandriva 2009.1 i386 | AMD64
Mandriva 2008.0 i386
Red Hat Enterprise Linux 5 ("RHEL5") / CentOS 5 i386 | AMD64
Red Hat Enterprise Linux 4 ("RHEL4") i386
Turbolinux 11 i386 | AMD64
PCLinuxOS 2007 i386

http://www.virtualbox.org/wiki/Linux_Downloads


mbI4uHKa писал(а):
03.10.2009 15:45
, тем не менее, проблема осталась.

Как решить?

uname -r
?
Спасибо сказали:

Аватара пользователя
mbI4uHKa
Сообщения: 210

Re: VirtualBox

Сообщение mbI4uHKa » 03.10.2009 22:43

Код: Выделить всё

uname -r

2.6.25-std-def-alt8.M41.4
lava, apt есть, и работает.
Насколько знаю, расширение файла и привязка его к исполнителю- удел windows. У меня он запустился, вопрос не ясен.
# All distributions i386 | AMD64
http://www.virtualbox.org/wiki/Linux_Downloads

HAW,
нашел пакет http://sisyphus.ru/ru/srpm/Branch5/update-kernel/
правда как подключить сизиф не знаю.
Спасибо сказали:

Аватара пользователя
HAW
Сообщения: 1321
ОС: ALT 4.1branch

Re: VirtualBox

Сообщение HAW » 04.10.2009 00:35

Никаких сизифоф!

Если интернет и компутер шустрые, тогда на 5 платформу перелазить пора и это другой вопрос.
Если в 4.1, то соответствующий бранч надо подключать.

Через GUI не помню.... рутом консольно в /etc/apt/sources.list.d/alt.list раскомментировать какой-нибудь http://ftp.altlinux.org/pub/... бранч
и только ядро обновить.
apt-get update; apt-get install update-kernel; update-kernel


скорее всего не совпадает версия заголовков и ядра.
хочется вывести в чисто поле,
поставить лицом к стенке
и выстрелить в лоб,
что бы поняли!!!
Спасибо сказали:

Аватара пользователя
mbI4uHKa
Сообщения: 210

Re: VirtualBox

Сообщение mbI4uHKa » 04.10.2009 10:56

HAW писал(а):
04.10.2009 00:35
Никаких сизифоф!

Если интернет и компутер шустрые, тогда на 5 платформу перелазить пора и это другой вопрос.
Если в 4.1, то соответствующий бранч надо подключать.

Через GUI не помню.... рутом консольно в /etc/apt/sources.list.d/alt.list раскомментировать какой-нибудь http://ftp.altlinux.org/pub/... бранч
и только ядро обновить.
apt-get update; apt-get install update-kernel; update-kernel


скорее всего не совпадает версия заголовков и ядра.

раскомментировал
rpm [updates] ftp://ftp.altlinux.org/pub/distributions/...nux/4.1/branch/ i586 classic,
apt-get update проходит успешно, но

Код: Выделить всё

[root@localhost ~]# apt-get install update-kernel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Невозможно найти пакет update-kernel


Так по очереди испытал все репозитории, в которых присутствует "branch". Результат тот же.

Компьютер и интернет позволяют перейти на 5-ую, но не вижу смысла. Да и не знаю как.
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: VirtualBox

Сообщение romuil » 04.10.2009 18:47

rpm [updates] ftp://ftp.altlinux.org/pub/distributions/...nux/4.1/branch/ noarch classic
не хватает и почитайте прикрепленную тему по установке пакетов.
Спасибо сказали:

Аватара пользователя
mbI4uHKa
Сообщения: 210

Re: VirtualBox

Сообщение mbI4uHKa » 17.10.2009 12:42

Всем большое спасибо.
Подключил noarch, убрал несколько других.
Выполнил apt-get update; apt-get install update-kernel; update-kernel, и все заработало.
Даже apache+php+mysql установился,хотя до этого не хотел.
Спасибо сказали: