Про KDE

Модератор: Skull

Aik
Сообщения: 4
ОС: AltLinux 4.1.1

Про KDE

Сообщение Aik » 30.10.2009 10:05

Доброго времени уважаемые линуксойды!!!!!!!
Я новичок в линуксе.
Установлен дистрибутив Alt 4.1.1 Desktop
Версия ядра 2,6,25-std-def alt8.M41.4
Версия кед 3,5,10
Подскажите реально ли обновить KDE до 4.x.x версий
На сайте кде лежат для федоры кеды 4х версий...я незнаю подойдут они или нет.
Подскажите в каком направлении копать...!
Заранее благодарен :drunk:
Спасибо сказали:

Аватара пользователя
begin2009
Сообщения: 349
Статус: Ламер со стажем
ОС: без глюков

Re: Про KDE

Сообщение begin2009 » 30.10.2009 18:22

Aik писал(а):
30.10.2009 10:05
Доброго времени уважаемые линуксойды!!!!!!!
Я новичок в линуксе.
Установлен дистрибутив Alt 4.1.1 Desktop
Версия ядра 2,6,25-std-def alt8.M41.4
Версия кед 3,5,10
Подскажите реально ли обновить KDE до 4.x.x версий
На сайте кде лежат для федоры кеды 4х версий...я незнаю подойдут они или нет.
Подскажите в каком направлении копать...!
Заранее благодарен :drunk:

KDE-4 и KDE-3 - вещи абсолютно разные. Единственный способ "обновления" - снос 3.5.10 и установка 4.
Ставить федоровские рпмки на алт не советую. Черевато. В лучшем случае просто не станут.

P.S. Не хочу холиварить, но что Вам в третих кедах не по сердцу? Я так поставил 3.5.10 на Мандриве 2009, где 4 по дефолту.
Пессимист видит темный туннель, оптимист видит свет в конце туннеля, реалист видит свет, туннель и поезд.
И только машинист видит этих трех идиотов, сидящих на рельсах.
Спасибо сказали:

Аватара пользователя
Ortis
Сообщения: 117
ОС: Mandriva 2011, Kubuntu 12.04

Re: Про KDE

Сообщение Ortis » 30.10.2009 18:23

1. Если вы новичок, не надо ставить ничего не от вашего дистрибутива. И уж тем более пакеты с сайта KDE. Вы поламаете все зависимости.
2. Сходите на сайт вашего дистрибутива: Сайт Альта и найдите там информацию по установке четвёртых кед на 4.1 в разделе, посвящённом этой ветке. Там точно есть, но на сколько работает, затрудняюсь ответить.
3. Вчера вышел Альт 5.0. Там KDE 4. Возможно, лучше обовиться до пятой ветки целиком (хотя не знаю).
4. Возможно, вам не нужны четвёртые кеды? Вам они точно нужны?
5. Иногда проще переустановить дистрибутив (далеко не всегда, конечно).
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Про KDE

Сообщение romuil » 30.10.2009 19:05

Ortis не пишите ерунду
Иногда проще переустановить дистрибутив (далеко не всегда, конечно).

Это неверно независимо от дистрибутива.

Aik, в файле /etc/apt/sources.list.d/alt.list
должны быть строки вида

Код: Выделить всё

#rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch i586 classic
#rpm [updates] http://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch noarch classic

iУведомление от модератора Skull
Я поправил, так как лучше указывать репозитарий Пятой платформы

Уберите знаки # или допишите их(строки), в случае отсутствия.
Потом скомандуйте
apt-get update && apt-get dist-upgrade

После этого можно приступать к установке kde4.
Получите список пакетов командой

Код: Выделить всё

apt-cache search kde4

или запустите Synaptic и установите все пакеты, начиная с kde4base-common. Необходимые зависимости подтянутся автоматически.
И читайте же прикрепленную тему про установку пакетов!
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Про KDE

Сообщение Skull » 30.10.2009 19:36

Из http://www.altlinux.org/FAQ:
Как поставить KDE4?
Если у вас Sisyphus или p5 branch, установите один из следующих пакетов:
kde4 (полный набор)
kde4-small (популярные приложения)
kde4-mini (минимальный набор)
kde4-devel (всё для разработчика)
Если таких пакетов для вашего бранча нет, выполните

Код: Выделить всё

apt-get install `apt-cache search ^kde4| grep ^kde4| grep -v devel| sed "s|[[:space:]].*||"`

KDE4 хранит данные пользователя в $HOME/.kde4. Для миграции настроек скопируйте старые параметры:

Код: Выделить всё

cp -R ~/.kde ~/.kde4

И не забудьте перейти на новый KDM:

Код: Выделить всё

service dm restart

В диалоге выберите сеанс «KDE». Все программы будут видны из меню KDE4. Программы от KDE4 будут видны только из меню KDE4. Одноимённые из KDE4 будут перекрывать те, что из KDE3 (например, если хотите везде использовать amarok-1.4, просто удалите kde4-amarok).
Skull
Спасибо сказали:

Aik
Сообщения: 4
ОС: AltLinux 4.1.1

Re: Про KDE

Сообщение Aik » 31.10.2009 12:00

Прежде чем пробовать переход на КДЕ4 хотелось бы сделать резервную копию....
подскажите какие директории и файлы заархивировать!?
или всю папку home? И так же вопрос...
как можно перенести настройки рабочего стола на другой комп.....дистрибутивы идентичны...
(хотелось бы перенести заставки, поведение окон, виджеты) ...
благодарю... за подробное описание темы
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Про KDE

Сообщение romuil » 31.10.2009 22:48

Aik писал(а):
31.10.2009 12:00
Прежде чем пробовать переход на КДЕ4 хотелось бы сделать резервную копию....
подскажите какие директории и файлы заархивировать!?
или всю папку home? И так же вопрос...
как можно перенести настройки рабочего стола на другой комп.....дистрибутивы идентичны...
(хотелось бы перенести заставки, поведение окон, виджеты) ...
благодарю... за подробное описание темы

Ничего архивировать не надо. Ветки KDE не пересекаются вообще никак.
Достаточно перенести содержимое /etc/ и все файлы и каталоги в домашнем каталоге, которые начинаются с символа '.'
Спасибо сказали:

Aik
Сообщения: 4
ОС: AltLinux 4.1.1

Re: Про KDE

Сообщение Aik » 02.11.2009 14:48

Ещё вопрос как можно отдельно запустить голую X систему
командой xinit ?
Выводит ошибку что типа запущенно уже...
подскажите
Спасибо сказали:

Aik
Сообщения: 4
ОС: AltLinux 4.1.1

Re: Про KDE

Сообщение Aik » 10.11.2009 10:52

Добрый день
Хочу установить антивирь.
Скачал его распаковал
теперь проблемма на этапе конфигурирования...
Вот пример лога

Код: Выделить всё

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by ClamAV configure 0.95.3, which was
generated by GNU Autoconf 2.64.  Invocation command line was

  $ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = linuxoid
uname -m = i686
uname -r = 2.6.25-std-def-alt8.M41.4
uname -s = Linux
uname -v = #1 SMP Sat Dec 6 14:42:12 MSK 2008

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /home/vertex/bin
PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/bin
PATH: /usr/games
PATH: /usr/X11R6/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2593: checking build system type
configure:2602: error: cannot guess build type; you must specify one

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL=''
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR=''
AR=''
ARGZ_H=''
AUTOCONF=''
AUTOHEADER=''
AUTOMAKE=''
AWK=''
BUILD_CLAMD_FALSE=''
BUILD_CLAMD_TRUE=''
CC=''
CCDEPMODE=''
CFGDIR=''
CFLAGS=''
CHECK_CPPFLAGS=''
CHECK_LIBS=''
CLAMAVGROUP=''
CLAMAVUSER=''
CLAMAV_MILTER_LIBS=''
CLAMD_LIBS=''
CONVENIENCE_LTDL_FALSE=''
CONVENIENCE_LTDL_TRUE=''
CPP=''
CPPFLAGS=''
CURSES_CPPFLAGS=''
CURSES_LIBS=''
CYGPATH_W=''
DBDIR=''
DEFS=''
DEPDIR=''
DISTCHECK_ENABLE_FLAGS_FALSE=''
DISTCHECK_ENABLE_FLAGS_TRUE=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
ENABLE_COVERAGE_FALSE=''
ENABLE_COVERAGE_TRUE=''
ENABLE_UNRAR_FALSE=''
ENABLE_UNRAR_TRUE=''
EXEEXT=''
FGREP=''
FRESHCLAM_LIBS=''
GCOV=''
GENHTML=''
GETENT=''
GPERF=''
GREP=''
HAVE_CURSES_FALSE=''
HAVE_CURSES_TRUE=''
HAVE_LIBCHECK_FALSE=''
HAVE_LIBCHECK_TRUE=''
HAVE_MILTER_FALSE=''
HAVE_MILTER_TRUE=''
INCLTDL=''
INSTALL_DATA=''
INSTALL_LTDL_FALSE=''
INSTALL_LTDL_TRUE=''
INSTALL_PROGRAM=''
INSTALL_SCRIPT=''
INSTALL_STRIP_PROGRAM=''
LCOV=''
LD=''
LDFLAGS=''
LIBADD_DL=''
LIBADD_DLD_LINK=''
LIBADD_DLOPEN=''
LIBADD_SHL_LOAD=''
LIBBZ2=''
LIBBZ2_PREFIX=''
LIBCLAMAV_LIBS=''
LIBCLAMAV_VERSION=''
LIBLTDL=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LINK_TOMMATH_FALSE=''
LINK_TOMMATH_TRUE=''
LIPO=''
LN_S=''
LTDLDEPS=''
LTDLINCL=''
LTDLOPEN=''
LTLIBBZ2=''
LTLIBOBJS=''
LT_CONFIG_H=''
LT_DLLOADERS=''
LT_DLPREOPEN=''
MAINT=''
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE=''
MAKEINFO=''
MKDIR_P=''
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE=''
PACKAGE_BUGREPORT='http://bugs.clamav.net/'
PACKAGE_NAME='ClamAV'
PACKAGE_STRING='ClamAV 0.95.3'
PACKAGE_TARNAME='clamav'
PACKAGE_URL='http://www.clamav.net/'
PACKAGE_VERSION='0.95.3'
PATH_SEPARATOR=':'
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
THREAD_LIBS=''
TH_SAFE=''
VERSION=''
VERSIONSCRIPTFLAG=''
VERSIONSCRIPT_FALSE=''
VERSIONSCRIPT_TRUE=''
ac_ct_CC=''
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__isrc=''
am__leading_dot=''
am__quote=''
am__tar=''
am__untar=''
bindir='${exec_prefix}/bin'
build=''
build_alias=''
build_cpu=''
build_os=''
build_vendor=''
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host=''
host_alias=''
host_cpu=''
host_os=''
host_vendor=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
ltdl_LIBOBJS=''
ltdl_LTLIBOBJS=''
mandir='${datarootdir}/man'
mkdir_p=''
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sys_symbol_underscore=''
sysconfdir='${prefix}/etc'
target=''
target_alias=''
target_cpu=''
target_os=''
target_vendor=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "ClamAV"
#define PACKAGE_TARNAME "clamav"
#define PACKAGE_VERSION "0.95.3"
#define PACKAGE_STRING "ClamAV 0.95.3"
#define PACKAGE_BUGREPORT "http://bugs.clamav.net/"
#define PACKAGE_URL "http://www.clamav.net/"

configure: exit 1

Помогите плиз :rolleyes:
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Про KDE

Сообщение romuil » 10.11.2009 19:37

Спасибо сказали: