Решено: так как все-таки правильно обновить школьный линукс (который alt)

Модератор: Skull

ska
Сообщения: 202
ОС: ALTLinux School Master

Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 27.11.2010 05:28

Обновлял по второму разу. Думал учесть предыдущие ошибки, чтобы все получилось нормально. Однако я так ничего и не понимаю. Есть диск из первой помощи, установил с него линукс мастер (это 4 версия альта)
Затем убрал из репозитариев ссылку на диск, добавил 2 ссылки на яндекс для i586 и noarch.
После этого в консоли выполнил синхронизацию

Код: Выделить всё

apt-get update


Потом обновился

Код: Выделить всё

apt-get dist-upgrade

Потом решил обновитья "как следует". Поэтому добавил к имеющимся 2ум репам еще 2 репозитария p5
потом снова синхронизация

Код: Выделить всё

apt-get update

Потом

Код: Выделить всё

apt-get dist-upgrade

Вот здесь начались непонятности. После того пакеты скачались, обновились, у меня пропал интернет - пишет что не может резолв такой-то адрес (хотя в резолв.конф у меня оба днс прописаны). Снова в кде не монтируется флешка, стнва через кде нельзя настроить сетевые интерфейсы - при клике на ссылку настройки окно закрывается. Еще в кде пропало завершение работы, есть только выйти из текущего сеанса, а дальше приходится из консоли через reboot или shutdown выключать или перезагружать.
Скажите, пожалуйста, я правильно ли обновлялся? Что произошло?
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 27.11.2010 09:08

1. Лучше обновлять не сразу на p5, а промежуточно, через 4.1.
2. Нужно смотреть, что apt-get удалял.
3. Крайне рекомендуется обновить и ядро командой update-kernel
4. После такого глобального обновления следует всё же перезагрузить компьютер, так как запущены ещё старые программы и это может привести к неприятным эффектам.
5. В p5 для управления сетью уже используется NetworkManager. Установите пакет NetworkManager-gnome

Подробная инструкция для обновления ALT Linux: http://forum.altlinux.org/index.php/topic,4487.0.html (взято с http://www.altlinux.org/FAQ)
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 27.11.2010 09:53

2. здесь я вырезал кусок из messages где установка и удаление шло...

3.

Код: Выделить всё

[linux@localhost ~]$ sudo apt-get install update-kernel
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
  gambas-examples: Depends: gambas-ide (= 2.17.0-alt1)
  gambas-ide: Depends: gambas-runtime (= 2.0.0-alt0.M40.1)
              Depends: gambas-devel (= 2.0.0-alt0.M40.1)
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
[linux@localhost ~]$ sudo apt-get --fix-broken install update-kernel
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
  gambas-examples: Depends: gambas-ide (= 2.17.0-alt1)
  gambas-ide: Depends: gambas-runtime (= 2.0.0-alt0.M40.1)
              Depends: gambas-devel (= 2.0.0-alt0.M40.1)
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).
[linux@localhost ~]$

4. перезагружал
5. ничего пока установить не могу через инет - инет перестал работать на линуксе
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Сергий
Сообщения: 89

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Сергий » 27.11.2010 23:29

Простите, а какая у Вас система ? Школьный Линукс(на базе Альт) ? Тогда почему Вы используете
sudo apt-get install update-kernel
? В Альт принято использовать su - . Или у Вас Edubuntu ? Тогда зачем подключать репозитории Альта ?
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 28.11.2010 06:14

У меня альт 4.0 с диска первой помощи, который я бузуспешно пытаюсь обновить через инет ). Я обычно пользуюсь судо. Иногда делаю sudo su. По-разному.

(Skull) писал(а):3. Крайне рекомендуется обновить и ядро командой update-kernel

Код: Выделить всё

[root@localhost ~]# update-kernel -t std-def
update-kernel: There are no available kernels with kernel flavour std-def
[root@localhost ~]#

Код: Выделить всё

[linux@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1

ходил по ссылке, http://www.altlinux.org/Kernels/Flavours там нет про связку std-smp. Это что значит?
Мне ядро обновлять с параметром -t std-smp?
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 29.11.2010 20:53

ska писал(а):
28.11.2010 06:14
update-kernel: There are no available kernels with kernel flavour std-def

http://sisyphus.ru/ru/srpm/Sisyphus/kernel-image-std-def появился с 4.1. Сначала обновитесь до 4.1, затем обновляйте ядро.
Skull
Спасибо сказали:

yaleks
Сообщения: 2121
Статус: вне статуса
ОС: Gentoo ~

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение yaleks » 29.11.2010 21:20

ska писал(а):
27.11.2010 05:28
Скажите, пожалуйста, я правильно ли обновлялся? Что произошло?

может проще поставить 5 версию изначально? Если /home на отдельном разделе, то нужные данные сохранятся.
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 30.11.2010 11:12

Skull писал(а):
29.11.2010 20:53
ska писал(а):
28.11.2010 06:14
update-kernel: There are no available kernels with kernel flavour std-def

http://sisyphus.ru/ru/srpm/Sisyphus/kernel-image-std-def появился с 4.1. Сначала обновитесь до 4.1, затем обновляйте ядро.

ок. Тогда как правильно обновиться с 4.0. на 4.1? Если я убираю 2 репы от 4.0 и добавляю вместо них 2 репы 4.1 (как советуют по ссылкам, которые вы указали - больше 2ух реп не использовать), тогда при синхронизации командой apt-get update выходит такое

Код: Выделить всё

[linux@localhost ~]$ sudo apt-get update
[sudo] password for linux:
Get:1 http://mirror.yandex.ru noarch release [839B]
Get:2 http://mirror.yandex.ru i586 release [843B]
Fetched 1682B in 7s (229B/s)
Get:1 http://mirror.yandex.ru noarch/classic pkglist [1110kB]
Err http://mirror.yandex.ru noarch/classic pkglist
  Connection timed out [IP: 95.108.197.241 80]
Hit http://mirror.yandex.ru noarch/classic release
Get:2 http://mirror.yandex.ru i586/classic pkglist [2690kB]
Err http://mirror.yandex.ru i586/classic pkglist
  Connection timed out [IP: 95.108.197.241 80]
Hit http://mirror.yandex.ru i586/classic release
Failed to fetch http://mirror.yandex.ru/altlinux/4.1/branch/noarch/base/pkglist.classic  Connection timed out [IP: 95.108.197.241 80]
Failed to fetch http://mirror.yandex.ru/altlinux/4.1/branch/i586/base/pkglist.classic  Connection timed out [IP: 95.108.197.241 80]
Reading Package Lists... Done
Building Dependency Tree... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.
[linux@localhost ~]$

Насколько это серьезная ошибка, чтобы обновлять дальше дистрибутив? Хочется заранее быть уверенным что все установится нормально.
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 30.11.2010 13:06

ska писал(а):
30.11.2010 11:12
Failed to fetch http://mirror.yandex.ru/altlinux/4.1/branc...pkglist.classic Connection timed out [IP: 95.108.197.241 80]
Доступа нет к серверу. Попробуйте попозже или на другом зеркале.
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 02.12.2010 09:50

Все почти повторилось. Итак, скачалось. Обновилось и в конце как обычно выдало ошибку. Some errors occured during interaction. Потом перезагрузил (хотя насколько понимаю, если ядро не обновлялось то в линуксе можно и не перезагружать). Но тем не менее. После первой перезагрузки все работало - открывались все программы и работал интернет. Но когда перезагрузился второй раз и далее, т.е. до наст. момента имеются следущие глюки
1 в кде нет заверишить работу, есть только завершить сеанс.
2 не работает интернет, т.е. внешний интерфейс, хотя Ifconfig показывает что к нему привязаны те же самые ай пи, с днсами тоже все в порядке. Но выхода в Интернет нет.

Далее если захожу в управление пакетами, выдает, что надо исправить два пакета с ошибками. Нажимаю исправить, предлагает обновить gambas-ide. Однако это дело заканчивается этим

Код: Выделить всё

Во время установки пакета gambas-ide-2.5.0-alt1:
error: unpacking of archive failed on file /usr/share/gambas2/help/help/doc/odbc: cpio: rename failed - Это каталог
E: Some errors occurred while running transaction


Далее подозреваю, что Интернета нет из за того что надо поставить пакет alterator-net (тупо интуитивно)) (хотя непонятно, почему, когда первый раз перезагрузился все работало..). Скачал его через винду, скинул в папку с архивами рпм. Но установить все равно не получается потому что он зависит от gambas-ide, который надо обновить.
Т.е. что мне делать с gambas-ide?
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение romuil » 02.12.2010 09:53

С твоих слов ничего не понятно. Нужны логи, сообщения об ошибках, всё максимально подробно. Для начала можно просто удалить gambas-ide, с ним разберешься после.
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 02.12.2010 10:33

romuil писал(а):
02.12.2010 09:53
С твоих слов ничего не понятно. Нужны логи, сообщения об ошибках, всё максимально подробно. Для начала можно просто удалить gambas-ide, с ним разберешься после.

в том то и дело, что я сам ничего понять не могу) Однако после установки alterator-net-eth и удаления gambas-ide заработал внешний интерфейс (в том смысле что пявился Интернет, т.к. внешний интерфейс и так работал, но Интерната на нем не было). По поводу ошибок...
Явных ошибок (с окнами в которых написано про ошибки) я не вижу. По логам мне тоже непонятно в чем может быть причина. Разве что вот это в kdm.log

Код: Выделить всё

********************************************************************************
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged. PAM logs messages related to authentication to authpriv.*.
********************************************************************************

X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 28 17:25:02 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
QSettings: error creating /tmp/kde-kdm-0596598392/.qt3
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 28 17:27:12 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
BOGUS LENGTH in write keyboard desc, expected 5392, got 5396
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 29 15:59:53 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 29 16:02:35 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
BOGUS LENGTH in write keyboard desc, expected 5504, got 5508
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 29 16:04:35 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 30 12:35:20 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
BOGUS LENGTH in write keyboard desc, expected 5488, got 5492
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.
X Window System Version 7.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 7.3
Build Operating System: Linux 2.6.18-std-smp-alt12.M40.3 i686 2.6.18-std-smp-alt12.M40.3 i686
Current Operating System: Linux localhost.localdomain 2.6.18-std-smp-alt12.M40.1 #1 SMP Mon Nov 10 03:23:01 MSK 2008 i686
Build Date: 20 November 2008
    Before reporting problems, check https://bugzilla.altlinux.org/
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 30 14:05:14 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
FreeFontPath: FPE "/usr/share/fonts/bitmap/misc/" refcount is 2, should be 1; fixing.


может еще это в Xorg.0.log


Кстати окно входа в систему изменилось и стало как-то "проще* выглядеть, и еще кде загружается вместе с дополнительным окном xconsole. И еще та же ошибка, если заходить через acc в настройки и кликать на сетевые интерфейсы, окно шустро закрывается без всяких предупреждений) (как и в прошлый раз это решается удалением пакета altarator-net-junior)
Осталось разобраться с графикой входа в систему и с кде. Где заврешение работы?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 02.12.2010 20:13

ska писал(а):
02.12.2010 10:33
Осталось разобраться с графикой входа в систему и с кде. Где заврешение работы?
Должен быть установлен kdm, а всякие xdm/gdm убраны.
Или создайте файл /etc/sysconfig/desktop и пропишите в нём
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 03.12.2010 06:29

Skull писал(а):
02.12.2010 20:13
ska писал(а):
02.12.2010 10:33
Осталось разобраться с графикой входа в систему и с кде. Где заврешение работы?
Должен быть установлен kdm, а всякие xdm/gdm убраны.
Или создайте файл /etc/sysconfig/desktop и пропишите в нём

Код: Выделить всё

[linux@localhost ~]$ rpm -qa | grep kdm
kdebase-kdm-3.5.10-alt16.M41.1
kde-settings-kdm-3.5.10-alt6.M41.1
[linux@localhost ~]$

Если создать файл desktop и прописать туда kde, то ничего не меняется - все то же самое. Когда загружается рабочий стол кде, то первые пару секунд он выгледит как kde 4.1 (симпатишная зеленая обоина по умолчанию и соотсветсвующие значки и надпись 4.1 говорят об этом). Однако через секунду все меняется и рабочий стол резко превращается в 4.0. и становится таким

И еще может в desktop правильнее писать не kde а displaymanager=kde?

P.S. после удаления xdm приходится вводить в консоли sartx чтобы загрузиться в графику.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 03.12.2010 08:50

Появились ссылки Выключить компьютер и Перезагрузить
после того как установил gnome-full (мне он кажется пошустрее, но если на него загружаюсь, то снова не фурычит внешний интерфейс, так что пока на кде()
В данный момент обновляю ядро! Иду на 5 версию, полет нормальный)
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение romuil » 03.12.2010 09:00

Нужен kde4base-workspace-kdm для KDE4. У тебя в системе неописуемый бедлам.
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 03.12.2010 11:13

romuil писал(а):
03.12.2010 09:00
Нужен kde4base-workspace-kdm для KDE4. У тебя в системе неописуемый бедлам.

Я тут ни причем). Это альт криво обновляется.
И зачем мне кде4 если у меня стоит кде 3.5.10?
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 04.12.2010 07:17

Обновил ядро. Не без последствий). Сначала несколько раз пытался загрузить его с зеркал яндекса, но там постоянно какие-то сбои. Мне это надоело и я поменял репозитарии на http://ftp.altlinux.org/pub/distributions/...nux/4.1/branch/
Все работает, все загружается. Единственно, неприяно было видеть, а точнее не видеть заставку загрузчика lilo. Т.е. она как бы есть. Наполовину. Т.е. фон на месте, логотипы прежние тоже, а вот меню выбора невидно. Вместо него одна полоска, примерно в 2 пикселя толщиной. Как бы мне вернуть нормальное отображение выбора ядер и ос в меню лило?

Код: Выделить всё

[linux@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.25-std-def-alt8.M41.5 #1 SMP Tue Aug 18 15:17:50 MSD 2009 i686 GNU/Linux
[linux@localhost ~]$

Код: Выделить всё

[linux@localhost ~]$ sudo cat /etc/lilo.conf
[sudo] password for linux:
map="/boot/map"
lba32
prompt
compact
timeout="100"
install="menu"
default="ALTLinux"
vga="0x314"
append="resume=/dev/sda2 panic=30 splash=silent"
message="/boot/splash/message"
boot="/dev/sda"

#image="/boot/vmlinuz"
#       label="ALTLinux"
#       initrd="/boot/initrd.img"
#       root="UUID=8be6ea39-676c-4218-8a62-39abb6313dc1"
#       read-only

#image="/boot/vmlinuz"
#       label="failsafe"
#       initrd="/boot/initrd.img"
#       root="UUID=8be6ea39-676c-4218-8a62-39abb6313dc1"
#       addappend="failsafe"
#       vga="normal"
#       read-only

other="/dev/sda1"
        label="Windows"
image="/boot/vmlinuz-2.6.18-std-smp-alt12.M40.1"
        initrd="/boot/initrd-2.6.18-std-smp-alt12.M40.1.img"
        label="2618-std-smp-12M401"
        root="/dev/sda3"
        read-only
        optional
image="/boot/vmlinuz-2.6.25-std-def-alt8.M41.5"
        initrd="/boot/initrd-2.6.25-std-def-alt8.M41.5.img"
#       label="2625-std-def-8M415"
        label="ALTLinux"
        root="/dev/sda3"
        read-only
        optional
[linux@localhost ~]$

Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 05.12.2010 11:08

ska писал(а):
03.12.2010 06:29
P.S. после удаления xdm приходится вводить в консоли sartx чтобы загрузиться в графику.
5 ранлевел в /etc/inittab и

Код: Выделить всё

chkconfig --level 5 dm on

спасут


ska писал(а):
04.12.2010 07:17
Как бы мне вернуть нормальное отображение выбора ядер и ос в меню лило?
Два варианта:
1. Текстовый режим: vga=normal и перезапуск lilo
2. Поставить нужный branding и запустить installkernel с новым ядром.
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 06.12.2010 01:54

Код: Выделить всё

1330 upgraded, 300 newly installed, 46 replaced, 290 removed and 60 not upgraded.
Need to get 0B/1131MB of archives.
After unpacking 986MB disk space will be freed.
Do you want to continue? [Y/n] y
Committing changes...
Preparing...                 ##################################################### [100%]
file /usr/bin/sox from install of sox-base-14.3.0-alt1.1 conflicts with file from package sox-13.0.0-alt3
file /usr/bin/soxplay from install of sox-base-14.3.0-alt1.1 conflicts with file from package sox-13.0.0-alt3
file /usr/share/man/man1/sox.1.bz2 from install of sox-base-14.3.0-alt1.1 conflicts with file from package sox-13.0.0-alt3
E: Error while running transaction
[root@localhost ~]#

Это я пытаюсь перейти с 4.1 на на пятую (через p5)
вот еще отедльно по пакету

Код: Выделить всё

[linux@localhost ~]$ sudo apt-get install sox
[sudo] password for linux:
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  sox: Depends: libsox-fmt-ffmpeg (= 14.3.0-alt1.1)
E: Broken packages
[linux@localhost ~]$
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 06.12.2010 08:47

Skull писал(а):
05.12.2010 11:08
ska писал(а):
03.12.2010 06:29
P.S. после удаления xdm приходится вводить в консоли sartx чтобы загрузиться в графику.
5 ранлевел в /etc/inittab и

Код: Выделить всё

chkconfig --level 5 dm on

спасут


ska писал(а):
04.12.2010 07:17
Как бы мне вернуть нормальное отображение выбора ядер и ос в меню лило?
Два варианта:
1. Текстовый режим: vga=normal и перезапуск lilo
2. Поставить нужный branding и запустить installkernel с новым ядром.

Не помогло (.
Во втором варианте делал так
Убедился какие темы имеются

Код: Выделить всё

[linux@localhost ~]$ apt-cache search branding-altlinux- bootsplash
branding-altlinux-backup-server-bootsplash - Theme for splash animations during bootup
branding-altlinux-desktop-bootsplash - Theme for splash animations during bootup
branding-altlinux-gnome-desktop-bootsplash - Theme for splash animations during bootup
branding-altlinux-kdesktop-bootsplash - Theme for splash animations during bootup
branding-altlinux-lite-bootsplash - Theme for splash animations during bootup
branding-altlinux-office-desktop-bootsplash - Theme for splash animations during bootup
branding-altlinux-office-server-bootsplash - Theme for splash animations during bootup
branding-altlinux-school-server-bootsplash - Theme for splash animations during bootup
branding-altlinux-workbench-bootsplash - Theme for splash animations during bootup
[linux@localhost ~]$

Затем отредактировал файл /etc/sysconfig/bootsplash таким образом

Код: Выделить всё

[linux@localhost ~]$ cat /etc/sysconfig/bootsplash
## Path:        System/Boot
## Description: enables/disables bootup graphics
## Type:        yesno
## Default:     yes
#
# SPLASH can be set to "no" to turn off the splash-screen on console 1
# at boot time (after kernel load).
#
# SPLASH=no to disable the splash screen
#
# SPLASH=yes to show the splash screen
#
SPLASH="yes"
THEME="branding-altlinux-school-server-bootsplash"
[linux@localhost ~]$

После этого выполнил

Код: Выделить всё

[linux@localhost ~]$ sudo installkernel 2.6.32-std-def-alt20.M50P.1
/home/linux
Added Windows
Added 2625-std-def-8M415
Added ALTLinux *
[linux@localhost ~]$

Перезагружаюсь и вижу то же самое. Примерная картинка того что я вижу

У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 06.12.2010 11:20

Кончайте хакать. Вам будет проще поставить дистрибутив на p5 и не заниматься самодеятельностью, типа точечного обновления.

Тему переношу в ALT Linux.
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 06.12.2010 11:55

Skull писал(а):
06.12.2010 11:20
Кончайте хакать. Вам будет проще поставить дистрибутив на p5 и не заниматься самодеятельностью, типа точечного обновления.

Тему переношу в ALT Linux.

ОК. Просто я ее завел в разделе образования, полагая, что мои проблемы обновиться связаны именно с альтом школьной сборки. Хочется узнать успешные истории про обновления в случае, когда был установлен линукс мастер с диска первой помощи и затем он был обновлен до 5 версии. Значит мне обновляться из репозитариев не судьба?)
Что значит хакать и самодеятельностью. Исключительно пошагово и опираясь на инструкции - сам ничего не придумывал. Просто хотелось бы уже закончить эту тему и обновится уже до 5, а вы мне предлагаете качать по-новой. Если не ошибаюсь около 3 гигов образ.( У меня уже все пакеты скачены из p5).
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 07.12.2010 13:20

ska писал(а):
06.12.2010 11:55
ОК. Просто я ее завел в разделе образования, полагая, что мои проблемы обновиться связаны именно с альтом школьной сборки. Хочется узнать успешные истории про обновления в случае, когда был установлен линукс мастер с диска первой помощи и затем он был обновлен до 5 версии. Значит мне обновляться из репозитариев не судьба?)
Если не заниматься самодеятельностью, то вполне реально хоть до Sisyphus. Пока же я виду фрагментарные попытки залезть куда-то, уж извините.
Исключительно пошагово и опираясь на инструкции - сам ничего не придумывал.
Кто вам давал инструкцию по ковырянию бутсплеша?
У меня уже все пакеты скачены из p5.
Если все 30 ГБ репозитория, то проще собрать образ на месте. :)

Поверьте, будет проще скачать заново, чем заниматься самодеятельностью.
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 08.12.2010 06:51

Skull писал(а):
07.12.2010 13:20
ska писал(а):
06.12.2010 11:55
ОК. Просто я ее завел в разделе образования, полагая, что мои проблемы обновиться связаны именно с альтом школьной сборки. Хочется узнать успешные истории про обновления в случае, когда был установлен линукс мастер с диска первой помощи и затем он был обновлен до 5 версии. Значит мне обновляться из репозитариев не судьба?)
Если не заниматься самодеятельностью, то вполне реально хоть до Sisyphus. Пока же я виду фрагментарные попытки залезть куда-то, уж извините.
Исключительно пошагово и опираясь на инструкции - сам ничего не придумывал.
Кто вам давал инструкцию по ковырянию бутсплеша?
У меня уже все пакеты скачены из p5.
Если все 30 ГБ репозитория, то проще собрать образ на месте. :)

Поверьте, будет проще скачать заново, чем заниматься самодеятельностью.

Понял. Пока мне кто-нибудь не скажет, что у него была похожая ситуация (а именно установил со школьного диска альт линукс мастер,) и ему удалось успешно провести обновление до пятой версии, остаюсь при своих выводах. А именно.
При переходе с 4 на 4.1 у школьного альта приисходит явный затык с alterator-net-junior, а также непонятные траблы с gambas-ide. Дальнейшие неприятности тоже остаются "необъяснимыми". Например, после обновления на 4.1 тонкая полоска в загрузочном меню выглядит необяснимо и загадочно).
Что было неверного в моем "ковырянии" бутсплеша? Разве это неправильный способ сменить загрузочную тему. Я таким образом понял ваше "поставить новый брэндинг". В любом случае на стабильность работы системы это не повлияло (даже если в время загрузки я буду видеть консоль а не графику). Если оставить в стороне бутсплеш, как вы объясните "неразрешенные зависимости" при попытке обновится на версию пять? Все это для меня необъяснимо, поэтому возможно и объясняю может быть непонятно. Хотя, по-моему, вполне детально изложил)).
Скачены у меня конечно не все 30 ГБ , а те, которые по-умолчанию установлены на линукс мастере.

P.S. кстати а что значит поставить новый branding? :unsure:
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 08.12.2010 07:23

ska писал(а):
08.12.2010 06:51
P.S. кстати а что значит поставить новый branding? :unsure:
Это значит, что для смены бутлоадера требуется поставить новую версию пакетов brаnding-*, соответствующую дистрибутиву из нужного бранча, и запустить installkernel.
Skull
Спасибо сказали:

yaleks
Сообщения: 2121
Статус: вне статуса
ОС: Gentoo ~

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение yaleks » 12.12.2010 17:45

Skull писал(а):
02.12.2010 20:13
ska писал(а):
02.12.2010 10:33
Осталось разобраться с графикой входа в систему и с кде. Где заврешение работы?
Должен быть установлен kdm, а всякие xdm/gdm убраны.
Или создайте файл /etc/sysconfig/desktop и пропишите в нём

почему-то при обновлении с 4.0 до 4.1 это не работает.

+ чтобы обновить gambas пришлось руками удалить /usr/share/gambas2/help/help/doc/odbc, после этого обновилось до конца. Есть предположение, что из-за этой ошибки не отрабатываются какие-то postinstall тригеры.
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 21.12.2010 08:51

Skull писал(а):
07.12.2010 13:20
Поверьте, будет проще скачать заново, чем заниматься самодеятельностью.

Я все равно ничего не понимаю).
Скачал altlinux-5.0.1-school-master-i586-ru-install-dvd5.iso
Записал на диск. Загружаюсь стандартный процесс установки. До определенного момента...
Критическая ошибка установки
alterator-auth; Depends alterator (>=4.7-alt4)
The following packages have unmet dependences;

Оочень интересно. Открываю диск, смотрю в папку с рпм и вижу alterator-auth-0.10-alt2.noarch.rpm
Вопрос. Если я заменю этот пакет версией поновее, у меня получится установить?

P.S. качал с torrent.altlinux.ru
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение Skull » 21.12.2010 16:19

ska писал(а):
21.12.2010 08:51
Критическая ошибка установки
alterator-auth; Depends alterator (>=4.7-alt4)
The following packages have unmet dependences;
Проверяйте качество записи. Диск или криво скачен или криво записан.
Skull
Спасибо сказали:

ska
Сообщения: 202
ОС: ALTLinux School Master

Re: Решено: так как все-таки правильно обновить школьный линукс

Сообщение ska » 22.12.2010 11:24

Наврное, надо было не убирать галочку форматировать непосредственно перед установкой. Первый раз я устанавливал сверху на старый раздел без форматирования. Записал образ по-новой в винде и установил на этот раз с форматированием. Все установилось. Спасибо.
Спасибо сказали: