Решено: AltLinux Школьный Мастер 4.0 (FireBird 1.5.6> libstdc++.so.5)

Модератор: Skull

Аватара пользователя
Norway
Сообщения: 26
ОС: Debian

Решено: AltLinux Школьный Мастер 4.0

Сообщение Norway » 27.01.2011 10:34

Здравствуйте.
Проблема (для меня) следующая: Имеется выше упомянутый дистриб, на него нужно срочно поставить FireBird именно 1.5.х С более новой версией программа (наша разработка) работать не будет. Во время установки через скрипт, всё идёт нормально, запросило пароль и сразу наткнулось на ошибку, точнее на недостающий файл : libstdc++.so.5. Ошибка выглядит так:

Код: Выделить всё

 "/opt/firebird/bin/gsec: error while loading shared libraries:  libstdc++.so.5: can not open shared object file: No such file or directory"

Сама по себе установка завершена, но вот с этой ошибкой. Подскажите пожалуйста, что можно сделать в такой случае?
p.s. Новую версию дистрибутива не предлагать, т.к. мы как разработики должны поддерживать и эту версию тоже, т.к. в школах она многих есть. Заранее спасибо.
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Решено: AltLinux Школьный Мастер 4.0

Сообщение romuil » 27.01.2011 12:40

Код: Выделить всё

 rpm -qa | grep libstdc++

Показывайте сюда.
Также вот

Код: Выделить всё

 rpm -ql libstdc++3.3-3.3.4-alt7
/etc/buildreqs/packages/substitute.d/libstdc++3.3
/usr/lib/libstdc++.so.5
/usr/lib/libstdc++.so.5.0.7

У меня такой файл имеется.
Спасибо сказали:

Аватара пользователя
Norway
Сообщения: 26
ОС: Debian

Re: Решено: AltLinux Школьный Мастер 4.0

Сообщение Norway » 27.01.2011 12:57

Код: Выделить всё

libstdc++4.1-devel-4.1.1-alt11
libstdc++4.1-4.1.1-alt11

Везде где вы указали, у меня 4,1 версия :(
Может с каикх-то репозитариев стянуть можно?
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: AltLinux Школьный Мастер 4.0

Сообщение Skull » 27.01.2011 13:02

Norway писал(а):
27.01.2011 10:34
Проблема (для меня) следующая: Имеется выше упомянутый дистриб, на него нужно срочно поставить FireBird именно 1.5.х С более новой версией программа (наша разработка) работать не будет.
Обновляйте до http://altlinux.org/Branches/p5 и ставьте оттуда firebird-2.1.3.18185.0
Skull
Спасибо сказали:

Аватара пользователя
Norway
Сообщения: 26
ОС: Debian

Re: Решено: AltLinux Школьный Мастер 4.0

Сообщение Norway » 27.01.2011 13:07

Извините, я вроде указал точно, что мне нужен именно 1,5 FireBird и именно на этой версии AltLinux, т.к. сборка программ будет происходить на этой версии дистрибутива.

upd. Получилось! Поставил репозитории бекпортов, через синаптик 2 версию, затем отдельно через скрипт версию 1,5. Установка прошла гладко и процесс удачно стартовал. Вроде пока всё нормально. Спасибо большое за подсказки.
Спасибо сказали: