Решено: Помогите настроить драйвера ATI (Решено)

Модератор: Skull

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 26.01.2008 09:30

Здравствуйте.

Описание системы:
Видеокарточка: Sapphire Radeon X550
Монитор: SyncMaster 940BW (широкоформатный 1440x900)
OC: AltLinux Desktop 4.0

Описание проблемы:
Установил ОС, поставил драйвер fglrx, выбрал нужно разрешение, по при загрузке системы установилось разрешение 1024x768.
Графическая игрушка xmoto запускалась без проблем.
Никакие шаманские пляски не помогли.
Установил драйвер с сейта ati через инсталятор. Перезапустил комп, изменений не обнаружил.
Поменял драйвер (через alterator) на 'ati - ATI(generic)' разрешение установилось правильное (1440x900).
Но xmoto - тормозит зверско.
Программа "ATI Catalyst Control Center" не запукается, по причине "Драйвер ATI не установлен или функционирует не правильно".

погуглив, выяснил, что у меня не работает 3D:

Код: Выделить всё

[root@localhost ~]# glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2


В логе:

Код: Выделить всё

drmOpenDevice: node name is /dev/dri/card14
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.


Код: Выделить всё

[root@localhost ~]# modprobe radeon
WARNING: Error inserting drm (/lib/modules/2.6.18-std-smp-alt7/kernel/drivers/char/drm/drm.ko): Cannot allocate memory
FATAL: Error inserting radeon (/lib/modules/2.6.18-std-smp-alt7/kernel/drivers/char/drm/radeon.ko): Unknown symbol in module, or unknown parameter (see dmesg)
[root@localhost ~]# dmesg|tail
radeon: Unknown symbol drm_get_resource_start
radeon: Unknown symbol drm_vbl_send_signals
radeon: Unknown symbol drm_cleanup_pci
radeon: Unknown symbol drm_ati_pcigart_init
radeon: Unknown symbol drm_core_ioremap
radeon: Unknown symbol drm_mmap
radeon: Unknown symbol drm_order
radeon: Unknown symbol drm_ati_pcigart_cleanup
radeon: Unknown symbol drm_core_reclaim_buffers
radeon: Unknown symbol drm_release


На запрос в яндексе "Error inserting drm Cannot allocate memory" ничего внятного не находится.
Подскажите как решить проблему.


У вас нет необходимых прав для просмотра вложений в этом сообщении.
ОС Kubuntu 9.10
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение romuil » 26.01.2008 10:25

Ставить драйвер надо из дистрибутива.
Ошибка скорее всего просит

Код: Выделить всё

depmod -a

А драйвер ATI называется fglrx (проприетарный).
Спасибо сказали:

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Re: Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 26.01.2008 12:12

romuil писал(а):
26.01.2008 10:25
Ставить драйвер надо из дистрибутива.
Ошибка скорее всего просит

Код: Выделить всё

depmod -a

А драйвер ATI называется fglrx (проприетарный).


В альтераторе такого драйвера не нашёл, есть:
ati - ATI(generic)
fglrx - ATI Radeon, FireGL (fglrx) - рекомендовано
radeon - ATI Radeon

При включении любого драйвера кроме ati - ATI(generic), возникает проблема с разрешением монитора.
Про команду depmod - не понял.
ОС Kubuntu 9.10
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 26.01.2008 20:40

Lausiv писал(а):
26.01.2008 12:12
При включении любого драйвера кроме ati - ATI(generic), возникает проблема с разрешением монитора.



А в чем проблема с разрешением? Подредактируйте файл /etc/X11/xorg.conf. В нем должна быть секция "Screen". Вот например как у меня:

Код: Выделить всё

Section "Screen"
    Identifier "screen1"
    Device      "NVidia GeForce6600 GT"
    Monitor     "NEC|NEC MultiSync FE750+"
    DefaultColorDepth 24
    Subsection "Display"
        Depth       8
        Modes       "800x600" "640x400"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1600x1200" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection


Имена девайса и монитора -- произвольные, но они должны быть определены в соответствующих секциях файла. Потом идут подсекции Display для разных режимов глубины цвета, и в каждой подсекции указаны допустимые разрешения (первое в списке получается по умолчанию). Соотвественно в DefaultColorDepth указана дефолтная глубина цвета.

Исправьте свой файл в соответствии со своими потребностями.
Спасибо сказали:

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Re: Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 28.01.2008 17:49

Alexei_VM писал(а):
26.01.2008 20:40
Lausiv писал(а):
26.01.2008 12:12
При включении любого драйвера кроме ati - ATI(generic), возникает проблема с разрешением монитора.


А в чем проблема с разрешением? Подредактируйте файл /etc/X11/xorg.conf. В нем должна быть секция "Screen". Вот например как у меня:


Проблема в том, что нужное разрешение (1440x900) не появляется в списке доступных(Центр управления KDE). Максимальное доступное разрешение, которого я добился было 1280x1024, но оно меня не устраивает, т.к. у меня широкоформатный монитор (соотношение сторон 16:9, а не 4:3).
Настройки файла xorg.conf - первое, что я начал рыть, нарыл очень много инфы по нему, но к моему случаю ничего не подходило.
Более того, если при установки ОС в момент выбора драйвера видеокарты установить разрешение 1440x900 (в этом списке такое разрешение доступно) и в той же форме протестировать, то графический режим запускается, но запускается не в указанном разрешении, а в 1024x768 (это видно из меню монитора).

Кстати, и далее нужное разрешение доступно в списке альтератора, но недоступно в списке из настроек монитора через "Центр управления KDE".

Как только я поменял драйвер, разрешение появилось в списке "Центр управления KDE">Переферия>Дисплей.
Но, при этом стали наблюдаться некоторые притормаживания.

P.S. Под виндой я на этой же видюхе играл в довольно мощные игры типа Тёмный мессия от 1С, FEAR и т.п. Никаких тормозов не было.
ОС Kubuntu 9.10
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 28.01.2008 18:15

Lausiv писал(а):
28.01.2008 17:49
Настройки файла xorg.conf - первое, что я начал рыть, нарыл очень много инфы по нему, но к моему случаю ничего не подходило.


Подходило... неподходило... Открыть файл, найти нужную секцию (Screen), поглядеть с какой глубиной цвета работает по умолчанию, найти соответствующую подсекцию, вписать туда нужное разрешение. Работы ровно на 1 минуту.
Спасибо сказали:

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Re: Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 29.01.2008 20:03

Alexei_VM писал(а):
28.01.2008 18:15
Lausiv писал(а):
28.01.2008 17:49
Настройки файла xorg.conf - первое, что я начал рыть, нарыл очень много инфы по нему, но к моему случаю ничего не подходило.


Подходило... неподходило... Открыть файл, найти нужную секцию (Screen), поглядеть с какой глубиной цвета работает по умолчанию, найти соответствующую подсекцию, вписать туда нужное разрешение. Работы ровно на 1 минуту.


Вот мой файл настройки.
Всё, что ты предложил, я давно уже сдалал.
:angry: Разрешение нихрена не читается из этого файла. Повторяю по буквам Н-И-Х-Р-Е-Н-А не читается.
Редактироавние этого НЕ помогает.

Я об этом пишу в каждом посте.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
ОС Kubuntu 9.10
Спасибо сказали:

Grom
Сообщения: 260
ОС: Debian Etch, RHEL-5.4

Re: Решено: Помогите настроить драйвера ATI

Сообщение Grom » 29.01.2008 20:32

Судя по содержимому второго и третьего фрагметов логов в первом посте, ядро собрано без поддержки DRM, необходимого для запуска радеоновского драйвера. Попробуй пересобрать ядро, выставив такие опции, как тут рекомендовано в пункте 2.1.1.
Послужной список: Slackware-3.x, RedHat-4.x,5.x,6.x,7.x, FedoraCore-3, Debian Etch/Lenny
Осваиваю: RHEL-5.4
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение romuil » 29.01.2008 20:33

Modeline работает только в последнем драйвере fglrx, надо доустанавливать ядро 2.6.24 и новый драйвер к нему.
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 29.01.2008 23:45

Grom писал(а):
29.01.2008 20:32
Попробуй пересобрать ядро, выставив такие опции, как тут рекомендовано в пункте 2.1.1.


Сборка ядра для АЛЬТ -- занятие исключительно для разработчиков! Если вы в силах освоить _правильную_ сборку этого ядра, то добро пожаловать в kernel team.

Всем остальным достаточно знать, что ядро собрано со всеми необходимыми опциями. В том числе и с DRM=m.


Сам я в кривокарточках ATi ничего не понимаю, так что перенаправляю вопрос в список рассылки. Посмотрим, как там прокомментируют проблему.
Спасибо сказали:

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Re: Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 31.01.2008 16:29

Спасибо всем за помощь. Ценю.
Придётся дальше разбираться самому. :mellow:
ОС Kubuntu 9.10
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 31.01.2008 23:02

Lausiv писал(а):
31.01.2008 16:29
Спасибо всем за помощь. Ценю.
Придётся дальше разбираться самому. :mellow:



Вот что ответили в рассылке (это самый вменяемый ответ):

И так батенька по порядку. Во первых, определитесь какой драйвер вы
желаете использовать:
fglrx или radeon(ati). У каждого из них настройки свои.
Попробуйте использовать присловутую программку gtf. Ее вывод нужно
вставить в xorg.conf файл.
Должно помочь.

Во вторых, я вам не рекомендую ставить fglrx так как про него ходит дурная
слава(падение иксов, приложений kde,
не работает берил и т.д.). fglrx у меня лишь в два раза лучше цифры на
glxgears показывает.

Сейчас я перешел на драйвер "radeon" и поверьте просто счастлив. Все что
глючило не глючит, а 3D ускорение работает.



Перед тем как подгружать модуль "radeon" нужно сделать следующее:
1. Должным образом отредактировать xorg.conf файл (см. пример ниже) и
прописать драйвер "radeon".
2. Проверить загружен ли модуль fglrx (lsmod | grep fglrx)
2.1 Если в выводе присутствует данный модуль его надо удалить (modprobe
-r fglrx)
3. Загрузить модуль "radeon" (modprobe radeon)
4. Перезапустить X сервер.

Пример xorg.conf файла:
#############START###############

Section "ServerLayout"
Identifier "Minimal layout"
Screen "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "ImPS/2 Generic Wheel Mouse|0" "CorePointer"
Option "Pixmap" "32"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "ImPS/2 Generic Wheel Mouse|0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "SyncMaster|0"
DisplaySize 380 300
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection
# параметры Options для Section "Device" см. в man radeon
Section "Device"
Identifier "Card0|0"
Driver "radeon"
BusID "PCI:01:00:0"
Option "AGPMode" "8"
Option "ColorTiling" "on"
Option "EnablePageFlip" "on"
Option "AGPFastWrite" "on"
Option "AccelDFS" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0|0"
Monitor "SyncMaster|0"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624"
"800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624"
"800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624"
"800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624"
"800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624"
"800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "DRI"
Group "xgrp"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection

########end xorg.conf###########

P.S. В конце концов я полностью удалил все пакеты связанные с fglrx. Да и
не забудте выполнить скрипт
/usr/libexec/X11/drv.d/x11 для правильного выставления симв. ссылок.


К сожалению, АТи не любит линукс-пользователей, а разработчики АЛЬТ не любят АТи-пользователей :(
Спасибо сказали:

Lausiv
Сообщения: 12
ОС: Kubuntu 9.04

Re: Решено: Помогите настроить драйвера ATI

Сообщение Lausiv » 04.02.2008 17:13

Спасибо, ЗАРАБОТАЛО!!! :D
ОС Kubuntu 9.10
Спасибо сказали:

jabx
Сообщения: 402
ОС: OpenSuSE 11.4 / Alt 6.0

Re: Решено: Помогите настроить драйвера ATI

Сообщение jabx » 27.05.2008 12:44

Недавно делал пробную установку Alt Linux 4 Lite. Карточка Sapphire Radeon X550.
Кроме VESA драйвера ничего нормально не завелось, ни с ATI(Generic) ни с fglrx.
Заводить ни чего не пытался (особой надобности не было), но осадок неприятный остался, выбор драйвера вроде есть, но не работает.
Или я не прав, просто мне с железом не повезло, а у других все работает нормально без танцев с бубном?
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 27.05.2008 14:27

jabx писал(а):
27.05.2008 12:44
Или я не прав, просто мне с железом не повезло, а у других все работает нормально без танцев с бубном?


Вы правы, вам не повезло с железом, раз вы купили АТи уже сейчас, а не через два года. :)

Никто ни про какие танцы с бубном вам не расскажет, пока не увидит хотя бы содержимое /etc/X11/xorg.conf и /var/log/Xorg.0.log
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Решено: Помогите настроить драйвера ATI

Сообщение Skull » 29.05.2008 12:24

jabx писал(а):
27.05.2008 12:44
Недавно делал пробную установку Alt Linux 4 Lite. Карточка Sapphire Radeon X550.
Кроме VESA драйвера ничего нормально не завелось, ни с ATI(Generic) ни с fglrx.
Заводить ни чего не пытался (особой надобности не было), но осадок неприятный остался, выбор драйвера вроде есть, но не работает.
Или я не прав, просто мне с железом не повезло, а у других все работает нормально без танцев с бубном?
В данной ситуации спасает обновление fglrx из 4.0/branch.
Skull
Спасибо сказали:

pchelovod
Сообщения: 4

Re: Решено: Помогите настроить драйвера ATI

Сообщение pchelovod » 29.05.2008 13:59

В данной ситуации спасает обновление fglrx из 4.0/branch.

А можете подсказать. Делал обновление fglrx из rpm пакетов, обновилось попросив доставить (тоже качал и ставил отдельно (ну нет у меня дома широкого канала в интернет)) пакеты. Теперь при перезагрузке в экране выборе системы целая куча новых пунктов. Как их оттуда убрать?
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 29.05.2008 14:09

pchelovod писал(а):
29.05.2008 13:59
Теперь при перезагрузке в экране выборе системы целая куча новых пунктов. Как их оттуда убрать?


Подредактировать (осторожно) /etc/lilo.conf и выполнить команду lilo.
Спасибо сказали:

pchelovod
Сообщения: 4

Re: Решено: Помогите настроить драйвера ATI

Сообщение pchelovod » 29.05.2008 14:26

Alexei_VM писал(а):
29.05.2008 14:09
pchelovod писал(а):
29.05.2008 13:59
Теперь при перезагрузке в экране выборе системы целая куча новых пунктов. Как их оттуда убрать?


Подредактировать (осторожно) /etc/lilo.conf и выполнить команду lilo.

Сенкс. С большущим трудом запустилась ATI HD2600 в родном разрешении, но 3D еще нет. Будем дальше копаться.
Спасибо сказали:

Аватара пользователя
Specialist
Сообщения: 83
ОС: XP SP3>AltDesktop4

Re: Решено: Помогите настроить драйвера ATI

Сообщение Specialist » 03.06.2008 17:09

pchelovod писал(а):
29.05.2008 14:26
Alexei_VM писал(а):
29.05.2008 14:09
pchelovod писал(а):
29.05.2008 13:59
Теперь при перезагрузке в экране выборе системы целая куча новых пунктов. Как их оттуда убрать?


Подредактировать (осторожно) /etc/lilo.conf и выполнить команду lilo.

Сенкс. С большущим трудом запустилась ATI HD2600 в родном разрешении, но 3D еще нет. Будем дальше копаться.

У меня все точно также: Драйвер встал, куча пунктов при загрузке системы. И очень сильно тормозят окна, даже в браузере не возможно страничку пролистать. Как это исправить ? И наконец-то включилось родное разрешение моника(1680х1050) А ж приятно смотреть стало.

Код: Выделить всё

glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting             LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
Установка Linux(Это я уже умею :) ) > Установка драйвера на видеокарту ATI(Тут застрял) > KDE 4 + CompizFusion
Fan Motorola E398
Спасибо сказали:

Аватара пользователя
BaZilio
Сообщения: 457
Статус: Say оПХБЕР again!

Re: Решено: Помогите настроить драйвера ATI

Сообщение BaZilio » 04.06.2008 09:25

Внимательно посмотрите /var/log/Xorg.0.log на предмет ошибок, выдаваемых fglrx.

Windows XP:
Netbook - Acer Aspire One A150.
Debian Squeeze amd64:
Laptop - Acer TravelMate 5520G.
Laptop_work - Toshiba Satellite C660.
Windows 7 x64:
Desktop - Core2Duo 6600 2.4GHz/6 GB/i965/GeForce 9500GT.

4 the lulz!
Спасибо сказали:

Аватара пользователя
Specialist
Сообщения: 83
ОС: XP SP3>AltDesktop4

Re: Решено: Помогите настроить драйвера ATI

Сообщение Specialist » 05.06.2008 18:13

BaZilio писал(а):
04.06.2008 09:25
Внимательно посмотрите /var/log/Xorg.0.log на предмет ошибок, выдаваемых fglrx.

Вот ошибка тут примерно начинается

Код: Выделить всё

(II) Reloading /usr/lib/X11/modules/linux//libfglrxdrm.so
(II) fglrx(0): Depth moves disabled by default
(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): cpuFlags: 0x4000000f
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
 (**) fglrx(0): ATI GART size: 256 MB
(II) fglrx(0): [pci] find AGP GART
(II) fglrx(0): [agp] Mode=0x1f000a0b bridge: 0x1106/0x0269
(II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
(II) fglrx(0): [agp] AGP v3 disable mask   0x00000000
(II) fglrx(0): [agp] enabling AGP with mode=0x1f000b0a
(II) fglrx(0): [agp] Remapping MC AGP space (new MCAGPBase = 0xe0000000, MCAGPSize = 0x10000000)
(II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f000302)
(II) fglrx(0): [agp] graphics chipset has AGP v3.0 (native mode)
[u](EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1007)[/u]
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
(==) fglrx(0): UseFastTLS=0
(==) fglrx(0): BlockSignalsOnLock=1
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
    [0] 0   0   0xfeaf0000 - 0xfeafffff (0x10000) MX[B]
    [1] 0   0   0xb0000000 - 0xbfffffff (0x10000000) MX[B]
    [2] -1  0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    [3] -1  0   0x000f0000 - 0x000fffff (0x10000) MX[B]
    [4] -1  0   0x000c0000 - 0x000effff (0x30000) MX[B]
    [5] -1  0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
    [6] -1  0   0xfeaec000 - 0xfeaeffff (0x4000) MX[B]
    [7] -1  0   0xfebffc00 - 0xfebffcff (0x100) MX[B]
    [8] -1  0   0xfebff800 - 0xfebff8ff (0x100) MX[B]
    [9] -1  0   0xfebe0000 - 0xfebeffff (0x10000) MX[B]
    [10] -1 0   0xe0000000 - 0xdfffffff (0x0) MX[B]O
    [11] -1 0   0xfeac0000 - 0xfeadffff (0x20000) MX[B](B)
    [12] -1 0   0xfeaf0000 - 0xfeafffff (0x10000) MX[B](B)
    [13] -1 0   0xb0000000 - 0xbfffffff (0x10000000) MX[B](B)
    [14] 0  0   0x000a0000 - 0x000affff (0x10000) MS[B](OprU)
    [15] 0  0   0x000b0000 - 0x000b7fff (0x8000) MS[B](OprU)
    [16] 0  0   0x000b8000 - 0x000bffff (0x8000) MS[B](OprU)
    [17] 0  0   0x0000a800 - 0x0000a8ff (0x100) IX[B]
    [18] -1 0   0x0000ffff - 0x0000ffff (0x1) IX[B]
    [19] -1 0   0x00000000 - 0x000000ff (0x100) IX[B]
    [20] -1 0   0x0000d000 - 0x0000d0ff (0x100) IX[B]
    [21] -1 0   0x0000cc00 - 0x0000cc1f (0x20) IX[B]
    [22] -1 0   0x0000c800 - 0x0000c81f (0x20) IX[B]
    [23] -1 0   0x0000c400 - 0x0000c41f (0x20) IX[B]
    [24] -1 0   0x0000c000 - 0x0000c01f (0x20) IX[B]
    [25] -1 0   0x0000fc00 - 0x0000fc0f (0x10) IX[B]
    [26] -1 0   0x0000d400 - 0x0000d4ff (0x100) IX[B]
    [27] -1 0   0x0000d800 - 0x0000d80f (0x10) IX[B]
    [28] -1 0   0x0000dc00 - 0x0000dc03 (0x4) IX[B]
 [29] -1 0   0x0000e000 - 0x0000e007 (0x8) IX[B]
    [30] -1 0   0x0000e400 - 0x0000e403 (0x4) IX[B]
    [31] -1 0   0x0000e800 - 0x0000e807 (0x8) IX[B]
    [32] -1 0   0x0000bc00 - 0x0000bc07 (0x8) IX[B]
    [33] -1 0   0x0000b800 - 0x0000b81f (0x20) IX[B]
    [34] -1 0   0x0000a800 - 0x0000a8ff (0x100) IX[B](B)
    [35] 0  0   0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    [36] 0  0   0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(II) fglrx(0): detected X.org 7.1.0.0
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xf0000000 FBMappedSize: 0x10000000
(==) fglrx(0): Write-combining range (0xb0000000,0x10000000)
(II) fglrx(0): FBMM initialized for area (0,0)-(1728,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1728,1050) (front color buffer - assumption)
(II) fglrx(0): Largest offscreen area available: 1728 x 7141
(==) fglrx(0): Backing store disabled
(II) Loading extension FGLRXEXTENSION
(II) Loading extension ATITVOUT
(WW) fglrx(0): Textured Video not supported without DRI enabled.
(II) LoadModule: "glesx"

(II) Loading /usr/lib/X11/modules//glesx.so
(II) Module glesx: vendor="X.Org Foundation"
    compiled for 7.1.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
(II) Loading extension GLESX
(II) fglrx(0): GLESX enableFlags = 10
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled
(II) fglrx(0): Finished Initialize PPLIB!
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor

Видюха у меня hd2400Pro !AGP!
Установка Linux(Это я уже умею :) ) > Установка драйвера на видеокарту ATI(Тут застрял) > KDE 4 + CompizFusion
Fan Motorola E398
Спасибо сказали:

grey_fox
Сообщения: 24

Re: Решено: Помогите настроить драйвера ATI

Сообщение grey_fox » 07.10.2008 09:41

Тема вроде как умерла, но проблема осталась.....
пользователи АТИ! кто нибудь ставил альт4 на видюху HD4800 серии?
просто ни на одном форуме не нашел вопросов по этим видеокартам,
одно из двух: либо проблем с ними нет ( :crazy:), либо никто с ними еще не сталкивался.
в общем из чего вопрос возник: собираюсь приобрести видюху данной серии, а именно: Palit HD4870
вот и хотелось бы узнать, стоит оно того или нет....
или не мучаться и приобрести GF8600 - 8800?
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Решено: Помогите настроить драйвера ATI

Сообщение Alexei_VM » 07.10.2008 19:22

grey_fox писал(а):
07.10.2008 09:41
или не мучаться и приобрести GF8600 - 8800?


АТи и "не мучаться" -- несовместимо. В настоящее время. В будущем ситуация может быть улучшится.
Спасибо сказали:

Аватара пользователя
MINZDRAVV
Сообщения: 33
ОС: ALKD7 х64 Branch Unix systemd

Re: Решено: Помогите настроить драйвера ATI

Сообщение MINZDRAVV » 08.01.2010 21:51

Подскажите пожалуйста почему драйвера для ATI, c ATI-видией работать отказываются?

Код: Выделить всё

[root@localhost ~]# rpm -qa | grep fglrx
kernel-modules-fglrx-std-def-1.0.8.47.1-alt2.132633.8.M41.4
fglrx-tools-8.47.1-alt1
fglrx_glx-8.47.1-alt1
[root@localhost ~]#

Код: Выделить всё

[root@localhost ~]# lspci | grep ati
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
01:05.0 VGA compatible controller: ATI Technologies Inc Device 9710
[root@localhost ~]#


У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали: