Проблемы с ALT 4.1

Модератор: Skull

Lopus
Сообщения: 57

Проблемы с ALT 4.1

Сообщение Lopus » 01.06.2009 22:42

Какой самый простой способ замены apt-get autoremove в ALT ?

Не нашёл в инете решения проблемы со звуком после обновления. Пропал и появляться не хочет.
Пробовал удалять всё кроме kernel-module-alsa-std-def, переустанавливал его.. не помогает. Все -oss пробовал удалять, alsaconf не запускается, alsamixer в норме.

Кнопка Tab в bash работает только на директории и программы, а на параметры (как в debian/ubuntu: apti<tab> in<tab> apa<tab>, получается aptitude install apache2) нет. Можно как-то добавить сию возможность?
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Проблемы с ALT 4.1

Сообщение romuil » 01.06.2009 22:48

Потрудитесь и упорядочите поток мыслей так, чтобы стало понятно.
Спасибо сказали:

Lopus
Сообщения: 57

Re: Проблемы с ALT 4.1

Сообщение Lopus » 01.06.2009 22:54

Дык, пальцы за мыслями не успевают :)

1. Чем заменить apt-get autoremove?
2. Не работает звук после обновления.
3. Как расширить функциональность кнопки tab в консоле (bash) ?

Так проще?
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Проблемы с ALT 4.1

Сообщение romuil » 01.06.2009 22:57

А теперь один вопрос - одна тема.
С подробностями и указанием версий, оборудования и логами.
Спасибо сказали:

Аватара пользователя
Skull
Модератор
Сообщения: 2089
ОС: ALT Linux

Re: Проблемы с ALT 4.1

Сообщение Skull » 04.06.2009 19:09

Lopus писал(а):
01.06.2009 22:54
1. Чем заменить apt-get autoremove?
Никак. RPM этого не позволяет.

Код: Выделить всё

2. Не работает звук после обновления.

Код: Выделить всё

apt-get install update-kernel && update-kernel

3. Как расширить функциональность кнопки tab в консоле (bash) ?
Использовать zsh (bash-completion глючит), а для apt-get install использовать apt-shell.
Skull
Спасибо сказали:

Lopus
Сообщения: 57

Re: Проблемы с ALT 4.1

Сообщение Lopus » 04.06.2009 19:50

Skull писал(а):
04.06.2009 19:09

Код: Выделить всё

2. Не работает звук после обновления.

Код: Выделить всё

apt-get install update-kernel && update-kernel

Поставил update-kernel, запускаю, а мне пишут:
bash: update-kernel: команда не найдена
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Проблемы с ALT 4.1

Сообщение Alexei_VM » 04.06.2009 21:20

Lopus писал(а):
04.06.2009 19:50
bash: update-kernel: команда не найдена


Читайте тут.
Спасибо сказали:

Lopus
Сообщения: 57

Re: Проблемы с ALT 4.1

Сообщение Lopus » 04.06.2009 22:37

Alexei_VM писал(а):
04.06.2009 21:20
Читайте тут.

Это я знаю. Из под рута и запускаю.
Спасибо сказали:

Alexei_VM
Сообщения: 765
ОС: ALT Linux Sisyphus

Re: Проблемы с ALT 4.1

Сообщение Alexei_VM » 04.06.2009 23:20

Lopus писал(а):
04.06.2009 22:37
Alexei_VM писал(а):
04.06.2009 21:20
Читайте тут.

Это я знаю. Из под рута и запускаю.


Или вы врете ("установил update-kernel'), или вы врете, что прочитали мою ссылку, или вы не умеете читать.

Во всех трех случаях помочь вам невозможно.
Спасибо сказали:

Lopus
Сообщения: 57

Re: Проблемы с ALT 4.1

Сообщение Lopus » 05.06.2009 00:14

Alexei_VM писал(а):
04.06.2009 23:20
Lopus писал(а):
04.06.2009 22:37
Alexei_VM писал(а):
04.06.2009 21:20
Читайте тут.

Это я знаю. Из под рута и запускаю.


Или вы врете ("установил update-kernel'), или вы врете, что прочитали мою ссылку, или вы не умеете читать.

Во всех трех случаях помочь вам невозможно.

Вот, пожалуйста..
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Аватара пользователя
romuil
Сообщения: 2095
Статус: Ромунцель
ОС: ALTLinux Sisyphus

Re: Проблемы с ALT 4.1

Сообщение romuil » 10.06.2009 19:00

!Предупреждение от модератора
Ещё одна попытка разборок - буду наказывать!
Спасибо сказали: