logrotate в ALTLinux

Модератор: Skull

kitty
Сообщения: 2

logrotate в ALTLinux

Сообщение kitty » 14.07.2009 13:26

Как известно, по умолчанию logrotate переименовывает логи таким способом: самый новый лог идет под именем maillog.1, вчерашний maillog.2. и т.д.
Нужно, чтобы в имени присутствовала дата. Но опция dateext в ALTLinux почему-то неизвестна! Может кто подскажет выход?)
Формат имени логов требуется примерно такой: maillog_Jul14 (либо как при использовании dateext: maillog.20090714).
Спасибо сказали:

Аватара пользователя
skeletor
Сообщения: 1224
Статус: Диффурщик
ОС: FreeBSD

Re: logrotate в ALTLinux

Сообщение skeletor » 15.07.2009 12:48

Покажите конфиг, который у вас не работает и опишите действия, которые делаете. У меня (правда на Генту) всё нормально работает.
"Винда съела дрова и резет здесь не фурычит"
"Все говорят, что у меня /dev/hands кривой и я всё делаю через /dev/ass. А у меня этих файлов вообще нет!"
Спасибо сказали:

kitty
Сообщения: 2

Re: logrotate в ALTLinux

Сообщение kitty » 15.07.2009 13:57

Содержимое файла, размещенного в /etc/logrotate.d:

/var/local/mailarch/in_ext {
daily
missingok
rotate 7
dateext
olddir /var/local/mailarch/in_ext_rotated
notifempty
}

При попытке ротировать имею что-то вроде такого сообщения: unknown option 'dateext' -- ignoring line... (К слову, logrotate версии 3.6.2).
Теперь вот приходится изобретать датирование после postrotate. Но обидно выдумывать какие-то алгоритмы для вставки даты в имя, когда есть такая замечательная опция dateext, вставляющая эту самую дату на автомате :(
Спасибо сказали:

Аватара пользователя
skeletor
Сообщения: 1224
Статус: Диффурщик
ОС: FreeBSD

Re: logrotate в ALTLinux

Сообщение skeletor » 15.07.2009 14:12

Попробуй обновить версию. У меня logrotate-3.7.8. Может из-за этого не понимает dateext
"Винда съела дрова и резет здесь не фурычит"
"Все говорят, что у меня /dev/hands кривой и я всё делаю через /dev/ass. А у меня этих файлов вообще нет!"
Спасибо сказали: