No valid modes for "CRT-1:1600x900"; (Отвалилось разрешение nvidia)

Модератор: Модераторы разделов

Аватара пользователя
Anguis
Сообщения: 212
ОС: Manjaro 17

No valid modes for "CRT-1:1600x900";

Сообщение Anguis » 13.12.2017 10:01

Привет всем!
Вкратце опишу проблему. С неделю назад внезапно что то случилось то ли с драйвером видеокарты, то ли с самой видеокартой, то ли с монитором. Проприетарный драйвер nvidia больше не определяет монитор и нет возможности задать верное разрешение.
Операционка - Manjaro, на основе Арча. Поэтому и пишу сюда, на профильном ресурсе не помогли..
в общем ссылка на тему на профильном ресурсе для тех кому интересно что я уже делал - https://manjaro.ru/blog/manjaro-kde-edition...zresheniem.html
Для тех, кому не интересно xorg.log:

Код: Выделить всё

[   295.627]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[   295.628] X Protocol Version 11, Revision 0
[   295.628] Build Operating System: Linux 4.9.54-1-lts x86_64
[   295.629] Current Operating System: Linux anguis 4.14.3-1-MANJARO #1 SMP PREEMPT Thu Nov 30 14:22:30 UTC 2017 x86_64
[   295.629] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 root=UUID=ac2d7f2d-f57b-4265-ab4d-8120599ce2a4 rw resume=UUID=5ee3db79-4998-4715-9784-a62afc59833c
[   295.630] Build Date: 12 October 2017  09:59:53PM
[   295.631]
[   295.631] Current version of pixman: 0.34.0
[   295.632]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   295.632] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   295.634] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  5 11:13:00 2017
[   295.634] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   295.635] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   295.635] (==) ServerLayout "Layout0"
[   295.635] (**) |-->Screen "Screen0" (0)
[   295.635] (**) |   |-->Monitor "Monitor0"
[   295.635] (**) |   |-->Device "Device0"
[   295.635] (**) |-->Input Device "Keyboard0"
[   295.635] (**) |-->Input Device "Mouse0"
[   295.635] (==) Automatically adding devices
[   295.635] (==) Automatically enabling devices
[   295.635] (==) Automatically adding GPU devices
[   295.635] (==) Automatically binding GPU devices
[   295.635] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   295.635] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   295.635]     Entry deleted from font path.
[   295.635] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   295.635]     Entry deleted from font path.
[   295.635]     (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   295.635] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   295.635]     Entry deleted from font path.
[   295.635]     (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   295.635] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/OTF/
[   295.635] (==) ModulePath set to "/usr/lib/xorg/modules"
[   295.635] (**) Extension "Composite" is enabled
[   295.635] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   295.635] (WW) Disabling Keyboard0
[   295.635] (WW) Disabling Mouse0
[   295.635] (II) Loader magic: 0x55a28f2ddd60
[   295.635] (II) Module ABI versions:
[   295.635]     X.Org ANSI C Emulation: 0.4
[   295.635]     X.Org Video Driver: 23.0
[   295.635]     X.Org XInput driver : 24.1
[   295.635]     X.Org Server Extension : 10.0
[   295.635] (++) using VT number 2

[   295.635] (--) controlling tty is VT number 2, auto-enabling KeepTty
[   295.637] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c2
[   295.637] (II) xfree86: Adding drm device (/dev/dri/card0)
[   295.637] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[   295.638] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules"
[   295.638] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[   295.638] (--) PCI:*(0:1:0:0) 10de:0f00:1458:3544 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[   295.638] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   295.638] (II) LoadModule: "glx"
[   295.638] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[   295.641] (II) Module glx: vendor="NVIDIA Corporation"
[   295.641]     compiled for 4.0.2, module version = 1.0.0
[   295.641]     Module class: X.Org Server Extension
[   295.641] (II) NVIDIA GLX Module  384.98  Thu Oct 26 14:35:55 PDT 2017
[   295.641] (II) LoadModule: "nvidia"
[   295.641] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   295.641] (II) Module nvidia: vendor="NVIDIA Corporation"
[   295.641]     compiled for 4.0.2, module version = 1.0.0
[   295.641]     Module class: X.Org Video Driver
[   295.641] (II) NVIDIA dlloader X Driver  384.98  Thu Oct 26 14:06:45 PDT 2017
[   295.641] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   295.641] (II) systemd-logind: releasing fd for 226:0
[   295.642] (II) Loading sub module "fb"
[   295.642] (II) LoadModule: "fb"
[   295.642] (II) Loading /usr/lib/xorg/modules/libfb.so
[   295.642] (II) Module fb: vendor="X.Org Foundation"
[   295.642]     compiled for 1.19.5, module version = 1.0.0
[   295.642]     ABI class: X.Org ANSI C Emulation, version 0.4
[   295.642] (II) Loading sub module "wfb"
[   295.642] (II) LoadModule: "wfb"
[   295.642] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   295.642] (II) Module wfb: vendor="X.Org Foundation"
[   295.642]     compiled for 1.19.5, module version = 1.0.0
[   295.642]     ABI class: X.Org ANSI C Emulation, version 0.4
[   295.642] (II) Loading sub module "ramdac"
[   295.642] (II) LoadModule: "ramdac"
[   295.642] (II) Module "ramdac" already built-in
[   295.643] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   295.643] (==) NVIDIA(0): RGB weight 888
[   295.643] (==) NVIDIA(0): Default visual is TrueColor
[   295.643] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   295.643] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[   295.643] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[   295.643] (**) NVIDIA(0): Enabling 2D acceleration
[   295.954] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   295.954] (--) NVIDIA(0):     CRT-0
[   295.954] (--) NVIDIA(0):     CRT-1 (boot)
[   295.954] (--) NVIDIA(0):     DFP-0
[   295.954] (--) NVIDIA(0):     DFP-1
[   295.955] (II) NVIDIA(0): NVIDIA GPU GeForce GT 630 (GF108) at PCI:1:0:0 (GPU-0)
[   295.955] (--) NVIDIA(0): Memory: 2097152 kBytes
[   295.955] (--) NVIDIA(0): VideoBIOS: 70.08.aa.00.00
[   295.955] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   295.957] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   295.957] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   295.957] (--) NVIDIA(GPU-0):
[   296.033] (--) NVIDIA(GPU-0): CRT-1: connected
[   296.033] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[   296.033] (--) NVIDIA(GPU-0):
[   296.035] (--) NVIDIA(GPU-0): DFP-0: disconnected
[   296.035] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[   296.035] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[   296.035] (--) NVIDIA(GPU-0):
[   296.035] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   296.035] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   296.035] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   296.035] (--) NVIDIA(GPU-0):
[   296.036] (WW) NVIDIA(0): No valid modes for "CRT-1:1600x900"; removing.
[   296.036] (WW) NVIDIA(0):
[   296.036] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[   296.036] (WW) NVIDIA(0):     "nvidia-auto-select".
[   296.036] (WW) NVIDIA(0):
[   296.036] (II) NVIDIA(0): Validated MetaModes:
[   296.036] (II) NVIDIA(0):     "CRT-1:nvidia-auto-select"
[   296.036] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[   296.037] (WW) NVIDIA(0): CRT-1 does not have an EDID, or its EDID does not contain a
[   296.037] (WW) NVIDIA(0):     maximum image size; cannot compute DPI from CRT-1's EDID.
[   296.037] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[   296.037] (--) Depth 24 pixmap format is 32 bpp
[   296.037] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[   296.037] (II) NVIDIA:     access.
[   296.039] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   296.039] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   296.039] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   296.039] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   296.039] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   296.039] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   296.039] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   296.039] (II) NVIDIA(0):     Config Options in the README.
[   296.052] (II) NVIDIA(0): Setting mode "CRT-1:nvidia-auto-select"
[   296.105] (==) NVIDIA(0): Disabling shared memory pixmaps
[   296.105] (==) NVIDIA(0): Backing store enabled
[   296.105] (==) NVIDIA(0): Silken mouse enabled
[   296.105] (**) NVIDIA(0): DPMS enabled
[   296.105] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[   296.105] (WW) NVIDIA(0): Option "NoLogo" is not used
[   296.105] (II) Loading sub module "dri2"
[   296.105] (II) LoadModule: "dri2"
[   296.105] (II) Module "dri2" already built-in
[   296.105] (II) NVIDIA(0): [DRI2] Setup complete
[   296.105] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   296.105] (--) RandR disabled
[   296.107] (II) Initializing extension GLX
[   296.108] (II) Indirect GLX disabled.


Еще что интересно. До этого случая я выставил разрешение для загрузчика grub (gfxmode) в 1280х800 (это не мое, но отображалось нормально, мое не поддерживается framebuffer) и оно отображалось нормально. Но после монитор при загрузке стал выводить - out of range и пришлось сменить разрешение на 1024х768..
И при загрузке с live монитор выдает out of range. WTF?? При этом nouveau работает нормально...
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 13463
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: No valid modes for "CRT-1:1600x900";

Сообщение Bizdelnick » 13.12.2017 10:59

Anguis писал(а):
13.12.2017 10:01
При этом nouveau работает нормально

Казалось бы, выход очевиден.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
Anguis
Сообщения: 212
ОС: Manjaro 17

Re: No valid modes for "CRT-1:1600x900";

Сообщение Anguis » 13.12.2017 12:05

Bizdelnick писал(а):
13.12.2017 10:59
Anguis писал(а):
13.12.2017 10:01
При этом nouveau работает нормально

Казалось бы, выход очевиден.

не очевиден. это костыль а не выход. меня очень беспокоит out of range там где раньше все было ок..
Спасибо сказали:

Вернуться в «Arch Linux»