Проблема с обновлением

Модератор: Модераторы разделов

amid88
Сообщения: 92

Проблема с обновлением

Сообщение amid88 »

Прошу сильно не пинать, пару месяцев как пробую Arch. Очередное обновление командой pacman -Syu закончилось ошибкой. Попробовал обновиться с графического интерфейса Pacman, тоже ошибка,предложил удалить какой то пакет, на что я согласился. Обновление теперь прошло успешно, но пропал графический Pacman. Попробовал его переустановить, получаю такую ошибку:

[ut4nj@radio ~]$ yay -S pamac-aur-git --noconfirm
:: Доступно 2 источников для pamac-aur-git:
:: Репозиторий AUR
1) pamac-aur-git 2) pamac-all

Введите номер (по умолчанию = 1): 1
-> Невозможно найти все требуемые пакеты:
pacman<5.3 (требуется пакету: pamac-aur-git)
[ut4nj@radio ~]$

Если я верно понимаю, нужен pacman версии 5.3, а стоит версии 6.0.0.
Как исправить положение?

P.S. Видимо я мутно объяснил проблему. Наверное при решении проблемы при обновлении я удалил pamac и не могу его переустановить.
Спасибо сказали:

Аватара пользователя
RusWolf
Сообщения: 424
ОС: ArchLinux 86x64

Re: Проблема с обновлением

Сообщение RusWolf »

Видимо просто надо пока не пользоваться pamac-aur.
Новая версия yay прекрасно работает с pacman 6.0
Добавлено (21:29):
А если так хочется pamac-aur:
Снимок экрана в 2021-06-03 21-23-13.png
то держи либу -
libalpm.so.12.gz
положить в /usr/lib
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

amid88
Сообщения: 92

Re: Проблема с обновлением

Сообщение amid88 »

Большое спасибо, положил либу в /usr/lib, а дальше как восстановить pamac-aur?
Спасибо сказали:

Аватара пользователя
RusWolf
Сообщения: 424
ОС: ArchLinux 86x64

Re: Проблема с обновлением

Сообщение RusWolf »

amid88 писал(а):
04.06.2021 07:31
Большое спасибо, положил либу в /usr/lib
Надеюсь из архива либу выташил?
amid88 писал(а):
04.06.2021 07:31
а дальше как восстановить pamac-aur?
Должен работать сразу без проблем.
Если шаловливыми ручками полазил, то поставь заново готовый пакет.
https://repo.archlinuxcn.org/x86_64/pamac-aur-10.1.2-1-x86_64.pkg.tar.zst
Спасибо сказали: