Avertv тюнер (помогите!!!)

Установка, настройка TV-тюнеров, видеокамер, веб-камер, плат видеозахвата, flash(MP3)-плееры

Модератор: Модераторы разделов

Mag
Сообщения: 6
ОС: Mandriva 2007.1 Free

Avertv тюнер

Сообщение Mag »

Добрый день! Установил себе Mandriva 2007.1. В Линуксе почти полный чайник:)) Имееется TVтюнер AverTV Studio 307. Я знаю, что тут это сто раз обсуждалось, прежде чем написать сюда, я два дня читал этот форум:)) Но все таки есть проблемы с настройкой тюнера. Помогите плз!

При установке линукса, установщик нашел тв тюнер, я там указал свою модель. Если зайти - Mandriva-Система-Настройки-Настройки компьютера, там вкладка Оборудование - настройка ТВ тюнера, то там в списке - модель карты - avertv studio 307, тип твтюнера - автоопределение.

Запускаю TVTime - он пишет NO SIGNAL, а снизу Cannot open capture device /dev/video0. Посмотрел я в папке /dev - там нет никаких video0.

Насколько я понял из этого форума, у меня стоит чип saa7134, в папке /lib/modules/2.6.17-13mdv/kernel/drivers/media/video нет папки с названием этого чипа. Подозреваю, что где то тут проблема.
Комплект исходников ядра установил, в нем есть saa7134.
Версия ядра - 2.6.17-13mdv

Как мне поставить для него драйвера? Если можно плз, объясните максимально подробно, а то я пока плохо понимаю.

Спасибо и прошу прощения за возможно глупые вопросы :blush:
Спасибо сказали:

Аватара пользователя
desperate
Сообщения: 228
ОС: Debian Lenny

Re: Avertv тюнер

Сообщение desperate »

Mag писал(а):
29.04.2007 15:25
Добрый день! Установил себе Mandriva 2007.1. В Линуксе почти полный чайник:)) Имееется TVтюнер AverTV Studio 307. Я знаю, что тут это сто раз обсуждалось, прежде чем написать сюда, я два дня читал этот форум:)) Но все таки есть проблемы с настройкой тюнера. Помогите плз!

При установке линукса, установщик нашел тв тюнер, я там указал свою модель. Если зайти - Mandriva-Система-Настройки-Настройки компьютера, там вкладка Оборудование - настройка ТВ тюнера, то там в списке - модель карты - avertv studio 307, тип твтюнера - автоопределение.

Запускаю TVTime - он пишет NO SIGNAL, а снизу Cannot open capture device /dev/video0. Посмотрел я в папке /dev - там нет никаких video0.

Насколько я понял из этого форума, у меня стоит чип saa7134, в папке /lib/modules/2.6.17-13mdv/kernel/drivers/media/video нет папки с названием этого чипа. Подозреваю, что где то тут проблема.
Комплект исходников ядра установил, в нем есть saa7134.
Версия ядра - 2.6.17-13mdv

Как мне поставить для него драйвера? Если можно плз, объясните максимально подробно, а то я пока плохо понимаю.

Спасибо и прошу прощения за возможно глупые вопросы :blush:

делай все от ROOT

Код: Выделить всё

rmmod saa7134
modprobe saa7134 card=X

X-номер твоей карточки в файле saa7134.cardlist и запускаешь прогу для ТВ, как в мандрива это сделать автоматом не знаю, т.к. юзаю SuSE
### Samsung R460-FSS0 # OS Debian Lenny # AMD64 # Gnome or Fluxbox ###
Спасибо сказали:

Аватара пользователя
Alexxx
Сообщения: 892
Статус: --==XXX==--
ОС: Archlinux current

Re: Avertv тюнер

Сообщение Alexxx »

desperate писал(а):
01.05.2007 00:40
делай все от ROOT

Код: Выделить всё

rmmod saa7134
modprobe saa7134 card=X

X-номер твоей карточки в файле saa7134.cardlist и запускаешь прогу для ТВ, как в мандрива это сделать автоматом не знаю, т.к. юзаю SuSE

А если внимательно! прочитать сообщение топикстартера, станет понятна бессмысленность Вашего совета.
Подсказка: Особенно обратить внимание на строчку: "в папке /lib/modules/2.6.17-13mdv/kernel/drivers/media/video нет папки с названием этого чипа"
В общем, сначала не мешало бы обзавестись этими самыми модулями, ну а потом уже и того, загружать их.
Спасибо сказали:

Mag
Сообщения: 6
ОС: Mandriva 2007.1 Free

Re: Avertv тюнер

Сообщение Mag »

desperate писал(а):
01.05.2007 00:40
делай все от ROOT

Код: Выделить всё

rmmod saa7134
modprobe saa7134 card=X

X-номер твоей карточки в файле saa7134.cardlist и запускаешь прогу для ТВ, как в мандрива это сделать автоматом не знаю, т.к. юзаю SuSE


при выполнении этих команд он говорит:

Код: Выделить всё

$ rmmod saa7134
ERROR: Module saa7134 does not exist in /proc/modules

$ modprobe saa7134 card=45
FATAL: Module saa7134 not found.


:((

Alexxx писал(а):
01.05.2007 08:29
А если внимательно! прочитать сообщение топикстартера, станет понятна бессмысленность Вашего совета.
Подсказка: Особенно обратить внимание на строчку: "в папке /lib/modules/2.6.17-13mdv/kernel/drivers/media/video нет папки с названием этого чипа"
В общем, сначала не мешало бы обзавестись этими самыми модулями, ну а потом уже и того, загружать их.


Ага, я тоже так подумал, что надо обзавестись этими модулями, только как - не знаю :blush:

В исходниках ядра они есть. Можно ли их туда включить, не перекомпилируя ядро? или как вообще включить их... я пока не особо понимаю

спасибо
Спасибо сказали:

Mag
Сообщения: 6
ОС: Mandriva 2007.1 Free

Re: Avertv тюнер

Сообщение Mag »

В общем вот что пока нарыл. При установке Мандривы почему не включается в ядро модуль saa7134. В конфиге от модуля есть такая строчка

Код:

# CONFIG_VIDEO_SAA7134 is not set
(на других модулях написано что-то типа CONFIG_VIDEO_BT848=m)

Т.е. насколько я понимаю, нужно перекомпилировать ядро с поддержкой saa7134 и все будет ок?

А можно ли как-то включить эти модули, не перекомпилируя ядро (а то у меня это не получается, несколько раз пробовал и с моим ядром не грузится линукс вообще :(((, поэтому хотелось бы просто, чтоб линукс как то увидел эти дрова)

Помогите плз! я пока в линуксе еще совсем чайник :((((
Спасибо сказали: