Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2 (Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2)

Ethernet card, Wi-Fi, Bluetooth, IrDA, ADSL-модемы, модемы

Модераторы: broom, Модераторы разделов

mook
Сообщения: 8
ОС: OpenWRT

Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 06:26

Люди добрые, пожалуйста, кто знает.


Model TP-Link TL-WR1043N/ND v2
Firmware Version OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)

Делаю всё по статье: http://ru-root.livejournal.com/2602850.html

Новый интерфейс появляется в web, но ifconfig его не видит, IP адрес ему не даётся. В чём может быть дело?

Пакеты вроде все необходимые поставил.

При этом уже на настроенном 2543nd V1 - без проблем создаются аналогичные сетевые интерфейсы, всё работает.
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 06:39

Изображение




Изображение

Изображение

Изображение
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 07:19

Логи
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 08:08

Список установленных пакетов:

У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

Аватара пользователя
Hephaestus
Сообщения: 2516
Статус: Многоуважаемый джинн...
ОС: Slackware64-14.1/14.2

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение Hephaestus » 04.12.2015 15:52

mook писал(а):
04.12.2015 06:26
Новый интерфейс появляется в web, но ifconfig его не видит, IP адрес ему не даётся.
На самом деле видит, просто интерфейс не поднят. Сделайте ifconfig -a - созданный интерфейс наверняка там отобразится.
IP-адрес не даётся по той же причине - интерфейс не поднимается.
Этот интерфейс как-нибудь реагирует на нажатие кнопки Connect в веб?

P.S. А Вы не забыли выдать скрипту /lib/netifd/proto/tunnel.sh права на исполнение?
А то в статье по Вашей ссылке об этом ни слова, а это важно.
Пускай скрипят мои конечности.
Я - повелитель бесконечности...
Мой блог
Спасибо сказали:

kerno
Сообщения: 8

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение kerno » 04.12.2015 16:12

Я так понимаю второй туннель это wan6, по сути это другой интерфейс, то и ип адрес должен быть другой. Если все зделанно по анологии со вторым тп-линком имхо конфликт ип адресов, либо вариант предедущего оратора.
Спасибо сказали:

kerno
Сообщения: 8

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение kerno » 04.12.2015 16:37

А вообще выкинь тп-линки, ставь микротики(не реклама, чисто совет). По деньгам не проиграешь, зато все стабильно работает. У меня на одном микротике 5 гре-туннелей висит, и один опнвпн. И без бубна.
Спасибо сказали:

Аватара пользователя
s.xbatob
Сообщения: 768
ОС: RfRemix

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение s.xbatob » 04.12.2015 17:59

kerno писал(а):
04.12.2015 16:37
У меня на одном микротике 5 гре-туннелей висит, и один опнвпн. И без бубна.

Как это - openvpn без бубна? udp транспорт не поддерживается, сжатие (общепринятый вариант!) не поддерживается...
Спасибо сказали:

Аватара пользователя
Hephaestus
Сообщения: 2516
Статус: Многоуважаемый джинн...
ОС: Slackware64-14.1/14.2

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение Hephaestus » 04.12.2015 18:21

kerno писал(а):
04.12.2015 16:12
Я так понимаю второй туннель это wan6
Неправильно понимаете. wan6 - это вообще не туннель.
Там изначально два wan-интерфейса: wan и wan6. Для ipv4 и ipv6 соответственно.
А туннель у ТС - это iptun.
Пускай скрипят мои конечности.
Я - повелитель бесконечности...
Мой блог
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 19:34

Hephaestus писал(а):
04.12.2015 15:52
mook писал(а):
04.12.2015 06:26
Новый интерфейс появляется в web, но ifconfig его не видит, IP адрес ему не даётся.
На самом деле видит, просто интерфейс не поднят. Сделайте ifconfig -a - созданный интерфейс наверняка там отобразится.
IP-адрес не даётся по той же причине - интерфейс не поднимается.
Этот интерфейс как-нибудь реагирует на нажатие кнопки Connect в веб?

P.S. А Вы не забыли выдать скрипту /lib/netifd/proto/tunnel.sh права на исполнение?
А то в статье по Вашей ссылке об этом ни слова, а это важно.


да. всё верно, на ifconfig -a показывает данный интерфейс. на нажатие кнопки Connect не реагирует

А как выдать права на исполнение данному скрипту??? Я думал он по умолчанию сам запускается. т.к. находится в /lib/netifd/proto/ :blush: типа как автозагрузка ))))
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 15608
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение Bizdelnick » 04.12.2015 19:44

mook писал(а):
04.12.2015 19:34
как выдать права на исполнение данному скрипту?

Так же, как и любому другому: chmod +x /lib/netifd/proto/tunnel.sh
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 20:01

Bizdelnick писал(а):
04.12.2015 19:44
mook писал(а):
04.12.2015 19:34
как выдать права на исполнение данному скрипту?

Так же, как и любому другому: chmod +x /lib/netifd/proto/tunnel.sh


Подскажите, какой то ответ должен быть на команду? Ввожу - и тишина ...
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 15608
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение Bizdelnick » 04.12.2015 20:05

(Эрик Реймонд) писал(а):Если программе нечего сказать, пусть лучше молчит.

Если бы что-то пошло не так, она бы нашла, что сказать.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 04.12.2015 20:06

Bizdelnick писал(а):
04.12.2015 20:05
(Эрик Реймонд) писал(а):Если программе нечего сказать, пусть лучше молчит.

Если бы что-то пошло не так, она бы сказала.


ок, ну тогда всё без изменений - права выдал - перегрузил, не поднимается мой IPTUN интерфейс
Спасибо сказали:

mook
Сообщения: 8
ОС: OpenWRT

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение mook » 02.01.2016 14:26

Ребят, всех с Новым Годом!!!!
К сожалению вопрос так и не решён :angry:
может есть ещё идеи?
Спасибо сказали:

bsb5068
Сообщения: 2
ОС: Ubuntu

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение bsb5068 » 07.04.2017 10:52

получилось у вас что-нибудь? я пробовал стандартно, через luci, не по хабровской статье. тоже не поднимается вроде как...

Model TP-Link TL-MR3220 v2
Firmware Version OpenWrt Designated Driver 50104 / LuCI Master (git-17.058.75946-283c69a)
Kernel Version 4.4.14

Код: Выделить всё

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdba:6732:2b0c::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0'
network.lan._orig_ifname='eth0 wlan0'
network.lan._orig_bridge='true'
network.lan.proto='dhcp'
network.wan=interface
network.wan.ifname='eth1'
network.wan.proto='dhcp'
network.wan.defaultroute='0'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 3 4'
network.@switch_vlan[0].vid='1'
network.@route[0]=route
network.@route[0].interface='lan'
network.@route[0].target='0.0.0.0'
network.@route[0].netmask='0.0.0.0'
network.@route[0].gateway='192.168.37.1'
network.@route[0].metric='1'
network.@route[0].mtu='1500'
network.@route[1]=route
network.@route[1].interface='wan'
network.@route[1].target='224.0.0.0/4'
network.@route[1].type='multicast'
network.tun1=interface
network.tun1.proto='l2tp'
network.tun1.ipv6='auto'
network.tun1.delegate='0'
network.tun1.username='xxxxxxxx'
network.tun1.password='yyyyyyyyy'
network.tun1.server='zzzzzzz.isasecret.com'
network.tun1.defaultroute='0'
network.tun1.peerdns='0'
network.tun2=interface
network.tun2.proto='ipip'
network.tun2.peeraddr='192.168.8.2'
network.tun2.delegate='0'
network.tun2.tunlink='eth0.4'
network.tun2.auto='0'
network.@route[2]=route
network.@route[2].interface='tun1'
network.@route[2].netmask='255.255.255.0'
network.@route[2].gateway='192.168.8.1'
network.@route[2].metric='0'
network.@route[2].target='192.168.8.0'


т.е. первый туннель l2tp поднимается до внешнего роутера. к нему же другой openwrt подключенс адресом 192.168.8.2, но туннель 2 между ними не поднимается. пинги ходят...
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Спасибо сказали:

bsb5068
Сообщения: 2
ОС: Ubuntu

Re: Не поднимается протокол ipip туннеля на OpenWRT TP-Link 1043 V2

Сообщение bsb5068 » 13.04.2017 01:38

у меня заработало через openvpn.
подробности тут.
Спасибо сказали: