Проблема с nvidia

nVidia, ATI, SIS, VIA и др.

Модераторы: broom, Модераторы разделов

Аватара пользователя
shevan
Сообщения: 992
ОС: Debian, Puppy

Re: Проблема с nvidia

Сообщение shevan » 15.08.2010 22:02

[ 18.847] xorg-server 2:1.8.2+git20100705+server-1.8-branch.665aa7ce-0ubuntu0sarvatt2~lucid

чего-то мне не нравится версия иксов.
Спасибо сказали:

Аватара пользователя
ironcam
Сообщения: 600
Статус: Ave Satan
ОС: Ubuntu 14.10 x64

Re: Проблема с nvidia

Сообщение ironcam » 15.08.2010 23:00

Ism писал(а):
15.08.2010 21:00
Удали вообще xorg.conf (сохрани копию где нибудь) (только в случае если у тебя последняя версия сервера x11) и перезагрузись x11 должен настроиться автоматом. (при условии корректно установленных дров nvidia)

или снеси убунту к чертям, переформатируй разделы и установи заново, только прямыми руками.

Ну сносить я не хочу....
xorg.conf удалил, не помогло.
Кстати, nvidia-settings запускается, но пишет:
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Код: Выделить всё

iron_cam@iron-cam:~$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

После перезагрузки иксов пишет что убунта использует режим низкого разрешения, это при том что использует она 1280x1024...
Ну и xorg.conf на всяких пожарный:

Код: Выделить всё

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.44  (buildmeister@builder97.nvidia.com)  Thu Jul 29 02:00:07 PDT 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Ism писал(а):
15.08.2010 21:11
У меня есть подозрение что вы не до конца дрова ставили. Если так, то возможно не все зависимости разрешены. и некоторых пакетов не хватает.
установите драйвер версии совместимой с вашим дистрибутивом.

Не все йогурты одинаково полезны

Эм...какой тогда ставить? Пробовал 96, 173, 180, 185, 256.35 и 256.44.
shevan писал(а):
15.08.2010 22:02
[ 18.847] xorg-server 2:1.8.2+git20100705+server-1.8-branch.665aa7ce-0ubuntu0sarvatt2~lucid

чего-то мне не нравится версия иксов.

В смысле?
вКонтакте
ОСь указана под аватаркой.
Вот скажите, я один такой? У меня всегда уникальные проблемы. Гугл о них ничего не знает, и другие линуксойды тоже...
Если проблемы решаются, только методом тыка...
Спасибо сказали: