Radeon M9 (9000 Mobility), два монитора и AccelMethod EXA (Нужна помощь в настройке X.org)

nVidia, ATI, SIS, VIA и др.

Модераторы: broom, Модераторы разделов

XaosLord
Сообщения: 1

Radeon M9 (9000 Mobility), два монитора и AccelMethod EXA

Сообщение XaosLord » 27.10.2011 14:52

Собственно.
Есть - CentOS 5.1, Radeon M9 (rv250), два монитора (1440*900), OpenSource драйвер.
Нужно - ускорение 2д рендера и расширенный рабочий стол. Первое удалось решить включением опции "AccelMethod" "EXA", второе - опцией "Xinerama" "on".

Проблема состоит в том, что на одном мониторе ускорение есть, а на втором нет...
Т.е. приложение, выводящееся на первом мониторе, работает отлично, процесс Xorg жрёт не более 5-10%.
Но стоит перетащить его на второй монитор как начинаются дикие тормоза. Xorg начинает отжирать 100% процессора и пользоваться приложение становится крайне затруднительно.
Да, собственно, любое окошко можно легко таскать по первому монитору, а по второму - тормозит отрисовка. Дико тормозит.

Не могу понять, что я делаю не так :(
Прошу помощи.

Заранее спасибо.

Мой xorg.cong

Код:

Section "ServerLayout" Identifier "Multihead layout" Screen 0 "Screen0" LeftOf "Screen1" Screen 1 "Screen1" 0 0 InputDevice "Keyboard0" "CoreKeyboard" Option "Xinerama" "on" Option "Clone" "off" EndSection Section "Device" Identifier "Videocard0" Driver "radeon" Option "ColorTiling" "on" Option "AccelMethod" "EXA" Option "EnablePageFlip" "on" Option "DRI" "on" Option "DMAForXv" "on" EndSection Section "Device" Identifier "Videocard1" Driver "radeon" Option "ColorTiling" "on" Option "AccelMethod" "EXA" Option "EnablePageFlip" "on" Option "DRI" "on" Option "DMAForXv" "on" BusID "PCI:1:14:0" Screen 1 EndSection Section "Screen" Identifier "Screen0" Device "Videocard0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Modes "1440x900" EndSubSection EndSection Section "Screen" Identifier "Screen1" Device "Videocard1" Monitor "Monitor1" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Modes "1440x900" EndSubSection EndSection
Спасибо сказали: