Решено: Несколько 3G модемов (Как настроить подключение?)

КПК, смартфоны, коммуникаторы, мобильные телефоны, диктофоны - подключаем, настраиваем.

Модераторы: broom, Модераторы разделов

156
Сообщения: 234
ОС: OPENSUSE ALTLINUX

Решено: Несколько 3G модемов

Сообщение 156 » 17.09.2010 07:09

Операционная система опен сусе 11.3 11.2 . Подключение провожу через wvdial , модемы системой определяются,
linux-g3ee:/ # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 001 Device 008: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
linux-g3ee:/ #
В wvdial создал две секции, которые отличаются только нумерацией модемов, первый модем прописан в системе как /dev/ttyUSB0 , второй как /dev/ttyUSB1.
Первый запуск wvdial utel для первого модема происходит нормально, инет появляется. Пробуем подключить второй модем командой wvdial utel2 , и тут лажа - первый модем отключается, а
подключение второго не доходит до конца. Если сначала дать команду wvdial utel2 , то второй модем подключается нормально, есть инет, далее даём команду wvdial utel , то второй модем отключается, а первый модем не подключается. Что нужно настроить - чтобы оба модема подклчались, и меняя по умолючанию путь на первый или второй модем, выходить в инет.

п.с. Балансировака каналов будет вторым этапом настройки.
Спасибо сказали:

Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: Решено: Несколько 3G модемов

Сообщение sash-kan » 17.09.2010 10:45

156 писал(а):
17.09.2010 07:09
подключение второго не доходит до конца.
подробности пропустили.
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:

156
Сообщения: 234
ОС: OPENSUSE ALTLINUX

Re: Решено: Несколько 3G модемов

Сообщение 156 » 17.09.2010 16:06

Решено . Оказалась большая неожиданность , я ошибся в определении номеров модемов. При подключении модема в папке /dev/ появляется несколько устройств , а именно /dev/ttyUSB0 /dev/ttyUSB1 , при подключении второго модема появляется /dev/ttyUSB2 и /dev/ttyUSB3 . Как подсказал гугл, модем определяется как устройство передачи данных /dev/ttyUSB0 и как голосовое устройство /dev/ttyUSB1. Поэтому во втором конфиге надо указывать не /dev/ttyUSB1 , а /dev/ttyUSB2.
Спасибо сказали: