Конфликт при обновлении системы

Cent OS, Scientific Linux

Модераторы: broom, Модераторы разделов

atwooo
Сообщения: 35

Конфликт при обновлении системы

Сообщение atwooo » 14.08.2019 16:11

Добрый день.
Недавно попытался обновить систему и вот что получил:

Код: Выделить всё

# yum update
Загружены модули: fastestmirror
Loading mirror speeds from cached hostfile
 * base: dedic.sh
 * epel: mirror.yandex.ru
 * extras: dedic.sh
 * remi-php73: mirror.reconn.ru
 * remi-safe: mirror.reconn.ru
 * updates: dedic.sh
Разрешение зависимостей
--> Проверка сценария
---> Пакет Percona-Server-shared-55.x86_64 0:5.5.62-rel38.14.el7 помечен для исключения
---> Пакет Percona-Server-shared-56.x86_64 0:5.6.44-rel86.0.el7 помечен для исключения
---> Пакет Percona-Server-shared-compat-57.x86_64 0:5.7.26-29.1.el7 помечен для исключения
---> Пакет Percona-XtraDB-Cluster-shared-55.x86_64 1:5.5.41-25.12.855.el7 помечен для исключения
---> Пакет Percona-XtraDB-Cluster-shared-56.x86_64 1:5.6.44-28.34.1.el7 помечен для исключения
---> Пакет Percona-XtraDB-Cluster-shared-57.x86_64 0:5.7.26-31.37.1.el7 помечен для исключения
---> Пакет Percona-XtraDB-Cluster-shared-compat-57.x86_64 0:5.7.26-31.37.1.el7 помечен для исключения
---> Пакет bind-libs-lite.x86_64 32:9.9.4-73.el7_6 помечен для обновления
---> Пакет bind-libs-lite.x86_64 32:9.9.4-74.el7_6.2 помечен как обновление
---> Пакет bind-license.noarch 32:9.9.4-73.el7_6 помечен для обновления
---> Пакет bind-license.noarch 32:9.9.4-74.el7_6.2 помечен как обновление
---> Пакет certbot.noarch 0:0.31.0-2.el7 помечен для обновления
---> Пакет certbot.noarch 0:0.36.0-1.el7 помечен как обновление
---> Пакет cpp.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет cpp.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет curl.x86_64 0:7.29.0-51.el7 помечен для обновления
---> Пакет curl.x86_64 0:7.29.0-51.el7_6.3 помечен как обновление
---> Пакет device-mapper.x86_64 7:1.02.149-10.el7_6.3 помечен для обновления
---> Пакет device-mapper.x86_64 7:1.02.149-10.el7_6.8 помечен как обновление
---> Пакет device-mapper-event.x86_64 7:1.02.149-10.el7_6.3 помечен для обновления
---> Пакет device-mapper-event.x86_64 7:1.02.149-10.el7_6.8 помечен как обновление
---> Пакет device-mapper-event-libs.x86_64 7:1.02.149-10.el7_6.3 помечен для обновления
---> Пакет device-mapper-event-libs.x86_64 7:1.02.149-10.el7_6.8 помечен как обновление
---> Пакет device-mapper-libs.x86_64 7:1.02.149-10.el7_6.3 помечен для обновления
---> Пакет device-mapper-libs.x86_64 7:1.02.149-10.el7_6.8 помечен как обновление
---> Пакет gcc.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет gcc.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет gcc-c++.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет gcc-c++.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет glib2.x86_64 0:2.56.1-2.el7 помечен для обновления
---> Пакет glib2.x86_64 0:2.56.1-4.el7_6 помечен как обновление
---> Пакет glibc.x86_64 0:2.17-260.el7_6.3 помечен для обновления
---> Пакет glibc.x86_64 0:2.17-260.el7_6.6 помечен как обновление
---> Пакет glibc-common.x86_64 0:2.17-260.el7_6.3 помечен для обновления
---> Пакет glibc-common.x86_64 0:2.17-260.el7_6.6 помечен как обновление
---> Пакет glibc-devel.x86_64 0:2.17-260.el7_6.3 помечен для обновления
---> Пакет glibc-devel.x86_64 0:2.17-260.el7_6.6 помечен как обновление
---> Пакет glibc-headers.x86_64 0:2.17-260.el7_6.3 помечен для обновления
---> Пакет glibc-headers.x86_64 0:2.17-260.el7_6.6 помечен как обновление
---> Пакет httpd.x86_64 0:2.4.6-88.el7.centos помечен для обновления
---> Пакет httpd.x86_64 0:2.4.6-89.el7.centos.1 помечен как обновление
---> Пакет httpd-tools.x86_64 0:2.4.6-88.el7.centos помечен для обновления
---> Пакет httpd-tools.x86_64 0:2.4.6-89.el7.centos.1 помечен как обновление
---> Пакет iproute.x86_64 0:4.11.0-14.el7 помечен для обновления
---> Пакет iproute.x86_64 0:4.11.0-14.el7_6.2 помечен как обновление
---> Пакет kernel.x86_64 0:3.10.0-957.27.2.el7 помечен для установки
---> Пакет kernel-headers.x86_64 0:3.10.0-957.10.1.el7 помечен для обновления
---> Пакет kernel-headers.x86_64 0:3.10.0-957.27.2.el7 помечен как обновление
---> Пакет kernel-tools.x86_64 0:3.10.0-957.10.1.el7 помечен для обновления
---> Пакет kernel-tools.x86_64 0:3.10.0-957.27.2.el7 помечен как обновление
---> Пакет kernel-tools-libs.x86_64 0:3.10.0-957.10.1.el7 помечен для обновления
---> Пакет kernel-tools-libs.x86_64 0:3.10.0-957.27.2.el7 помечен как обновление
---> Пакет kexec-tools.x86_64 0:2.0.15-21.el7 помечен для обновления
---> Пакет kexec-tools.x86_64 0:2.0.15-21.el7_6.4 помечен как обновление
---> Пакет libargon2.x86_64 0:20161029-2.el7 помечен для обновления
---> Пакет libargon2.x86_64 0:20161029-3.el7 помечен как обновление
---> Пакет libcurl.x86_64 0:7.29.0-51.el7 помечен для обновления
---> Пакет libcurl.x86_64 0:7.29.0-51.el7_6.3 помечен как обновление
---> Пакет libgcc.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет libgcc.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет libgomp.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет libgomp.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет libssh2.x86_64 0:1.4.3-12.el7 помечен для обновления
---> Пакет libssh2.x86_64 0:1.4.3-12.el7_6.3 помечен как обновление
---> Пакет libstdc++.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет libstdc++.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет libstdc++-devel.x86_64 0:4.8.5-36.el7_6.1 помечен для обновления
---> Пакет libstdc++-devel.x86_64 0:4.8.5-36.el7_6.2 помечен как обновление
---> Пакет libteam.x86_64 0:1.27-5.el7 помечен для обновления
---> Пакет libteam.x86_64 0:1.27-6.el7_6.1 помечен как обновление
---> Пакет lvm2.x86_64 7:2.02.180-10.el7_6.3 помечен для обновления
---> Пакет lvm2.x86_64 7:2.02.180-10.el7_6.8 помечен как обновление
---> Пакет lvm2-libs.x86_64 7:2.02.180-10.el7_6.3 помечен для обновления
---> Пакет lvm2-libs.x86_64 7:2.02.180-10.el7_6.8 помечен как обновление
---> Пакет mariadb-libs.x86_64 1:5.5.60-1.el7_5 помечен как недействительный
--> Обработка зависимостей: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 пакета: 1:mariadb-5.5.60-1.el7_5.x86_64
--> Обработка зависимостей: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 пакета: 1:mariadb-server-5.5.60-1.el7_5.x86_64
---> Пакет microcode_ctl.x86_64 2:2.1-47.el7 помечен для обновления
---> Пакет microcode_ctl.x86_64 2:2.1-47.5.el7_6 помечен как обновление
---> Пакет nginx.x86_64 1:1.14.2-1.el7_4.ngx помечен для обновления
---> Пакет nginx.x86_64 1:1.16.1-1.el7.ngx помечен как обновление
---> Пакет php.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-bcmath.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-bcmath.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-cli.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-cli.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-common.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-common.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-fpm.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-fpm.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-gd.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-gd.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-json.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-json.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-mbstring.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-mbstring.x86_64 0:7.3.8-1.el7.remi помечен как обновление
--> Обработка зависимостей: libonig.so.5()(64bit) пакета: php-mbstring-7.3.8-1.el7.remi.x86_64
---> Пакет php-mysqlnd.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-mysqlnd.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-pdo.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-pdo.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-pecl-igbinary.x86_64 0:3.0.0-1.el7.remi.7.2 помечен для обновления
---> Пакет php-pecl-igbinary.x86_64 0:3.0.1-2.el7.remi.7.3 помечен как обновление
---> Пакет php-pecl-mcrypt.x86_64 0:1.0.2-2.el7.remi.7.2 помечен для обновления
---> Пакет php-pecl-mcrypt.x86_64 0:1.0.2-2.el7.remi.7.3 помечен как обновление
---> Пакет php-pecl-memcached.x86_64 0:3.1.3-1.el7.remi.7.2 помечен для обновления
---> Пакет php-pecl-memcached.x86_64 0:3.1.3-1.el7.remi.7.3 помечен как обновление
---> Пакет php-pecl-msgpack.x86_64 0:2.0.3-1.el7.remi.7.2 помечен для обновления
---> Пакет php-pecl-msgpack.x86_64 0:2.0.3-1.el7.remi.7.3 помечен как обновление
---> Пакет php-pecl-zip.x86_64 0:1.15.4-1.el7.remi.7.2 помечен для обновления
---> Пакет php-pecl-zip.x86_64 0:1.15.4-1.el7.remi.7.3 помечен как обновление
---> Пакет php-process.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-process.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-tidy.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-tidy.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет php-xml.x86_64 0:7.2.16-1.el7.remi помечен для обновления
---> Пакет php-xml.x86_64 0:7.3.8-1.el7.remi помечен как обновление
---> Пакет python.x86_64 0:2.7.5-76.el7 помечен для обновления
---> Пакет python.x86_64 0:2.7.5-80.el7_6 помечен как обновление
---> Пакет python-libs.x86_64 0:2.7.5-76.el7 помечен для обновления
---> Пакет python-libs.x86_64 0:2.7.5-80.el7_6 помечен как обновление
---> Пакет python-perf.x86_64 0:3.10.0-957.10.1.el7 помечен для обновления
---> Пакет python-perf.x86_64 0:3.10.0-957.27.2.el7 помечен как обновление
---> Пакет python2-acme.noarch 0:0.31.0-1.el7 помечен для обновления
---> Пакет python2-acme.noarch 0:0.36.0-1.el7 помечен как обновление
---> Пакет python2-certbot.noarch 0:0.31.0-2.el7 помечен для обновления
---> Пакет python2-certbot.noarch 0:0.36.0-1.el7 помечен как обновление
---> Пакет python2-certbot-nginx.noarch 0:0.31.0-1.el7 помечен для обновления
---> Пакет python2-certbot-nginx.noarch 0:0.36.0-1.el7 помечен как обновление
---> Пакет python2-future.noarch 0:0.16.0-7.el7 помечен для обновления
---> Пакет python2-future.noarch 0:0.16.0-15.20181019gitbee0f3b.el7 помечен как обновление
---> Пакет python2-josepy.noarch 0:1.1.0-1.el7 помечен для обновления
---> Пакет python2-josepy.noarch 0:1.2.0-1.el7 помечен как обновление
---> Пакет rsync.x86_64 0:3.1.2-4.el7 помечен для обновления
---> Пакет rsync.x86_64 0:3.1.2-6.el7_6.1 помечен как обновление
---> Пакет selinux-policy.noarch 0:3.13.1-229.el7_6.9 помечен для обновления
---> Пакет selinux-policy.noarch 0:3.13.1-229.el7_6.15 помечен как обновление
---> Пакет selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.9 помечен для обновления
---> Пакет selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.15 помечен как обновление
---> Пакет systemd.x86_64 0:219-62.el7_6.5 помечен для обновления
---> Пакет systemd.x86_64 0:219-62.el7_6.9 помечен как обновление
---> Пакет systemd-libs.x86_64 0:219-62.el7_6.5 помечен для обновления
---> Пакет systemd-libs.x86_64 0:219-62.el7_6.9 помечен как обновление
---> Пакет systemd-sysv.x86_64 0:219-62.el7_6.5 помечен для обновления
---> Пакет systemd-sysv.x86_64 0:219-62.el7_6.9 помечен как обновление
---> Пакет teamd.x86_64 0:1.27-5.el7 помечен для обновления
---> Пакет teamd.x86_64 0:1.27-6.el7_6.1 помечен как обновление
---> Пакет tuned.noarch 0:2.10.0-6.el7_6.3 помечен для обновления
---> Пакет tuned.noarch 0:2.10.0-6.el7_6.4 помечен как обновление
---> Пакет tzdata.noarch 0:2018i-1.el7 помечен для обновления
---> Пакет tzdata.noarch 0:2019b-1.el7 помечен как обновление
---> Пакет vim-common.x86_64 2:7.4.160-5.el7 помечен для обновления
---> Пакет vim-common.x86_64 2:7.4.160-6.el7_6 помечен как обновление
---> Пакет vim-enhanced.x86_64 2:7.4.160-5.el7 помечен для обновления
---> Пакет vim-enhanced.x86_64 2:7.4.160-6.el7_6 помечен как обновление
---> Пакет vim-filesystem.x86_64 2:7.4.160-5.el7 помечен для обновления
---> Пакет vim-filesystem.x86_64 2:7.4.160-6.el7_6 помечен как обновление
---> Пакет vim-minimal.x86_64 2:7.4.160-5.el7 помечен для обновления
---> Пакет vim-minimal.x86_64 2:7.4.160-6.el7_6 помечен как обновление
---> Пакет wget.x86_64 0:1.14-18.el7 помечен для обновления
---> Пакет wget.x86_64 0:1.14-18.el7_6.1 помечен как обновление
--> Проверка сценария
---> Пакет mariadb-libs.x86_64 1:5.5.60-1.el7_5 помечен как недействительный
--> Обработка зависимостей: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 пакета: 1:mariadb-5.5.60-1.el7_5.x86_64
--> Обработка зависимостей: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 пакета: 1:mariadb-server-5.5.60-1.el7_5.x86_64
---> Пакет oniguruma5.x86_64 0:6.9.2-2.el7.remi помечен для установки
--> Обработка конфликта: Percona-Server-shared-55-5.5.62-rel38.14.el7.x86_64 конфликтует с Percona-Server-shared-56
--> Обработка конфликта: 1:Percona-XtraDB-Cluster-shared-56-5.6.44-28.34.1.el7.x86_64 конфликтует с Percona-Server-shared-56
--> Обработка конфликта: Percona-XtraDB-Cluster-shared-57-5.7.26-31.37.1.el7.x86_64 конфликтует с Percona-Server-shared-56
--> Обработка конфликта: Percona-Server-shared-56-5.6.44-rel86.0.el7.x86_64 конфликтует с Percona-Server-shared-55
--> Обработка конфликта: Percona-XtraDB-Cluster-shared-compat-57-5.7.26-31.37.1.el7.x86_64 конфликтует с Percona-XtraDB-Cluster-shared-55
--> Обработка конфликта: Percona-XtraDB-Cluster-shared-compat-57-5.7.26-31.37.1.el7.x86_64 конфликтует с Percona-XtraDB-Cluster-shared-56
--> Обработка конфликта: 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86_64 конфликтует с Percona-XtraDB-Cluster-shared-56
--> Обработка конфликта: 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86_64 конфликтует с Percona-Server-shared-55
--> Обработка конфликта: Percona-Server-shared-compat-57-5.7.26-29.1.el7.x86_64 конфликтует с Percona-Server-shared-56
--> Обработка конфликта: Percona-Server-shared-compat-57-5.7.26-29.1.el7.x86_64 конфликтует с Percona-Server-shared-55
--> Проверка зависимостей окончена
Ошибка: Пакет: 1:mariadb-5.5.60-1.el7_5.x86_64 (@base)
            Необходимо: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5
            Удаление: 1:mariadb-libs-5.5.60-1.el7_5.x86_64 (@base)
                mariadb-libs(x86-64) = 1:5.5.60-1.el7_5
            Заменил: Percona-XtraDB-Cluster-shared-57-5.7.26-31.37.1.el7.x86_64 (percona-release-x86_64)
                Не найдено
Ошибка: Percona-XtraDB-Cluster-shared-compat-57 conflicts with 1:Percona-XtraDB-Cluster-shared-56-5.6.44-28.34.1.el7.x86_64
Ошибка: Percona-XtraDB-Cluster-shared-55 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86_64
Ошибка: Пакет: 1:mariadb-server-5.5.60-1.el7_5.x86_64 (@base)
            Необходимо: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5
            Удаление: 1:mariadb-libs-5.5.60-1.el7_5.x86_64 (@base)
                mariadb-libs(x86-64) = 1:5.5.60-1.el7_5
            Заменил: Percona-XtraDB-Cluster-shared-57-5.7.26-31.37.1.el7.x86_64 (percona-release-x86_64)
                Не найдено
Ошибка: Percona-XtraDB-Cluster-shared-57 conflicts with Percona-Server-shared-56-5.6.44-rel86.0.el7.x86_64
Ошибка: Percona-Server-shared-56 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86_64
Ошибка: Percona-Server-shared-compat-57 conflicts with Percona-Server-shared-56-5.6.44-rel86.0.el7.x86_64
Ошибка: Percona-XtraDB-Cluster-shared-55 conflicts with 1:Percona-XtraDB-Cluster-shared-56-5.6.44-28.34.1.el7.x86_64
Ошибка: Percona-Server-shared-55 conflicts with Percona-Server-shared-56-5.6.44-rel86.0.el7.x86_64
Ошибка: Percona-Server-shared-compat-57 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86_64
Ошибка: Percona-XtraDB-Cluster-shared-56 conflicts with Percona-Server-shared-56-5.6.44-rel86.0.el7.x86_64
Ошибка: Percona-XtraDB-Cluster-shared-compat-57 conflicts with 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86_64
 Вы можете попробовать --skip-broken чтобы обойти проблему
 Вы можете попробовать запустить: rpm -Va --nofiles --nodigest
Может кто в курсе что это означает и как это лечится?
Спасибо сказали:

Аватара пользователя
devilr
Сообщения: 1809
ОС: Mandriva => Gentoo (~amd64)

Re: Конфликт при обновлении системы

Сообщение devilr » 14.08.2019 16:21

Так вроде по русски написано и даже предложены два варианта решения проблемы.
Мудрость приходит с возрастом.
Иногда возраст приходит один.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 15835
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Конфликт при обновлении системы

Сообщение Bizdelnick » 14.08.2019 16:22

Это означает, что установить percona трёх разных версий одновременно невозможно.
Добавлено (16:23):
devilr писал(а):
14.08.2019 16:21
предложены два варианта решения проблемы.
Я бы не рекомендовал следовать первому из этих советов, а второй ничего не решит. Тут yum в своём репертуаре: пишет какие-то глупости, а разрулить ничего не может.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

atwooo
Сообщения: 35

Re: Конфликт при обновлении системы

Сообщение atwooo » 14.08.2019 16:31

Итого получается что первый вариант не стоит делать а второй не решит проблему?
percona это что то незнакомое для меня( Возможно этот пакет ставился в месте с каким то другим но я явно не пытался сам поставить percona трех разных версий.
Есть какие то варианты решения этого вопроса?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1503
ОС: Fedora 30

Re: Конфликт при обновлении системы

Сообщение Vascom » 14.08.2019 16:55

Эти пакеты из какого-то левого репозитория. Так что либо удаляй что-то из конфликтующих пакетов, либо спрашивай помощи в том стороннем репозитории.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 15835
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Конфликт при обновлении системы

Сообщение Bizdelnick » 14.08.2019 17:51

atwooo писал(а):
14.08.2019 16:31
percona это что то незнакомое для меня( Возможно этот пакет ставился в месте с каким то другим но я явно не пытался сам поставить percona трех разных версий.
Это странно, потому что эти пакеты явно не из официального репозитория, и сами по себе прилететь не могли.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
s.xbatob
Сообщения: 807
ОС: Fedora

Re: Конфликт при обновлении системы

Сообщение s.xbatob » 14.08.2019 18:43

Кто такой Percona? Явно сторонний проект. Удалите его, обновляйтесь, потом ставьте обратно (если получится) Не получится -- разбирайтесь с его авторами.
P.S. Посмотрел про проект. Ничего выдающегося не предлагает. Требуется для общения с партнёрами?
Спасибо сказали:

atwooo
Сообщения: 35

Re: Конфликт при обновлении системы

Сообщение atwooo » 15.08.2019 15:41

Действительно убрал файл с репозиторием и все стало нормально.
НО странно... в том списке обновлений было что то что касалось БД (mariadb-5.5.60-1.el7_5.x86_64)
Теперь его нет и это не понятно(
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1503
ОС: Fedora 30

Re: Конфликт при обновлении системы

Сообщение Vascom » 15.08.2019 16:12

Видимо ты не тот репозиторий убрал.
Спасибо сказали:

atwooo
Сообщения: 35

Re: Конфликт при обновлении системы

Сообщение atwooo » 15.08.2019 16:42

Ну как не тот?
Вот вся папка

Код: Выделить всё

ls -lha /etc/yum.repos.d/
итого 108K
drwxr-xr-x.  2 root root 4,0K авг 15 11:48 .
drwxr-xr-x. 87 root root 8,0K авг 15 15:32 ..
-rw-r--r--.  1 root root 1,7K ноя 23  2018 CentOS-Base.repo
-rw-r--r--.  1 root root 1,3K ноя 23  2018 CentOS-CR.repo
-rw-r--r--.  1 root root  649 ноя 23  2018 CentOS-Debuginfo.repo
-rw-r--r--.  1 root root  314 ноя 23  2018 CentOS-fasttrack.repo
-rw-r--r--.  1 root root  630 ноя 23  2018 CentOS-Media.repo
-rw-r--r--.  1 root root 1,3K ноя 23  2018 CentOS-Sources.repo
-rw-r--r--.  1 root root 5,6K ноя 23  2018 CentOS-Vault.repo
-rw-r--r--.  1 root root  951 окт  2  2017 epel.repo
-rw-r--r--.  1 root root 1,1K окт  2  2017 epel-testing.repo
-rw-r--r--   1 root root  356 мар 19 12:47 nginx.repo
-rw-r--r--   1 root root  446 мар  8 10:34 remi-glpi91.repo
-rw-r--r--   1 root root  446 мар  8 10:34 remi-glpi92.repo
-rw-r--r--   1 root root  446 мар  8 10:34 remi-glpi93.repo
-rw-r--r--   1 root root  446 мар  8 10:34 remi-glpi94.repo
-rw-r--r--   1 root root  855 мар  8 10:34 remi-modular.repo
-rw-r--r--   1 root root  456 мар  8 10:34 remi-php54.repo
-rw-r--r--   1 root root 1,3K мар  8 10:34 remi-php70.repo
-rw-r--r--   1 root root 1,3K мар  8 10:34 remi-php71.repo
-rw-r--r--   1 root root 1,3K авг 14 15:52 remi-php72.repo
-rw-r--r--   1 root root 1,3K авг 14 15:46 remi-php73.repo
-rw-r--r--   1 root root 2,6K мар  8 10:34 remi.repo
-rw-r--r--   1 root root  750 мар  8 10:34 remi-safe.repo
И среде них был еще один файл percona-original-release.repo который я переместил в другое место.
И Важно что ошибка пропала. Теперь оно нормально предлагает обновиться.
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1503
ОС: Fedora 30

Re: Конфликт при обновлении системы

Сообщение Vascom » 15.08.2019 16:54

При чём тут каталог?
Если хочешь показать включённые репозитории - используй команду

Код: Выделить всё

yum repolist
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 15835
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Конфликт при обновлении системы

Сообщение Bizdelnick » 15.08.2019 17:24

atwooo писал(а):
15.08.2019 15:41
в том списке обновлений было что то что касалось БД (mariadb-5.5.60-1.el7_5.x86_64)
Теперь его нет и это не понятно(
Что же тут непонятного? Percona, насколько я помню, когда-то была форком MySQL, а нынче, кажется, просто надстройка над MariaDB (или той же MySQL, я в них слабо разбираюсь). Вот по зависимости от Percona и тянулась MariaDB.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

atwooo
Сообщения: 35

Re: Конфликт при обновлении системы

Сообщение atwooo » 15.08.2019 20:11

Vascom писал:
15.08.2019 16:54
При чём тут каталог?
Если хочешь показать включённые репозитории - используй команду

Код: Выделить всё

yum repolist

Код: Выделить всё

yum repolist 
Загружены модули: fastestmirror
Loading mirror speeds from cached hostfile
 * base: dedic.sh
 * epel: mirror.logol.ru
 * extras: centos-mirror.rbc.ru
 * remi-php73: mirror.reconn.ru
 * remi-safe: mirror.reconn.ru
 * updates: dedic.sh
Идентификатор репозитория                                                                                                                                      репозиторий                                                                                                                                                                                         состояние
!base/7/x86_64                                                                                                                                                 CentOS-7 - Base                                                                                                                                                                                     10 019
!epel/x86_64                                                                                                                                                   Extra Packages for Enterprise Linux 7 - x86_64                                                                                                                                                      13 343
!extras/7/x86_64                                                                                                                                               CentOS-7 - Extras                                                                                                                                                                                      435
!nginx-stable/7/x86_64                                                                                                                                         nginx stable repo                                                                                                                                                                                      164
!remi-php73                                                                                                                                                    Remi's PHP 7.3 RPM repository for Enterprise Linux 7 - x86_64                                                                                                                                          322
!remi-safe                                                                                                                                                     Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                                                                                                                                           3 553
!updates/7/x86_64                                                                                                                                              CentOS-7 - Updates                                                                                                                                                                                   2 500
repolist: 30 336
Спасибо сказали: