как обновить fedora core версии 11

Cent OS, Scientific Linux

Модератор: Модераторы разделов

v4567
Сообщения: 148
ОС: Devuan

как обновить fedora core версии 11

Сообщение v4567 »

Есть очень старая fedora core версия 11.

Надо установить скайп.
Скайп не ставиться, вернее ставиться версии порядка 2, которая в связи со сменой протокола не конектится к серверу. Скайп версии 4 не ставится.

В федоре очень много настроек, сносить её и ставить последнюю не хотелось бы.

Пытался обновить следующими командами:

Код: Выделить всё

yum update rpm

Выдало вот что:

Код: Выделить всё

Setting up Update Process
No Packages marked for Update

Код: Выделить всё

yum --enablerepo=rawhide --skip-broken upgrade


час проверяло пакеты и выдало в конце по очень многим пакетам такую ошибку (привёл самый конец) libc не обновилась:

Код: Выделить всё

Error: Missing Dependency: libpolkit.so.2 is needed by package hal-0.5.12-29.20090226git.fc11.i586 (updates)
Error: Missing Dependency: java-gcj-compat is needed by package jakarta-commons-codec-1.3-10.4.fc11.i586 (installed)
Error: Missing Dependency: libgupnp-igd-1.0.so.2 is needed by package farsight2-0.0.14-1.fc11.i586 (updates)
Error: Missing Dependency: libvncserver.so.0 is needed by package directfb-1.2.9-2.fc11.i586 (updates)
Error: Missing Dependency: ant = 1.7.1-10.0.fc11 is needed by package ant-jmf-1.7.1-10.0.fc11.i586 (updates)
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


запуск

Код: Выделить всё

package-cleanup --problems


выдал вот что:

Код: Выделить всё

Setting up yum
Loaded plugins: fastestmirror, presto, refresh-packagekit, versionlock
Loading mirror speeds from cached hostfile
Reading local RPM database
Processing all local requires
Missing dependencies:
Package gdm-2.26.1-10.fc11.i586 requires /sbin/nologin
Package fakeroot-1.12.2-21.fc11.i586 requires /usr/bin/getopt
Package hal-0.5.12-26.20090226git.fc11.i586 requires util-linux >= 2.12a-16
Package xmlto-0.0.22-1.fc11.i586 requires util-linux
Package mozilla-vlc-1.0.0-0.11rc3.fc11.i586 requires vlc = 1.0.0-0.11rc3.fc11
Package DeviceKit-disks-004-3.fc11.i586 requires util-linux-ng
Package nfs-utils-1.1.5-6.fc11.i586 requires /sbin/nologin
Package redhat-lsb-3.2-3.fc11.i586 requires /bin/dmesg
Package redhat-lsb-3.2-3.fc11.i586 requires /bin/kill
Package redhat-lsb-3.2-3.fc11.i586 requires /bin/more
Package redhat-lsb-3.2-3.fc11.i586 requires /bin/mount
Package redhat-lsb-3.2-3.fc11.i586 requires /bin/umount
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/chfn
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/chsh
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/col
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/ipcrm
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/ipcs
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/logger
Package redhat-lsb-3.2-3.fc11.i586 requires /usr/bin/renice
Package rarian-0.8.1-4.fc11.i586 requires util-linux
Package readahead-1.4.9-1.fc11.i586 requires /usr/bin/ionice
Package prelink-0.4.0-7.fc11.i586 requires util-linux
Package openssh-5.2p1-2.fc11.i586 requires /sbin/nologin
Package policycoreutils-2.0.62-12.6.fc11.i586 requires /bin/mount
Package coreutils-7.2-1.fc11.i586 requires util-linux-ng >= 2.14
Package initscripts-8.95-1.3.i586 requires mount >= 2.11l
Package initscripts-8.95-1.3.i586 requires util-linux >= 2.10s-11
Package usermode-1.100-2.i586 requires util-linux
Package mkinitrd-6.0.86-2.fc11.i586 requires /sbin/losetup
Package mkinitrd-6.0.86-2.fc11.i586 requires mount
Package kde-settings-4.2-10.20090430svn.fc11.noarch requires util-linux


запуск:

Код: Выделить всё

package-cleanup --dupes


выдал вот что:

Код: Выделить всё

Setting up yum
Loaded plugins: fastestmirror, presto, refresh-packagekit, versionlock


запуск:

Код: Выделить всё

rpm -Va --nofiles --nodigest


выдал вот что:

Код: Выделить всё

Unsatisfied dependencies for initscripts-8.95-1.3.i586:
        mount >= 2.11l нужен для initscripts-8.95-1.3.i586
        util-linux >= 2.10s-11 нужен для initscripts-8.95-1.3.i586
Unsatisfied dependencies for hal-0.5.12-26.20090226git.fc11.i586:
        util-linux >= 2.12a-16 нужен для hal-0.5.12-26.20090226git.fc11.i586
Unsatisfied dependencies for mozilla-vlc-1.0.0-0.11rc3.fc11.i586:
        vlc = 1.0.0-0.11rc3.fc11 нужен для mozilla-vlc-1.0.0-0.11rc3.fc11.i586
Unsatisfied dependencies for usermode-1.100-2.i586:
        util-linux нужен для usermode-1.100-2.i586
Unsatisfied dependencies for nfs-utils-1:1.1.5-6.fc11.i586:
        /sbin/nologin нужен для nfs-utils-1:1.1.5-6.fc11.i586
Unsatisfied dependencies for xmlto-0.0.22-1.fc11.i586:
        util-linux нужен для xmlto-0.0.22-1.fc11.i586
Unsatisfied dependencies for readahead-1:1.4.9-1.fc11.i586:
        /usr/bin/ionice нужен для readahead-1:1.4.9-1.fc11.i586
Unsatisfied dependencies for policycoreutils-2.0.62-12.6.fc11.i586:
        /bin/mount нужен для policycoreutils-2.0.62-12.6.fc11.i586
Unsatisfied dependencies for coreutils-7.2-1.fc11.i586:
        util-linux-ng >= 2.14 нужен для coreutils-7.2-1.fc11.i586
Unsatisfied dependencies for redhat-lsb-3.2-3.fc11.i586:
        /bin/dmesg нужен для redhat-lsb-3.2-3.fc11.i586
        /bin/kill нужен для redhat-lsb-3.2-3.fc11.i586
        /bin/more нужен для redhat-lsb-3.2-3.fc11.i586
        /bin/mount нужен для redhat-lsb-3.2-3.fc11.i586
        /bin/umount нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/chfn нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/chsh нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/col нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/ipcrm нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/ipcs нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/logger нужен для redhat-lsb-3.2-3.fc11.i586
        /usr/bin/renice нужен для redhat-lsb-3.2-3.fc11.i586
Unsatisfied dependencies for openssh-5.2p1-2.fc11.i586:
        /sbin/nologin нужен для openssh-5.2p1-2.fc11.i586
Unsatisfied dependencies for rarian-0.8.1-4.fc11.i586:
        util-linux нужен для rarian-0.8.1-4.fc11.i586
Unsatisfied dependencies for DeviceKit-disks-004-3.fc11.i586:
        util-linux-ng нужен для DeviceKit-disks-004-3.fc11.i586
Unsatisfied dependencies for kde-settings-4.2-10.20090430svn.fc11.noarch:
        util-linux нужен для kde-settings-4.2-10.20090430svn.fc11.noarch
Unsatisfied dependencies for fakeroot-1.12.2-21.fc11.i586:
        /usr/bin/getopt нужен для fakeroot-1.12.2-21.fc11.i586
Unsatisfied dependencies for gdm-1:2.26.1-10.fc11.i586:
        /sbin/nologin нужен для gdm-1:2.26.1-10.fc11.i586
Unsatisfied dependencies for prelink-0.4.0-7.fc11.i586:
        util-linux нужен для prelink-0.4.0-7.fc11.i586
Unsatisfied dependencies for mkinitrd-6.0.86-2.fc11.i586:
        /sbin/losetup нужен для mkinitrd-6.0.86-2.fc11.i586
        mount нужен для mkinitrd-6.0.86-2.fc11.i586


Получается не всё обновилось.

скайп скачал бинарники и просто их скопировал.

glibc как была версии libc-2.10.1.so так и осталась.

соответственно по ldd скайп показывает что все библиотеки есть, а при запуске /usr/share/skype/skype --version выдаёт вот что:

Код: Выделить всё

/usr/share/skype/skype: symbol lookup error: /usr/share/skype/skype: undefined symbol: _ZN9QHashData14detach_helper2EPFvPNS_4NodeEPvEPFvS1_Eii

при запуске /usr/share/skype/skype выдаёт вот что:

Код: Выделить всё

Ошибка сегментирования


Не знаю даже что и делать?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: как обновить fedora core версии 11

Сообщение Vascom »

11 реально устарела так, что по любому легче установить ф25 и настроить, чем обновлять. Поверь.
Спасибо сказали:

gesigor
Сообщения: 401
ОС: Fedora 30

Re: как обновить fedora core версии 11

Сообщение gesigor »

Лично я обновлял так старую федору: узнал id пользователя, сохранил полностью каталог пользователя. Некоторые вещи из /etc также сохранил. Поставил систему заново. Завел пользователя с сохраненным id. Каталог сохраненный также подсунул. Большинство настроек подхватилось.
OC Centos, FC21
https://gesigor.ru
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18675
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: как обновить fedora core версии 11

Сообщение Bizdelnick »

Если именно обновлять, то через все промежуточные релизы 11→12→13→14→15→16→17→18→19→20→21→22→23→24→25(→rawhide). Но это, полагаю, будет более напряжно, чем установить новую версию с сохранением /home и последующей донастройкой. Да и не факт, что найдутся зеркала, где такие старые репозитории ещё живы.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
Atolstoy
Сообщения: 1654
Статус: Tux in the rain
ОС: Linux x86_64

Re: как обновить fedora core версии 11

Сообщение Atolstoy »

Обновляться через все релизы есть смысл, только если принципиально хочется идти именно этим путём. Времени уйдёт много, зато это такой дзен :)
Репы, кстати, тут: http://archives.fedoraproject.org/pub/arch.../linux/updates/
Всего лишь 26 литров пива достаточно человеку для удовлетворения ежедневной потребности в кальции. Здоровое питание - это так просто!
http://atolstoy.wordpress.com
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18675
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: как обновить fedora core версии 11

Сообщение Bizdelnick »

Atolstoy писал(а):
27.02.2017 09:39
Обновляться через все релизы есть смысл, только если принципиально хочется идти именно этим путём.

Иначе вероятность получить нерабочую систему очень высока. Даже при обновлении через один релиз что-нибудь может отвалиться, а уж через 14…
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали: