Samba 4.9.1 не работает в Centos 7

Cent OS, Scientific Linux

Модератор: Модераторы разделов

demetrius2003
Сообщения: 58

Samba 4.9.1 не работает в Centos 7

Сообщение demetrius2003 »

Доброго дня, уважаемые форумчане!
Что-то преследуют меня какие-то неудачи. Уже неделю бьюсь и никак не могу заставить работать Самбу! Никак! Это просто звиздец! Дошло до того, что на виртуалке я ставлю заново Центос 7. Открываю очередную статью в гугле по настройке Самбы. Делаю всё по рецепту буква к букве. И ничего... Также в виртуалках подняты специально несколько ОС Windows от 7 до 10 версий, чтоб исключить траблы с их стороны. Но разницы не видно. Отработано десятки статей из интернета! Ошибки всегда одинаковы. От "Неверный дескриптор" до "Разрешение на доступ отсутствует". Один раз получилось создать шару для гостевого доступа. Но для проверки снёс Центос и сделал второй раз по этому же рецепту - "Разрешение на доступ отсутствует". Что это вообще? Почему оно такое сырое? Или я дурак? Как быть то? Одна система - для 1С, другая - для Самбы? Почему в одном Центосе нельзя уместить две софтины? Обязательно грабли, грабли, грабли?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:39, всего редактировалось 1 раз.
Спасибо сказали:

demetrius2003
Сообщения: 58

Re: Samba 4.9.1 не работает в Centos 7

Сообщение demetrius2003 »

Я сам уже ничего не делаю. Я ставлю чистую ОС. Открываю по порядку следующую статью, найденную в гугле по запросу "настройка Samba в Centos 7" и повторяю всё буква в букву. Уже пройдено порядка 30-ти статей! Не могут же все авторы "ошибаться"?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:39, всего редактировалось 1 раз.
Спасибо сказали:

demetrius2003
Сообщения: 58

Re: Samba 4.9.1 не работает в Centos 7

Сообщение demetrius2003 »

Вот один из самых простых вариантов:

Код: Выделить всё

yum install samba samba-client samba-common
firewall-cmd --permanent --zone=public --add-service=samba
firewall-cmd --reload
mkdir -p /srv/samba/anonymous
chmod -R 0775 /srv/samba/anonymous
chown -R nobody:nobody /srv/samba/anonymous
chcon -t samba_share_t /srv/samba/anonymous
vi /etc/samba/smb.conf
[global]
	workgroup = WORKGROUP
	netbios name = centos
	security = user
[Anonymous]
	comment = Anonymous File Server Share
	path = /srv/samba/anonymous
	browsable =yes
	writable = yes
	guest ok = yes
	read only = no
	force user = nobody
systemctl enable smb.service
systemctl enable nmb.service
systemctl start smb.service
systemctl start nmb.service
Тут вообще сложно в чём-то ошибиться! И тем не менее - это не работает!

P.S.: в этом случае, кстати, до ошибки и дело то не доходит! Винда запрашивает логи пароль. Но у меня в винде один юзер с паролем - Dima и в Линуксе пара юзверей Root и Admin. И, собственно, ни одна пара не подходит! Что ей надо? Что за глупость такая?
Последний раз редактировалось demetrius2003 15.04.2020 13:09, всего редактировалось 1 раз.
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:39, всего редактировалось 1 раз.
Спасибо сказали:

demetrius2003
Сообщения: 58

Re: Samba 4.9.1 не работает в Centos 7

Сообщение demetrius2003 »

Этот параметр в одном из вариантов отсутствовал. Ничего это не меняет. Я уже действую методом комбинаторики, тупо наугад меняя параметры и смотря, как ОНО на это реагирует. Глупо, конечно, но Линукс не оставил мне ничего другого!
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Bizdelnick »

demetrius2003 писал(а):
15.04.2020 13:06
path = /srv/samba/anonymous
Контекст selinux на этот каталог не выставляли, и политика, конечно, enforce?
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:38, всего редактировалось 1 раз.
Спасибо сказали:

Аватара пользователя
yurkats
Сообщения: 70
ОС: Fedora

Re: Samba 4.9.1 не работает в Centos 7

Сообщение yurkats »

1) Как уже упоминали, предпочтительно сделать
/etc/selinux/config
==================
SELINUX=disabled

и перезагрузиться, т.к. если не уметь правильно конфигурировать этот selinux можно очень много головняка поиметь, в большинстве случаев, он не особо нужен.

2) /etc/samba/smb.conf
=======================

security = user
map to guest = Bad Password
guest account = nobody
passdb backend = tdbsam
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:38, всего редактировалось 1 раз.
Спасибо сказали:

demetrius2003
Сообщения: 58

Re: Samba 4.9.1 не работает в Centos 7

Сообщение demetrius2003 »

Небольшой отчет. SELinux я отключил в первую очередь. Как и всякие брандмауэры в винде. Временно. Просто чтоб понять, что же происходит! Сеть настроена нормально. Все остальные сервисы работают без проблем! FTP. Да тот же xrdp, к примеру. Вообще ничего настраивать не надо. Установил, запустил и оно работает. С винды захожу на Центс без проблем! Гемор вот именно с Самбой. На данный момент что бы я ни менял в конфиге, винда запрашивает логин-пароль, хоть ты тресни. Какой пароль она просит? Пробовал подсовывать все, что заведены в системах. Бестолку. Вышеуказанный конфиг тоже ничего кардинально не меняет. Идёт запрос логина-пароля.
P.S.: конфиг не переваривает строку с "bad password" почему то. Но это меня не удивляет.
P.P.S: если свалить в кучу, т. е. написать как есть:

Код: Выделить всё

security = user
map to guest = Bad Password
guest account = nobody
passdb backend = tdbsam
то открывается пустое поле "папка пуста". Если добавить впереди [global], то ошибка - testparm ругается на строку map to guest = Bad Password. Если добавить:

Код: Выделить всё

[Samba]
path = /srv/samba
то опять запрос пароля!
Добавлено (08:16):
Напишу отдельным постом. Я так понимаю, что Самбе что-то очень сильно мешает в работе. Итого буквально:
1. Пишем раз:

Код: Выделить всё

security = user
map to quest = bad password
guest account = nobody
passdb backend = tdbsam
Получаем белое поле и "пустая папка" без пароля.
2. Пишем два:

Код: Выделить всё

security = user
map to quest = bad password
guest account = nobody
passdb backend = tdbsam
[samba]
path = /srv/samba
Получаем папку samba, но при попытке зайти в неё запрос пароля.
3. Пишем три:

Код: Выделить всё

security = user
map to quest = bad password
guest account = nobody
passdb backend = tdbsam
[samba]
path = /srv/samba
force user = nobody
guset ok = yes
browsable = yes
writable = yes
read only = no
Получаем вроде рабочий вариант. И даже [global] даёт поставить, хотя пять минут назад не давала. Проблема в том, что файлы нельзя редактировать. Т. е. если я создал текстовый файл, написал в него что-то, сохранил, то повторно открыть его можно, но сохранить он его не даст. Но это уже кое что!
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1699
ОС: Fedora 32

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Vascom »

Сообщение удалено.
Последний раз редактировалось Vascom 27.06.2020 07:37, всего редактировалось 1 раз.
Спасибо сказали:

Аватара пользователя
Serega86
Сообщения: 198
ОС: OpenSuse

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Serega86 »

Для Samba должны быть заведены пользователи с такими же именами что и в винде. И как уже сказали выше пароли для пользователей самба заводятся через smbpasswd.
Нашел у себя в заметках. Источник к сожалению утерян.
После того как файл конфигурации подготовлен проверить его на корректность командой testparm
Теперь нужно создать SAMBA-пользователей. Дело в том, что SAMBA
использует свою базу аккаунтов пользователей но в ее работе нужно чтобы
существовали и системные пользователи тоже. То есть чтобы завести SAMBA-
аккаунт сперва нужно создать системного пользователя командой useradd
а потом “связать” его с SAMBA"
Создаем системного пользователя
# useradd auser
Задаем пароль пользователю. Внимание! Если вы создаете аккаунт только для
того чтобы он пользовался SAMBA то имеет смысл закрыть ему прямой доступ
в систему задав в качестве shell /sbin/nologin в /etc/passwd Тогда пользователь
будет ограничен только возможностью использования SAMBA
# passwd auser
Теперь самый животрепещущий момент! “Связываем” системный аккаунт с
аккаунтом SAMBA, который создается после выполнения этой команды
# smbpasswd -a auser
Включаем учетную запись SAMBA (по умолчанию отключена)
# smbpasswd -e auser
Теперь можно проверить работоспособность прямо из командной строки
# smbclient //192.168.146.132/home -U auser
Password:
Domain=[LOCALHOST] OS=[Unix] Server=[Samba 3.0.33-3.7.el5]
smb: \>
Все работает!"
Все глюки Windows исправляются установкой Linux!
Спасибо сказали:

Аватара пользователя
yurkats
Сообщения: 70
ОС: Fedora

Re: Samba 4.9.1 не работает в Centos 7

Сообщение yurkats »

Чтобы не было проблем с возможностью редактирования, смотри на права и владельца файла которое создаешь в шаре
Выставь chmod -R 777 /srv/samba
chown -R nobody:nobody /srv/samba

Пользователей samba создавать не нужно, все подключившиеся будут ходить как nobody

ЗЫЖ со старыми заметками и вариантами конфигов из интернета, будьте внимательны, на крайних версиях самбы они не всегда работают так это было во времена 3 версии..., я регулярно сталкиваюсь с тем что работоспособные 5-7 летние варианты конфигов в блохах блохеров, не всегда работают на текущих версиях этого софта.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Samba 4.9.1 не работает в Centos 7

Сообщение Bizdelnick »

yurkats писал:
16.04.2020 13:54
Выставь chmod -R 777 /srv/samba
Ну вот это уже точно лишнее.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
s.xbatob
Сообщения: 1137
ОС: Fedora

Re: Samba 4.9.1 не работает в Centos 7

Сообщение s.xbatob »

yurkats писал:
16.04.2020 13:54
все подключившиеся будут ходить как nobody
А вот это — верный способ быстро превратить ресурс в помойку, которую потом и не разгрести.
Спасибо сказали:

Аватара пользователя
s.xbatob
Сообщения: 1137
ОС: Fedora

Re: Samba 4.9.1 не работает в Centos 7

Сообщение s.xbatob »

yurkats писал:
15.04.2020 19:39
1) Как уже упоминали, предпочтительно сделать
/etc/selinux/config
==================
SELINUX=disabled
там надо всего лишь пару правил добавить, к тому же setroubleshoot прямо указывает что надо сделать.
Спасибо сказали: