Замена xfce4-weather-plugin

Модератор: Модераторы разделов

Аватара пользователя
chitatel
Сообщения: 1867

Замена xfce4-weather-plugin

Сообщение chitatel »

Перестал работать xfce4-weather-plugin (0.8.2.97). Вместо данных написано: "Нет данных". :(

Debian 7.7

XFCE 4.10.0 установлен отсюда: http://packages.siduction.org

Не пойму, в чём проблема - видимо, баг в плагине...

Подскажите, есть ли что-то подобное xfce4-weather-plugin, чтобы воткнуть в панель XFCE4?

Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Замена xfce4-weather-plugin

Сообщение Bizdelnick »

chitatel писал(а):
14.10.2014 18:31
Перестал работать xfce4-weather-plugin

Шо, опять? У меня с утра работал. Правда версия из оф. репов.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
chitatel
Сообщения: 1867

Re: Замена xfce4-weather-plugin

Сообщение chitatel »

Bizdelnick писал(а):
14.10.2014 18:37
Шо, опять?

Aга. :(
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Замена xfce4-weather-plugin

Сообщение Bizdelnick »

Ан нет, у меня по-прежнему работает.

Shell

% dpkg-query -W xfce4-weather-plugin xfce4-weather-plugin 0.7.4-5

Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Fkabir
Сообщения: 369

Re: Замена xfce4-weather-plugin

Сообщение Fkabir »

met.no changed their API

https://forum.xfce.org/viewtopic.php?id=9163
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=764864

Пока решения для тех, кто на Дебиан 7 поставил плагин из Xfce 4.10, нет. Разве что откатиться на плагин из Дебиан 7. Или ставить из Сида.
Спасибо сказали:

Fkabir
Сообщения: 369

Re: Замена xfce4-weather-plugin

Сообщение Fkabir »

Ага, в Джесси уже поправили. Пересобрал пакет под Wheezy - пока только под i386
Скачатьxfce4-weather-plugin_0.8.3-2_i386.deb
Спасибо сказали:

Аватара пользователя
chitatel
Сообщения: 1867

Re: Замена xfce4-weather-plugin

Сообщение chitatel »

Fkabir писал(а):
30.10.2014 00:10
Пока решения для тех, кто на Дебиан 7 поставил плагин из Xfce 4.10, нет. Разве что откатиться на плагин из Дебиан 7. Или ставить из Сида.

У меня XFCE4 4.10 из Siduction'a и эти workaround'ы не прокатывают. :(
Спасибо сказали:

Fkabir
Сообщения: 369

Re: Замена xfce4-weather-plugin

Сообщение Fkabir »

Спасибо сказали:

Fkabir
Сообщения: 369

Re: Замена xfce4-weather-plugin

Сообщение Fkabir »

Ну шо, наша песня хороша... Поставил Jessie, там версия плагина 0.8.3-2
Снова не ищет по городам и не кажет погоду...

Версия из бекпортов wheezy не подходит. Новых бекпортов пока нет. Видимо, чтоб не перемешивать стейбл с другим, надо ждать...
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Замена xfce4-weather-plugin

Сообщение Bizdelnick »

Fkabir писал(а):
01.05.2015 10:44
0.8.3-2
Снова не ищет по городам и не кажет погоду...

Странно, УМВР.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Fkabir
Сообщения: 369

Re: Замена xfce4-weather-plugin

Сообщение Fkabir »

Хм, сейчас и у меня работает. Днем не находился город...
Спасибо сказали:

Аватара пользователя
chitatel
Сообщения: 1867

Re: Замена xfce4-weather-plugin

Сообщение chitatel »

Кажись, weather-plugin отвалился теперь и в jessie. :(

В debian-russian рассылке тоже кто-то пишет о проблеме.

Я так полагаю, у Debian это уже традиция - нагадить с плагином погоды в XFCE4.

P.S.
Вот такое понравилось: http://www.opennet.ru/tips/3013_weather_cli_shell_curl.shtml
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 18483
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Замена xfce4-weather-plugin

Сообщение Bizdelnick »

Отвалился, ага. Только то не вина дебиана. На api.met.no в очередной раз перестали поддерживать версию протокола, которую использует плагин.
https://api.met.no/weatherapi/locationforec...3/documentation
- New version 1.3. The old version, 1.2, will expire at 2017-05-09.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

Аватара пользователя
alv
Бывший модератор
Сообщения: 7268
Статус: Пенсионер в законе
ОС: Cintu

Re: Замена xfce4-weather-plugin

Сообщение alv »

chitatel писал(а):
14.10.2014 18:31
Перестал работать xfce4-weather-plugin

А что, кросс-ОСный, кросс-дистрибутивный и кросс-десктопный плагин чукча дрова собирает уже отменили?
Спасибо сказали:

Аватара пользователя
chitatel
Сообщения: 1867

Re: Замена xfce4-weather-plugin

Сообщение chitatel »

alv писал(а):
20.05.2017 17:20
chitatel писал(а):
14.10.2014 18:31
Перестал работать xfce4-weather-plugin

А что, кросс-ОСный, кросс-дистрибутивный и кросс-десктопный плагин чукча дрова собирает уже отменили?

Чукча не собиратель. Чукча охотник и/или оленевод. :)

Наверное соберу, да, как руки дойдут.
Спасибо сказали: