OpenBox и муьтимедийные пллееры (Ни один не работает)

Модератор: Модераторы разделов

Tocaor
Сообщения: 124
ОС: Debian Lenny, Saueeze

OpenBox и муьтимедийные пллееры

Сообщение Tocaor »

В общем такая ситуация. Сначала перелез на OpenBox что называется по нужде. Машинка старая, ни KDE, ни GNOME, ни даже XFCE по нормальному не тянет. Сначала поставил LXDE, а потом решил, коль уж настраивать так всё под себя и с самого начала. И вот уже всё вроде стоит и работает, только вот какая проблема организовалась. Ни VLC, ни SMplayer не проигрывают вообще никакое видео. VLC проигрывает звук и показывает чёрное окно, а SMPlayer вообще какую то ошибку выдают с кодом "1". В чём может быть проблема? Есть подозрение на дрова видюхи. Не знаю, могут они влиять? Дело в том что в процессе сборки поддержки 3D возникли какие то проблемы. Я разбираться не стал и оставил как есть. 2D мне вообще то за глаза хватит. Но сам fglrx вроде нормально встал. Если в нём проблема то как это узнать?
Спасибо сказали:

liaonau
Сообщения: 390
ОС: gentoo

Re: OpenBox и муьтимедийные пллееры

Сообщение liaonau »

Tocaor писал(а):
17.02.2011 18:30
VLC проигрывает звук и показывает чёрное окно, а SMPlayer вообще какую то ошибку выдают с кодом "1".

Какую именно?

Плееры у вас только при запущенном openbox не работают что ли?

Tocaor писал(а):
17.02.2011 18:30
Если в нём проблема то как это узнать?

Например, запустить иксы с vesa драйвером. Но при чем здесь openbox?
Спасибо сказали:

Tocaor
Сообщения: 124
ОС: Debian Lenny, Saueeze

Re: OpenBox и муьтимедийные пллееры

Сообщение Tocaor »

SMPlayer чудодейственным способом заработал. Может надо было перезагрузиться? А VLC до сих пор показывает чёрный экран и в сообщениях выдаёт седующее:

Код: Выделить всё

swscale error: could not init SwScaler and/or allocate memory

Хотя swscale стоит.
Не знаю при чём тут OpenBox. Это всего лишь предположение.
Спасибо сказали:

liaonau
Сообщения: 390
ОС: gentoo

Re: OpenBox и муьтимедийные пллееры

Сообщение liaonau »

Tocaor писал(а):
18.02.2011 06:51

Код: Выделить всё

swscale error: could not init SwScaler and/or allocate memory

Хотя swscale стоит.

Ну значит проблема или в ffmpeg (swscale), vlc его использует, или в видео драйвере/настройках.
Поставьте другую версию ffmpeg (или у вас отдельно пакет swscale, можно предположить) или же вначале поизменяйте xorg.conf, а может вообще все заработает с иными -vo? xv или gl (это для mplayer, для vlc не знаю как переключать способы вывода)
Tocaor писал(а):
18.02.2011 06:51
Не знаю при чём тут OpenBox. Это всего лишь предположение.

Абсолютно ни при чем. Тему стоило бы перенести в “Видео”, было бы возможно больше ответов.
Спасибо сказали:

Аватара пользователя
Fangelion
Сообщения: 112
ОС: Debian GNU/Linux

Re: OpenBox и муьтимедийные пллееры

Сообщение Fangelion »

Tocaor писал(а):
18.02.2011 06:51
SMPlayer чудодейственным способом заработал. Может надо было перезагрузиться? А VLC до сих пор показывает чёрный экран и в сообщениях выдаёт седующее:

Код: Выделить всё

swscale error: could not init SwScaler and/or allocate memory

Хотя swscale стоит.
Не знаю при чём тут OpenBox. Это всего лишь предположение.


Да. есть бага с библиотекой libswscale0. Нужна версия 4:0.5.2-6.
Спасибо сказали: