Слишком мелкий текст (в LXDE при запуске на ТВ через HDMI)

Модератор: Модераторы разделов

Аватара пользователя
Mahoney
Сообщения: 200
ОС: Fedora

Слишком мелкий текст

Сообщение Mahoney »

Доброго времени суток.

Основная DE у меня KDE. Но с помощью bumblebee я запускаю на HDMI выходе другой экземпляр X сервера с LXDE. Помнится, при первом запуске всё было нормально. А сейчас все шрифты очень мелкие. И это на 42" экране!
Я пробовал увеличивать шрифты в настройках, но они увеличиваются не везде.
Я в этом LXDE планирую пускать в основном VLC, чтобы фильмы всякие смотреть на большом экране. А там шрифты мелкие. В окнах ничего не видно. Как бы пофиксить?
I code, therefore I am...
Спасибо сказали:

Аватара пользователя
moonglow
Сообщения: 90
ОС: CentOS

Re: Слишком мелкий текст

Сообщение moonglow »

Mahoney писал(а):
06.01.2014 02:06
Я в этом LXDE планирую пускать в основном VLC

в настройках VLC выберите тему GTK+, шрифты станут такими же, как в остальной системе

настройки шрифтов разные у GTK+ и Qt, по-этому во всем LXDE шрифт будет один, а в одной программе, например, в k3b - другой, потому что она на Qt

по-этому, Вам нужно изменить все настройки для программ на GTK+ (в LXDE их несколько, все можно найти через меню->Preferences)
И все настройки для программ на Qt (конфигуратором Qt, в LXDE этих настроек нет, в LXDE настройки только для GTK+)

если между запусками сбиваются настройки, то проверьте доступ на запись в домашний каталог, все настройки LXDE хранятся в директории .config в домашнем каталоге
Спасибо сказали:

Аватара пользователя
Mahoney
Сообщения: 200
ОС: Fedora

Re: Слишком мелкий текст

Сообщение Mahoney »

moonglow писал(а):
06.01.2014 04:38
в настройках VLC выберите тему GTK+, шрифты станут такими же, как в остальной системе

А нету у меня в настройках VLC темы GTK+. Можно только в рамках темы Qt выбрать оформление в стиле Gtk+. Но размер шрифтов при этом не меняется.
В репозитории смотрел, нет там ничего вроде vlc-gtk+.

moonglow писал(а):
06.01.2014 04:38
И все настройки для программ на Qt (конфигуратором Qt, в LXDE этих настроек нет, в LXDE настройки только для GTK+)

А что за конфигуратор такой? Никогда не видел. В меню "Настройки" есть пункт "Параметры системы KDE", но он не открывается. Наверно по той же причине, что и сам KDE во втором экземпляре не стартует...
I code, therefore I am...
Спасибо сказали:

Аватара пользователя
Mahoney
Сообщения: 200
ОС: Fedora

Re: Слишком мелкий текст

Сообщение Mahoney »

Решил проблему добавлением строки

Код: Выделить всё

xrandr --dpi 120x120


в скрипт запуска LXDE.
I code, therefore I am...
Спасибо сказали: