Орг вопрос. Разные пакетные менеджеры и репозитарии

Knoppix

Модератор: Warderer

Аватара пользователя
rain_99
Сообщения: 917
ОС: Debian

Орг вопрос. Разные пакетные менеджеры и репозитарии

Сообщение rain_99 » 14.06.2018 06:26

Доброго всем дня.
Debian Stable - на текущий момент.
Remmina подключена через
deb http://ftp.debian.org/debian stretch-backports main

При обновлении update-upgrade apt-get говорит

Код: Выделить всё

Пакеты, которые будут оставлены в неизменном виде:
  remmina remmina-common remmina-plugin-rdp remmina-plugin-secret remmina-plugin-vnc
А почему он в неименном виде порой оставляет, и приходится делать

Код: Выделить всё

root@debian:/home/rain# apt-get install remmina
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но 0.7.3-2 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
В этот раз вставать отказался.
Почитал про аптитьюд - пробую через него

Код: Выделить всё

root@debian:/home/rain# aptitude install remmina
Следующие пакеты будут УДАЛЕНЫ:               
  libssh-4{u} 
Следующие пакеты будут обновлены:
  remmina{b} remmina-common 
2 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 3 пакетов не обновлено.
Необходимо получить 428 kБ архивов. После распаковки освободится 333 kБ.
Следующие пакеты имеют неудовлетворённые зависимости:
 remmina : Зависит: libssh-4 (>= 0.8.0~20170825.94fa1e38) но его установка не запланирована
 remmina-plugin-rdp : Зависит: remmina (= 1.2.0-rcgit.29+dfsg-1~bpo9+1) но устанавливается 1.2.30.1+dfsg-1~bpo9+1
 remmina-plugin-secret : Зависит: remmina (= 1.2.0-rcgit.29+dfsg-1~bpo9+1) но устанавливается 1.2.30.1+dfsg-1~bpo9+1
 remmina-plugin-vnc : Зависит: remmina (= 1.2.0-rcgit.29+dfsg-1~bpo9+1) но устанавливается 1.2.30.1+dfsg-1~bpo9+1
Следующие действия разрешат зависимости:

     Обновить следующие пакеты:                                                                                
1)     libssh-4 [0.7.3-2 (now, stable) -> 0.8.0~20170825.94fa1e38-1~bpo9+1 (stretch-backports)]                
2)     remmina-plugin-rdp [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now) -> 1.2.30.1+dfsg-1~bpo9+1 (stretch-backports)]   
3)     remmina-plugin-secret [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now) -> 1.2.30.1+dfsg-1~bpo9+1 (stretch-backports)]
4)     remmina-plugin-vnc [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now) -> 1.2.30.1+dfsg-1~bpo9+1 (stretch-backports)]   



Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                                                                              
1)     remmina-plugin-secret [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now)]                                           

     Обновить следующие пакеты:                                                                             
2)     libssh-4 [0.7.3-2 (now, stable) -> 0.8.0~20170825.94fa1e38-1~bpo9+1 (stretch-backports)]             
3)     remmina-plugin-rdp [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now) -> 1.2.30.1+dfsg-1~bpo9+1 (stretch-backports)]
4)     remmina-plugin-vnc [1.2.0-rcgit.29+dfsg-1~bpo9+1 (now) -> 1.2.30.1+dfsg-1~bpo9+1 (stretch-backports)]

     Оставить следующие зависимости неразрешёнными:                                                         
5)     remmina рекомендует remmina-plugin-secret                                                            



Принять данное решение? [Y/n/q/?] q
Отмена всех результатов по разрешению данных зависимостей.
Прервать.
Теперь два вопроса.
1. Если реммина лежит в офф репах - а бакпорты - это все же не посторонние. То почему не устанавливает apt?
2. Я так понимаю - аптитьюд все установит, но и все поломает?
...Все в наших руках...
Спасибо сказали:

Аватара пользователя
yoricI
Сообщения: 527
ОС: gentoo fluxbox

Re: Орг вопрос. Разные пакетные менеджеры и репозитарии

Сообщение yoricI » 14.06.2018 08:13

Попробуйте apt-get dist-upgrade
Спасибо сказали:

Аватара пользователя
rain_99
Сообщения: 917
ОС: Debian

Re: Орг вопрос. Разные пакетные менеджеры и репозитарии

Сообщение rain_99 » 14.06.2018 08:27

чтото странное

Код: Выделить всё

root@debian:/home/rain# apt-get dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  ayatana-indicator-application ayatana-indicator-common libayatana-appindicator3-1 libayatana-ido3-0.4-0
  libayatana-indicator3-7 libfreerdp-client2-2 libfreerdp2-2 libssh-4 libvncclient1 libwinpr2-2 remmina-common
Для их удаления используйте «apt autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  remmina remmina-plugin-rdp remmina-plugin-secret remmina-plugin-vnc
Пакеты, которые будут обновлены:
  remmina-common
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 4 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 277 kБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 569 kB.
Хотите продолжить? [Д/н] n
Аварийное завершение.
root@debian:/home/rain# apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 5 пакетов не обновлено.
...Все в наших руках...
Спасибо сказали:

Аватара пользователя
yoricI
Сообщения: 527
ОС: gentoo fluxbox

Re: Орг вопрос. Разные пакетные менеджеры и репозитарии

Сообщение yoricI » 14.06.2018 09:37

Полностью sources.list[.d] покажите.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14482
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Орг вопрос. Разные пакетные менеджеры и репозитарии

Сообщение Bizdelnick » 14.06.2018 09:43

rain_99 писал:
14.06.2018 06:26
Если реммина лежит в офф репах - а бакпорты - это все же не посторонние. То почему не устанавливает apt?
У Вас установлен libssh-4 из stable, а нужна версия из stretch-backports. Поскольку репозиторий backports имеет более низкий приоритет, автоматически пакет не обновится. Надо указать явно, какой репозиторий использовать. Так по идее должно сработать: apt install -t stretch-backports remmina
rain_99 писал:
14.06.2018 06:26
Я так понимаю - аптитьюд все установит, но и все поломает?
Не должен ничего поломать.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали: