Решено: Не работает Compiz

Модератор: Skull

did
Сообщения: 31
ОС: openSUSE-11.0

Решено: Не работает Compiz

Сообщение did » 09.01.2010 19:27

Здравствуйте уважаемые. Решил обратиться к Вам со своей проблемой.
Краткая конфигурация машины: ОС Альт Мастер-5.0; Intel P4 2.4; ECS848p-A; DDR-RAM 1024Mb; Asus AGP NV 128mb.
Установил Альт мастер 5.0 для сыновей ну и сам заинтерисовался школьным Линуксом. В общем все что мне надо на первое время настроил, работает но захотел показать домашним 3D эффекты во всей красе и настроить Компиз. Пакеты по моему установлены все по «apt-cache search compiz». Проблема состоит в том что работать он не хочет, на команду simple-ccsm окно Мененджера открывается и на этом все, консоль выдает:

/usr/bin/simple-ccsm:40: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips = gtk.Tooltips()
/usr/bin/simple-ccsm:182: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips = gtk.Tooltips()
/usr/bin/simple-ccsm:415: DeprecationWarning: Use the new widget gtk.Tooltip
Tooltips.set_tip(self, _("Disabled"))

честно говоря не понял что надо...? на команду #compiz --replace выдает:

Compiz(core error)-Error: Couldn't load plugin 'glib'
Compiz(core error)-Error: Couldn't load plugin'gnomecompat'

Здесь типа что-то не грузится...? пакет 'glib' установлен . После этой команды чернеет а затем
все что было открыто на разных рабочих столах оказывается на одном, оформление окон нет
не пододвинуть не закрыть.. и ни каких эффектов, по Alt+Ctrl+право-лево куб должен вращаться ? Нету..
На форумах советуют подредактировать /etc/X11/xorg.conf привожу его ниже:

Section "ServerFlags"
EndSection

Section "ServerLayout"
Identifier "Minimal layout"
Screen "Screen0"
EndSection

Section "Module"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "Device"
Identifier "Card0|0"
Driver "nvidia"
EndSection

Section "Monitor"
DisplaySize 380 300
VertRefresh 56-75
HorizSync 30-83
Identifier "L1953S|0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device "Card0|0"
Monitor "L1953S|0"

SubSection "Display"

Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600" "960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
EndSubSection
EndSection

В частности добавить в секцию «Extensions» эти строки:
Option «RENDER» «Enadle»
Option «Composite» «Enable»

в секцию «Screen»
Option»AllowGLXWithComposite» «True»
Option»AddARGBGLXVisuals» «True»

Но я думаю что этим вовсе сломаю иксы, тем более секции «Extensions» вообще нет. Или я не прав..? Ниже приведу выводы команд которые по моему должны как-то помочь этой проблеме:

[did@comp-Pentium-4-7da90b ~]$ rpm -qa | grep nvidia
nvidia_glx_185.18.36-185.18.36-alt71
kernel-modules-nvidia-std-def-185.18.36-alt2.132638.14
nvidia_glx_173.14.20-173.14.20-alt54
nvidia_glx_common-185.18.36-alt71
nvidia_glx_96.43.13-96.43.13-alt44


[did@comp-Pentium-4-7da90b ~]$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)


[root@comp-Pentium-4-7da90b ~]# glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce FX 5200/AGP/SSE2

Заранее благодарен.
Спасибо сказали:

Аватара пользователя
starik
Сообщения: 200

Re: Решено: Не работает Compiz

Сообщение starik » 16.01.2010 22:08

думаю здесь вы найдете больше специалистов по Альтлинукс, возможно и ответят скорее форум АЛЬТЛинукс
Спасибо сказали:

Аватара пользователя
megabaks
Сообщения: 697
ОС: Gentoo ~x86

Re: Решено: Не работает Compiz

Сообщение megabaks » 17.01.2010 14:53

компиз лучше запускать так

Код: Выделить всё

compiz-manager
или так

Код: Выделить всё

fusion-icon
если последний установлен,конечно
Спасибо сказали:

did
Сообщения: 31
ОС: openSUSE-11.0

Re: Решено: Не работает Compiz

Сообщение did » 21.01.2010 18:32

Всем спасибо с проблемой разобрался.
Спасибо сказали: