Не могу сделать update

Cent OS, Scientific Linux

Модератор: Модераторы разделов

Аватара пользователя
kerogaz
Сообщения: 865
ОС: CentOS,FreeBSD 12.0

Не могу сделать update

Сообщение kerogaz »

Fedora 31 Появились сообщения

Код: Выделить всё

dnf update
Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    from dnf.cli import main
  File "/usr/lib/python3.7/site-packages/dnf/__init__.py", line 30, in <module>
    import dnf.base
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 31, in <module>
    from dnf.comps import CompsQuery
  File "/usr/lib/python3.7/site-packages/dnf/comps.py", line 27, in <module>
    from dnf.exceptions import CompsError
  File "/usr/lib/python3.7/site-packages/dnf/exceptions.py", line 22, in <module>
    import dnf.util
  File "/usr/lib/python3.7/site-packages/dnf/util.py", line 30, in <module>
    import dnf.callback
  File "/usr/lib/python3.7/site-packages/dnf/callback.py", line 22, in <module>
    import dnf.yum.rpmtrans
  File "/usr/lib/python3.7/site-packages/dnf/yum/rpmtrans.py", line 26, in <module>
    import rpm
  File "/usr/lib64/python3.7/site-packages/rpm/__init__.py", line 38, in <module>
    from rpm._rpm import *
ImportError: /lib64/librpmbuild.so.9: file too short
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1578
ОС: Fedora 31

Re: Не могу сделать update

Сообщение Vascom »

Что-то сломал. Проверь целостность указанной либы.
Спасибо сказали:

Аватара пользователя
kerogaz
Сообщения: 865
ОС: CentOS,FreeBSD 12.0

Re: Не могу сделать update

Сообщение kerogaz »

Да ничего я не ломал. Кроме dnf update ничего не делал
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1578
ОС: Fedora 31

Re: Не могу сделать update

Сообщение Vascom »

Может хард сыпется?
Спасибо сказали:

Аватара пользователя
kerogaz
Сообщения: 865
ОС: CentOS,FreeBSD 12.0

Re: Не могу сделать update

Сообщение kerogaz »

Как исправить ощибку? Может yum утановить?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1578
ОС: Fedora 31

Re: Не могу сделать update

Сообщение Vascom »

Yum нет в ф31.
Проверь целостность либы.
Спасибо сказали:

Аватара пользователя
kerogaz
Сообщения: 865
ОС: CentOS,FreeBSD 12.0

Re: Не могу сделать update

Сообщение kerogaz »

dnfdragora вообще не запускается Пишет "Ой похоже произошел сбой .... отправьте отчет чтобы нам помочь :)
А dnfdragora-updater вообще ничего не сообщает и не запускается. Нажимаешь на виджет как на пустое место
Добавлено (13:01):
запускал с предыдущих ядер - то же самое. Я предыдущий update сделал нормально а на этом такая вот история. Есть какой то кардинальный способ исправить положение ( без копания в проверках целостности библиотек и т.д.)?
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1578
ОС: Fedora 31

Re: Не могу сделать update

Сообщение Vascom »

Нет.
Спасибо сказали:

Аватара пользователя
s.xbatob
Сообщения: 873
ОС: Fedora

Re: Не могу сделать update

Сообщение s.xbatob »

kerogaz писал(а):
28.12.2019 12:32
ImportError: /lib64/librpmbuild.so.9: file too short
файл повреждён. Или смотрит не туда.
Что говорит ls?

Shell

# ls -l /lib64/librpmbuild.so.9*
lrwxrwxrwx. 1 root root 20 Nov 19 12:41 /lib64/librpmbuild.so.9 -> librpmbuild.so.9.0.1
-rwxr-xr-x. 1 root root 204112 Nov 19 12:41 /lib64/librpmbuild.so.9.0.1
Спасибо сказали:

Аватара пользователя
Vascom
Сообщения: 1578
ОС: Fedora 31

Re: Не могу сделать update

Сообщение Vascom »

Как успехи?
Спасибо сказали: