gentoo заскоки

Sabayon, Calculate, Funtoo, Exherbo

Модератор: /dev/random

Аватара пользователя
/dev/random
Администратор
Сообщения: 5300
ОС: Gentoo

Re: gentoo заскоки

Сообщение /dev/random »

bars писал:
12.03.2022 16:10
Что за обратная зависимость rust?
"Обратные зависимости" - это пакеты, которые зависят от указанного. В данном случае, от llvm. В цитате написано, что некоторые из этих пакетов, в т.ч. rust, ломаются, если выключить эти архитектуры.
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

/dev/random писал:
12.03.2022 16:14
"Обратные зависимости" - это пакеты, которые зависят от указанного. В данном случае, от llvm. В цитате написано, что некоторые из этих пакетов, в т.ч. rust, ломаются, если выключить эти архитектуры.
Ясно.
Плохо что llvm не доработка при сборке пакета такая.
Время увеличилось примерно на 20-30% сборки пакета.
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Код: Выделить всё

$ eselect news read 58
2022-04-19-systemd-utils
  Title                     Migration to sys-apps/systemd-utils
Лезет и лезет. Своим одиозным именем всех распугает.
Спасибо сказали:
Аватара пользователя
ormorph
Сообщения: 2666
ОС: Gentoo

Re: gentoo заскоки

Сообщение ormorph »

У меня тоже прикол получился. Взял новую игрушку, решил на внешний hdd установить минимальную ОС Gentoo. Делал наиболее минимальную конфигурацию ядра, добавил для wifi. Смотрю все интерфейсы появились, значит все замечательно перед этим собрал ещё wpa_supplicant, для wifi. Запустил, соединился по ssh, начал настраивать через ssh wifi. Настроил, так как wireless-tools не установлен, смотрел параметры сети через пакет на компе на котором подключался по ssh.
В общем все замечательно заработало интернет по wifi пошёл. И тут я решил накатить wireless-tools, и посмотреть параметры сети, и тут то получился облом:

Shell

# iwlist wlp1s0 scanning
wlp1s0 Interface doesn't support scanning
Не думал, что конфигурация получится на столько минималистичной, что даже нельзя будет просмотреть информацию о сети и устройстве.

Shell

# iwconfig wlp1s0
wlp1s0 no wireless extensions.
При этом соединение работает нормально.
Пока комп в работе, и пере собрать ядро не могу. Пока грешу в сторону нехватки IEEE 802.11.
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Скажите пож-ста, зачем система лепит мне опять llvm-15? Кому он нужен? 13 и 14 стоят.

Код: Выделить всё

globus@aspera ~ $ equery d sys-devel/llvm-15.0.3
 * These packages depend on sys-devel/llvm-15.0.3:
dev-libs/libdispatch-5.3.3-r1 (sys-devel/llvm)
media-libs/mesa-22.1.7 (video_cards_r600 ? sys-devel/llvm:14[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?,llvm_targets_AMDGPU(-)])
sys-devel/clang-13.0.1 (~sys-devel/llvm-13.0.1:13[debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
sys-devel/lld-13.0.1-r1 (~sys-devel/llvm-13.0.1)
sys-devel/llvmgold-14 (sys-devel/llvm:14[binutils-plugin])
sys-libs/compiler-rt-13.0.1 (sys-devel/llvm:13)
sys-libs/compiler-rt-sanitizers-13.0.1 (sys-devel/llvm:13)
sys-libs/libomp-14.0.6-r1 (offload ? ~sys-devel/llvm-14.0.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
www-client/firefox-91.13.0 (sys-devel/llvm:14)
                           (sys-devel/llvm:13)
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

yoricI писал:
11.11.2022 06:16
Скажите пож-ста, зачем система лепит мне опять llvm-15? Кому он нужен? 13 и 14 стоят.
Видать для сборки пакетов по зависимостям идет.
Вся эта нечесть ресурсоемкая llvm/rust нужна только для сборки пакетов, покрайне мере у меня.
rust хоть сделали бинарный пакет rust-bin, что бы не насиловать компутер, а вот llvm нет бинарника, плохо.

У меня у самого сейчас выдало обновления.

Код: Выделить всё

[ebuild     U ] sys-devel/llvm-common-15.0.3 [14.0.6]
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
ormorph
Сообщения: 2666
ОС: Gentoo

Re: gentoo заскоки

Сообщение ormorph »

yoricI писал:
11.11.2022 06:16
llvm-15? Кому он нужен? 13 и 14 стоят.
Мне больше интересно зачем вам 13 версия. С 14 всё понятно, 15 идет так как доступна как стабильная, у вас же llvm установлен. А старые 13 и 14 доступны, так как в установленных ебилдах прописано:

Код: Выделить всё

LLVM_MAX_SLOT=14
или
LLVM_MAX_SLOT=13
Если мне не нужно слишком много llvm, то я просто в свой локальный оверлей добавляю копии c r-1..x ипрописываю последний LLVM_MAX_SLOT=15 например в qt-creator, и если сборка прошла норм, тов всё замечательно, все неиспользуемые llvm удаляются автоматически по depclean.
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Специально я её не устанавливал, может только нечаянно. Зачем они так намутили с этими всеми clang, llvm, lld, rt-comp etc?
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Пару недель уже висит и не проходит обновление:
Total: 34 packages (34 upgrades, 3 uninstalls), Size of downloads: 281 018 KiB Conflict: 3 blocks (all satisfied) !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.36.0-r1:0/5.36::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" pulled in by =dev-lang/perl-5.36* required by (virtual/perl-Data-Dumper-2.184.0:0/0::gentoo, ebuild scheduled for merge) USE="" ^ ^^^^^ (and 32 more with the same problem) (dev-lang/perl-5.34.1-r4:0/5.34::gentoo, installed) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" pulled in by dev-lang/perl:0/5.34= required by (dev-perl/IO-Socket-SSL-2.72.0:0/0::gentoo, installed) USE="-examples -idn -test" ^^^^^^^^ dev-lang/perl:0/5.34= required by (dev-perl/Devel-CheckLib-1.140.0:0/0::gentoo, installed) USE="-test" ^^^^^^^^ =dev-lang/perl-5.34* required by (virtual/perl-Test-Simple-1.302.183:0/0::gentoo, installed) USE="" ^ ^^^^^ dev-lang/perl:0/5.34= required by (dev-perl/URI-5.100.0:0/0::gentoo, installed) USE="-test" ^^^^^^^^ dev-lang/perl:0/5.34= required by (dev-perl/Devel-StackTrace-2.40.0:0/0::gentoo, installed) USE="-test" ^^^^^^^^ dev-lang/perl:0/5.34= required by (dev-perl/File-Listing-6.140.0:0/0::gentoo, installed) USE="-test" ^^^^^^^^ =dev-lang/perl-5.34.1-r4 required by (virtual/perl-IO-Compress-2.103.0-r2:0/0::gentoo, installed) USE="" ^ ^^^^^^^^^ dev-lang/perl:0/5.34= required by (dev-perl/Date-Manip-6.850.0:0/0::gentoo, installed) USE="-test" (and 131 more with the same problems) NOTE: Use the '--verbose-conflicts' option to display parents omitted above !!! The slot conflict(s) shown above involve package(s) which may need to !!! be rebuilt in order to solve the conflict(s). However, the following !!! package(s) cannot be rebuilt for the reason(s) shown: (dev-perl/IO-Socket-SSL-2.72.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/File-Listing-6.140.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/Devel-CheckLib-1.140.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/URI-5.100.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/Date-Manip-6.850.0:0/0::gentoo, installed): ebuild is masked or unavailable
И облом.

Но тем не менее:
# eix dev-perl/IO-Socket-SSL и все подобные \[U\] dev-perl/IO-Socket-SSL Available versions: 2.74.0^t ~2.78.0^t {examples idn test} Installed versions: 2.72.0^t(15:34:55 26.01.2022)(-examples -idn -test) Homepage: https://metacpan.org/release/IO-Socket-SSL Description: Nearly transparent SSL encapsulation for IO::Socket::INET
Что не так опять?
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

Недавно обновился, ошибок вроде не было.

Код: Выделить всё

# qlist -IvU | egrep 'IO-Socket-SS|perl-5'
dev-lang/perl-5.36.0-r1 -berkdb -debug -doc gdbm -ithreads -minimal -quadmath
dev-perl/IO-Socket-SSL-2.74.0 -examples -idn -test
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Код: Выделить всё

# qlist -IvU | egrep 'IO-Socket-SS|perl-5'
dev-lang/perl-5.34.1-r4 -berkdb -debug -doc gdbm -ithreads -minimal -quadmath
dev-perl/IO-Socket-SSL-2.72.0 -examples -idn -test
(dev-perl/IO-Socket-SSL-2.72.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/File-Listing-6.140.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/Devel-CheckLib-1.140.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/URI-5.100.0:0/0::gentoo, installed): ebuild is masked or unavailable (dev-perl/Date-Manip-6.850.0:0/0::gentoo, installed): ebuild is masked or unavailable
Думаю снести их, но что-то боязно. Почему пишет, что ebuild-ы недоступны, если в системе пакеты находятся?
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

yoricI писал:
28.12.2022 07:08
Думаю снести их, но что-то боязно. Почему пишет, что ebuild-ы недоступны, если в системе пакеты находятся?
Извините за не скромный вопрос, дерево портов обновляли? :unsure:
Может замаскированы вами?
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

bars писал:
28.12.2022 09:32
Извините за не скромный вопрос, дерево портов обновляли? :unsure:Может замаскированы вами?
Естественно обновлял. Ничего не маскировал, оно само после очередного олбановления сломалось.

Код: Выделить всё

 $ grep -r dev-perl /etc/portage/*
globus@aspera ~ $ eix dev-perl/Date-Manip
[U] dev-perl/Date-Manip
     Available versions:  6.890.0^t {test}
     Installed versions:  6.850.0^t(09:43:35 26.01.2022)(-test)
     Homepage:            https://metacpan.org/release/Date-Manip
     Description:         Perl date manipulation routines 
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5300
ОС: Gentoo

Re: gentoo заскоки

Сообщение /dev/random »

Попробуйте очистить ненужные зависимости (emerge -ac и убедитесь, что он не пытается удалить нужные вам пакеты). Если не поможет, то попробуйте явным образом обновить те проблемные 5 пакетов (emerge -1u {имена}).
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

По depclean всё чисто, ничего не удалялось, непосредственно эти пять обновились. Но дальше продолжается:

Код: Выделить всё

Total: 63 packages (58 upgrades, 5 new, 3 uninstalls), Size of downloads: 293 563 KiB
Conflict: 3 blocks (all satisfied)
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
dev-lang/perl:0
  (dev-lang/perl-5.36.0-r1:0/5.36::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" pulled in by
    =dev-lang/perl-5.36* required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r8:0/0::gentoo, installed) USE=""
    ^              ^^^^^                                                                                                                                         
    (and 32 more with the same problem)

  (dev-lang/perl-5.34.1-r4:0/5.34::gentoo, installed) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" pulled in by
    =dev-lang/perl-5.34.1-r4 required by (virtual/perl-IO-Compress-2.103.0-r2:0/0::gentoo, installed) USE=""
    ^              ^^^^^^^^^                                                                                                                                       
    dev-lang/perl:0/5.34= required by (dev-perl/Net-HTTP-6.210.0:0/0::gentoo, installed) USE="-minimal -test"
                 ^^^^^^^^                                                                                                                                                              
    =dev-lang/perl-5.34* required by (virtual/perl-IO-1.460.0:0/0::gentoo, installed) USE=""
    ^              ^^^^^                                                                                                                           
    (and 136 more with the same problems)
И вываливается. Снести вручную 136 пакетов, которые perl-5.34 держат?

Это по @system не проходило, попробовал по @world - пошло. Извините за беспокойство))
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

Хмм, ван нужно обновить dev-lang/perl-5.36, в этом все беда.
И после perl-cleaner --all и perl-cleaner --reallyall может поможет очистить старые библиотеки.
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Когда-то так делал, но уже долгонько оно всё саамо по @*** проходило. А Вы делали так, или само прошло?
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

yoricI писал:
28.12.2022 14:05
Когда-то так делал, но уже долгонько оно всё саамо по @*** проходило. А Вы делали так, или само прошло?
Делаю после обновления perla.
perl-cleaner --all и perl-cleaner --reallyall
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

bars писал:
28.12.2022 15:41
Делаю после обновления perla.
perl-cleaner --all и perl-cleaner --reallyall
Надо будет и мне вспомнить про эту практику))
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Почему не обновляется телеграм, что ему надо?

Shell

# grep -r telegram /etc/portage/*
/etc/portage/package.accept_keywords/net-im:net-im/telegram-desktop ~amd64

$ eix telegram
[U] net-im/telegram-desktop
Available versions: 4.8.1-r2 (~)4.8.3 {+X +dbus enchant +fonts +jemalloc qt6 qt6-imageformats screencast wayland}
Installed versions: 4.8.1-r2(23:00:33 23.06.2023)(X dbus fonts jemalloc -enchant -qt6 -qt6-imageformats -screencast -wayland)

# emerge -av net-im/telegram-desktop
[ebuild R ] net-im/telegram-desktop-4.8.1-r2::gentoo USE="X dbus fonts (jemalloc) -enchant -qt6 -qt6-imageformats -screencast -wayland" 0 KiB

!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

net-im/telegram-desktop:0
Как посмотреть неудовлетворительные зависимости?
Последний раз редактировалось /dev/random 16.07.2023 12:50, всего редактировалось 1 раз.
Причина: В [ish] некоторые части лога воспринимаются как bbcode-теги. Заменил на [sh].
Спасибо сказали:
Аватара пользователя
ormorph
Сообщения: 2666
ОС: Gentoo

Re: gentoo заскоки

Сообщение ormorph »

yoricI писал:
16.07.2023 07:25
Как посмотреть неудовлетворительные зависимости?
Кто же его знает, попробуйте отдельно пере собрать данный пакет. Ту вам показывает только то, что данный пакет пропущен при обновлении. На сколько я понял там какой то прикол флагом jemalloc, у вас он ни где не замаскерован?
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Так я и пробую, пересобирается стабильный устаревший, а должен ~
ormorph писал(а):
16.07.2023 09:38
прикол флагом jemalloc, у вас он ни где не замаскерован?
Нет
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5300
ОС: Gentoo

Re: gentoo заскоки

Сообщение /dev/random »

yoricI писал:
16.07.2023 07:25
Как посмотреть неудовлетворительные зависимости?
$ emerge -pv =категория/пакет-версия
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Какое-то непривычное поведение. Раньше, если надо было размаскировать нестабильный пакет, так и писалось прямым текстом. Сейчас только намёк. Я правильно понимаю, что надо сделать ">=dev-cpp/expected-lite-0.6.3 ~amd64" или это ещё не конец эпопеи?
# emerge -pv =net-im/telegram-desktop-4.8.3 !!! All ebuilds that could satisfy "dev-cpp/expected-lite" have been masked. !!! One of the following masked packages is required to complete your request: - dev-cpp/expected-lite-0.6.3::gentoo (masked by: ~amd64 keyword) (dependency required by "dev-cpp/cppgir-0_p20230606::gentoo" [ebuild]) (dependency required by "net-im/telegram-desktop-4.8.3::gentoo" [ebuild]) (dependency required by "=net-im/telegram-desktop-4.8.3" [argument]) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5300
ОС: Gentoo

Re: gentoo заскоки

Сообщение /dev/random »

yoricI писал:
16.07.2023 13:22
Я правильно понимаю, что надо сделать ">=dev-cpp/expected-lite-0.6.3 ~amd64"
Если вы имеете в виду, что это нужно прописать в package.accept_keywords, то да. Или можно сократить до "dev-cpp/expected-lite", опустив и ограничение версии, и архитектуру.
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

А вообще-то, не хотелось бы из какого-то телеграма нарушать стабильность, особенно в важной области компиляций. Кстати, это дело уже давненько висит, само не рассасывается. Кто он такой, этот телеграм? Что себе позволяет? И куда смотрят смотрители.
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5300
ОС: Gentoo

Re: gentoo заскоки

Сообщение /dev/random »

yoricI писал:
16.07.2023 13:26
А вообще-то, не хотелось бы из какого-то телеграма нарушать стабильность
Тогда уберите телеграм из package.accept_keywords, чтобы он оставался на стабильной версии и не надоедал вам сообщениями о невозможности обновиться до нестабильной.
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Логично)) Так и сделаю, и как это я сам не догадался))
Спасибо сказали:
Аватара пользователя
bars
Сообщения: 941
ОС: BSD/LINUX

Re: gentoo заскоки

Сообщение bars »

Если хочется более свежею версию 4.8.4, то использовать net-im/telegram-desktop-bin.
Настройка BSD систем
Знание сила, незнание Рабочая сила!
Спасибо сказали:
Аватара пользователя
yoricI
Сообщения: 2428
ОС: gentoo fluxbox

Re: gentoo заскоки

Сообщение yoricI »

Да не нужна мне свежая версия, как-то давно поддался панике, и с тех пор мучался))
Спасибо сказали: