Не работает ssh

SLAX, Deep Style, ZenWalk

Модератор: Модераторы разделов

vintyara
Сообщения: 71
ОС: FreeBSD

Не работает ssh

Сообщение vintyara »

Есть slackware 10.2. Сломался у меня ССШ через две недели его работы. Самое интересное - сломался один раз - не стал разбираться ибо нужно было переставлять линух. Переставил - всё работало. Прошло ещё недели 2 - опять загнулся. В линухе я профан - посоветуйте что делать ? Мне оно очень надо.
Причём такое ощущение что демон не стартует :

root@pingvin:/etc/rc.d# ./rc.sshd start
root@pingvin:/etc/rc.d#
root@pingvin:/etc/rc.d# ps ax | grep sshd
1584 ? Ss 0:00 /usr/sbin/sshd
1771 pts/1 S+ 0:00 grep sshd

Вот что выдаётся если зделать ssh на себя :

root@pingvin:/var/log# ssh localhost
ssh_exchange_identification: Connection closed by remote host
root@pingvin:/var/log# ssh 192.168.0.3
ssh_exchange_identification: Connection closed by remote host
root@pingvin:/var/log#


Выручайте !

ЗЫ где ssh ведёт логи ?
Спасибо сказали:

Аватара пользователя
pzp-5
Сообщения: 558
Статус: Главный модератор "Пингвинария" на Лафоксе.

Re: Не работает ssh

Сообщение pzp-5 »

vintyara писал(а):
22.08.2006 19:51
ЗЫ где ssh ведёт логи ?

Код: Выделить всё

cat /var/log/messages | grep sshd
Угадайте: где на фотографии, которая представляет мой аватавр, спрятана птичка?
Спасибо сказали:

Аватара пользователя
Avdonin
Сообщения: 54
ОС: Debian Etch 4.0

Re: Не работает ssh

Сообщение Avdonin »

Привет.
Выложи конфиг sshd_config, и выполни команду netstat -nl после запуска sshd (покажи нам ее вывод).
Хотя если "connection closed by remote host", то демон должен быть запущен.
"Папа, я, когда вырасту, тоже стану рутом!" ©
Спасибо сказали:

vintyara
Сообщения: 71
ОС: FreeBSD

Re: Не работает ssh

Сообщение vintyara »

логи:

root@pingvin:~# cat /var/log/messages | grep sshd
Aug 20 22:53:30 pingvin sshd[1266]: Server listening on 0.0.0.0 port 22.
Aug 21 09:28:56 pingvin sshd[1266]: Server listening on 0.0.0.0 port 22.
Aug 22 18:10:24 pingvin sshd[1266]: Received signal 15; terminating.
Aug 22 18:10:28 pingvin sshd[3859]: Server listening on 0.0.0.0 port 22.
Aug 22 18:10:44 pingvin sshd[3859]: Received signal 15; terminating.
Aug 22 18:10:45 pingvin sshd[3869]: Server listening on 0.0.0.0 port 22.
Aug 22 18:11:28 pingvin sshd[3869]: Received signal 15; terminating.
Aug 22 18:26:09 pingvin sshd[1366]: Server listening on 0.0.0.0 port 22.
Aug 22 18:37:27 pingvin sshd[1366]: Server listening on 0.0.0.0 port 22.
Aug 22 18:38:51 pingvin sshd[1366]: Received signal 15; terminating.
Aug 22 18:38:52 pingvin sshd[1584]: Server listening on 0.0.0.0 port 22.
Aug 22 19:14:15 pingvin sshd[1366]: Server listening on 0.0.0.0 port 22.

Команда netstat -nl :

root@pingvin:/etc/rc.d# ./rc.sshd start
root@pingvin:/etc/rc.d# netstat -nl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:37 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:113 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 213.130.6.115:53 0.0.0.0:* LISTEN
tcp 0 0 192.168.0.3:53 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
udp 0 0 0.0.0.0:512 0.0.0.0:*
udp 0 0 0.0.0.0:1025 0.0.0.0:*
udp 0 0 0.0.0.0:37 0.0.0.0:*
udp 0 0 213.130.6.115:53 0.0.0.0:*
udp 0 0 192.168.0.3:53 0.0.0.0:*
udp 0 0 127.0.0.1:53 0.0.0.0:*
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 1873 public/flush
unix 2 [ ACC ] STREAM LISTENING 1877 private/proxymap
unix 2 [ ACC ] STREAM LISTENING 1881 private/smtp
unix 2 [ ACC ] STREAM LISTENING 1885 private/relay
unix 2 [ ACC ] STREAM LISTENING 1889 public/showq
unix 2 [ ACC ] STREAM LISTENING 1893 private/error
unix 2 [ ACC ] STREAM LISTENING 3205 /var/run/proftpd/proftpd.sock
unix 2 [ ACC ] STREAM LISTENING 1897 private/discard
unix 2 [ ACC ] STREAM LISTENING 1901 private/local
unix 2 [ ACC ] STREAM LISTENING 1905 private/virtual
unix 2 [ ACC ] STREAM LISTENING 1909 private/lmtp
unix 2 [ ACC ] STREAM LISTENING 1913 private/anvil
unix 2 [ ACC ] STREAM LISTENING 1917 private/scache
unix 2 [ ACC ] STREAM LISTENING 1921 private/maildrop
unix 2 [ ACC ] STREAM LISTENING 1925 private/old-cyrus
unix 2 [ ACC ] STREAM LISTENING 1929 private/cyrus
unix 2 [ ACC ] STREAM LISTENING 1933 private/uucp
unix 2 [ ACC ] STREAM LISTENING 1937 private/ifmail
unix 2 [ ACC ] STREAM LISTENING 1941 private/bsmtp
unix 2 [ ACC ] STREAM LISTENING 3522 /tmp/.X11-unix/X0
unix 2 [ ACC ] STREAM LISTENING 1842 public/cleanup
unix 2 [ ACC ] STREAM LISTENING 3577 /tmp/.ICE-unix/dcop1855-1156274250
unix 2 [ ACC ] STREAM LISTENING 3747 /tmp/.ICE-unix/1878
unix 2 [ ACC ] STREAM LISTENING 3765 /tmp/mcop-root/pingvin_home-0751-44eb585b
unix 2 [ ACC ] STREAM LISTENING 3570 /tmp/ksocket-root/kdeinit__0
unix 2 [ ACC ] STREAM LISTENING 3572 /tmp/ksocket-root/kdeinit-:0
unix 2 [ ACC ] STREAM LISTENING 3600 /tmp/ksocket-root/klauncherCIsRIb.slave-socket
unix 2 [ ACC ] STREAM LISTENING 1968 /var/run/mysql/mysql.sock
unix 2 [ ACC ] STREAM LISTENING 2063 /dev/gpmctl
unix 2 [ ACC ] STREAM LISTENING 1849 private/tlsmgr
unix 2 [ ACC ] STREAM LISTENING 1853 private/rewrite
unix 2 [ ACC ] STREAM LISTENING 1857 private/bounce
unix 2 [ ACC ] STREAM LISTENING 1861 private/defer
unix 2 [ ACC ] STREAM LISTENING 1865 private/trace
unix 2 [ ACC ] STREAM LISTENING 1869 private/verify
Active IPX sockets
Proto Recv-Q Send-Q Local Address Foreign Address State

файликов sshd_config у меня несколько :
root@pingvin:/etc/rc.d# locate sshd_config
/etc/ssh/sshd_config
/etc/sshd_config

Вот /etc/sshd_config :

Port 22
ListenAddress 0.0.0.0
HostKey /etc/ssh_host_key
RandomSeed /etc/ssh_random_seed
ServerKeyBits 768
LoginGraceTime 600
KeyRegenerationInterval 3600
PermitRootLogin yes
IgnoreRhosts yes
StrictModes yes
QuietMode no
FascistLogging yes
CheckMail no
IdleTimeout 3d
X11Forwarding no
PrintMotd no
KeepAlive yes
SyslogFacility DAEMON
RhostsAuthentication no
RhostsRSAAuthentication no
RSAAuthentication yes
PasswordAuthentication no
PermitEmptyPasswords no
UseLogin no

В /etc/ssh/sshd_config вроде как ничего полезного нет (там всё закомментировано), но могу и его выложить.
Спасибо сказали:

Аватара пользователя
Avdonin
Сообщения: 54
ОС: Debian Etch 4.0

Re: Не работает ssh

Сообщение Avdonin »

Код: Выделить всё

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN

Это говорит о том что демон работает. Он просто по каким-то причинам не дает тебе залогинится на хосте.
файликов sshd_config у меня несколько :
root@pingvin:/etc/rc.d# locate sshd_config
/etc/ssh/sshd_config
/etc/sshd_config

Ясно. Возможно демон читает конфиогурацию не из нужного конфигурационного файла. Попробуй:
#killall sshd
#/usr/sbin/sshd -f /etc/sshd_config
и попробуй залогинится снова.

А ключи нормально сгенерились?

Если это не поможет, то запусти /usr/sbin/sshd с ключом -d и с другой консоли попробуй залогиниться. Демон будет все подробно писать в системный лог. После этого смотри /var/log/messages и /var/log/syslog

P.S. В man'е сказано: "Specifies the name of the configuration file. The default is /etc/ssh/sshd_config. sshd refuses to start if there is no con-figuration file."
То есть твой демон читает конфигурацию из /etc/ssh/sshd_config.
"Папа, я, когда вырасту, тоже стану рутом!" ©
Спасибо сказали:

Аватара пользователя
VisualN
Сообщения: 213
ОС: Gentoo Linux

Re: Не работает ssh

Сообщение VisualN »

tcp_wrappers используется?
Похоже на это, потому что если бы сам sshd сбрасывал соединение он бы писал влогах об этом.
В общем судя по логам до sshd соединение вообще не доходит, режется где то раньше.
Надо прописать в /etc/hosts.allow если tcp_wrappers используется:
sshd: ALL
Nothing ever changes...
Спасибо сказали:

vintyara
Сообщения: 71
ОС: FreeBSD

Re: Не работает ssh

Сообщение vintyara »

Avdonin

Ясно. Возможно демон читает конфиогурацию не из нужного конфигурационного файла. Попробуй:
#killall sshd
#/usr/sbin/sshd -f /etc/sshd_config
и попробуй залогинится снова.


root@pingvin:/usr/sbin# killall sshd
root@pingvin:/usr/sbin# ./sshd -f /etc/sshd_config
sshd re-exec requires execution with an absolute path

т.е. не хочет он ничего запускать. Да и демон я по другому стартую, из /etc/rc.d/rc.sshd

А ключи нормально сгенерились?

не знаю :( как проверить ?

Если это не поможет, то запусти /usr/sbin/sshd с ключом -d и с другой консоли попробуй залогиниться. Демон будет все подробно писать в системный лог. После этого смотри /var/log/messages и /var/log/syslog


я опять таки немного по другому запустил:
root@pingvin:/etc/rc.d# ./rc.sshd start -d

Вот логи:
root@pingvin:~# cat /var/log/syslog | grep sshd
...
Aug 23 00:50:08 pingvin sshd[2319]: refused connect from 65.173.158.20 (65.173.158.20)
Aug 23 00:58:03 pingvin sshd[2321]: refused connect from 65.173.158.20 (65.173.158.20)
Aug 23 06:42:40 pingvin sshd[1581]: warning: /etc/hosts.allow, line 12: missing newline or line too long
Aug 23 06:42:40 pingvin sshd[1581]: refused connect from 127.0.0.1 (127.0.0.1)
Aug 23 06:43:11 pingvin sshd[1595]: fatal: Cannot bind any address.
Aug 23 06:43:13 pingvin sshd[1598]: warning: /etc/hosts.allow, line 12: missing newline or line too long
Aug 23 06:43:13 pingvin sshd[1598]: refused connect from 127.0.0.1 (127.0.0.1)
Aug 23 06:49:26 pingvin sshd[1902]: warning: /etc/hosts.allow, line 12: missing newline or line too long
Aug 23 06:49:26 pingvin sshd[1902]: refused connect from 127.0.0.1 (127.0.0.1)


root@pingvin:~# cat /var/log/messages | grep sshd
...
Aug 23 06:41:39 pingvin sshd[1366]: Server listening on 0.0.0.0 port 22.
Aug 23 06:47:20 pingvin sshd[1366]: Received signal 15; terminating.
Aug 23 06:48:49 pingvin sshd[1899]: Server listening on 0.0.0.0 port 22.


VisualN

А что такое tcp_wrappers? :) Я не знаю, но на всякий случай sshd: ALL прописал. Не помогло.
Спасибо сказали:

Аватара пользователя
Avdonin
Сообщения: 54
ОС: Debian Etch 4.0

Re: Не работает ssh

Сообщение Avdonin »

root@pingvin:/usr/sbin# ./sshd -f /etc/sshd_config
sshd re-exec requires execution with an absolute path
т.е. не хочет он ничего запускать. Да и демон я по другому стартую, из /etc/rc.d/rc.sshd

Так ты его и запути с абсолютным путем после killall sshd, набирай именно:
#/usr/sbin/sshd -f /etc/sshd_config
Он у тебя не тот конфигурационный файл смотрит. Если ничего не выйдет попробуй просто заменить /etc/ssh/sshd_config на /etc/sshd_config.

Если ничего не выйдет, то дело в политике безопасности самого sshd, tcp_wrappers тут не при чем.
"Папа, я, когда вырасту, тоже стану рутом!" ©
Спасибо сказали:

Аватара пользователя
nesferato
Сообщения: 472
Статус: В изобилии!
ОС: Fedora, Slackware

Re: Не работает ssh

Сообщение nesferato »

Пробовал прописать в файле конфигурации sshd ip-адрес сервера явно?
Результат пропорционален осознанности.
Спасибо сказали:

vintyara
Сообщения: 71
ОС: FreeBSD

Re: Не работает ssh

Сообщение vintyara »

Avdonin
увы :(

root@pingvin:~# root@pingvin:/etc/ssh# /usr/sbin/sshd -f /etc/sshd_config
/etc/sshd_config: line 4: Bad configuration option: RandomSeed
/etc/sshd_config: line 11: Bad configuration option: QuietMode
/etc/sshd_config: line 12: Bad configuration option: FascistLogging
/etc/sshd_config line 13: Deprecated option CheckMail
/etc/sshd_config: line 14: Bad configuration option: IdleTimeout
/etc/sshd_config line 19: Deprecated option RhostsAuthentication
/etc/sshd_config: terminating, 4 bad configuration options

после чего демон не стартует.
Неужели это конец :( ?

nesferato
да. никаких изменений :(

Что хочу добавить: у меня почему-то и "автозагрузка" не работает :( Может оно взаимосвязано ? Раньше работала. Т.е. есть /etc/rc.d/rc.local

#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local setup commands in here:
ppp-on
iptables -t nat -A POSTROUTING -s 192.168.0.2 -j MASQUERADE

#iptables -t nat -A POSTROUTING -s 192.168.0.2 -d ! 192.168.0.0/24 -j MASQUERADE



Иптаблес вроде как срабатывает, тот же ппп-он - нет. Хотя первое время точно работало.
Спасибо сказали:

vintyara
Сообщения: 71
ОС: FreeBSD

Re: Не работает ssh

Сообщение vintyara »

Разобрался :) Всем спасибо за помощь :) !
Заработало после добаления в /etc/allow.hosts строки
ALL: 192.168.0.

=)

Теперь бы всё же научить стартовать ppp-on, но это уже наверное другая история :)
Ещё раз спасибо откликнувшимся :) !
Спасибо сказали: