Тюнер Behold 407 FM (Дрова & настройка)

Установка, настройка TV-тюнеров, видеокамер, веб-камер, плат видеозахвата, flash(MP3)-плееры

Модератор: Модераторы разделов

Talalayev
Сообщения: 12
ОС: Linux

Тюнер Behold 407 FM

Сообщение Talalayev »

Доброго времени суток! Товарищи, подскажите где найти нормальные дрова под линукс для тюнера Behold 407 FM, нашел какие то на
http://www.beholder.ru/bb/viewtopic.php?t=1142
но они чего то не ставятся. Может у когонть есть? И как настроить тюнер? Большое спасибо. :ph34r: :(
Спасибо сказали:

virens
Сообщения: 125
ОС: Debian GNU/Linux

Re: Тюнер Behold 407 FM

Сообщение virens »

Talalayev писал(а):
31.07.2006 21:51
Доброго времени суток! Товарищи, подскажите где найти нормальные дрова под линукс для тюнера Behold 407 FM, нашел какие то на
http://www.beholder.ru/bb/viewtopic.php?t=1142
но они чего то не ставятся. Может у когонть есть? И как настроить тюнер? Большое спасибо. :ph34r: :(

Дрова для тюнера - в твоём ядре Линукс. Описание того, как тюнер подымается - у меня (почти та же модель).
Спасибо сказали:

cobold
Сообщения: 6

Re: Тюнер Behold 407 FM

Сообщение cobold »

У меня работает 407-й.
Наложил патч на ядро отсюда
опции:

Код: Выделить всё

$ cat /etc/modules.d/tv
options tda9887 secam=d
options tuner secam=d
options saa7134_alsa

Пользую tvtime.

З.Ы. не подскажите как "правильно" гонять звук от тюнера по PCI
Вариант с sox не устраивает тем что при длительном просмотре звук начинает отставать от изображения, несмотря на небольшую загрузку процессора.
Спасибо сказали:

RulerM
Сообщения: 192
ОС: Open SUSE 10.3 Gnome xgl

Re: Тюнер Behold 407 FM

Сообщение RulerM »

virens писал(а):
01.08.2006 15:28
Дрова для тюнера - в твоём ядре Линукс. Описание того, как тюнер подымается - у меня (почти та же модель).


У меня также 409-й. Помогла ваша инструкция в свое время, спасибо, собсно важна была тока строчка про секам.
Ибо сам 409-й заводится достаточно спокойно на приличном количестве разных комбинаций тюнер-карта (7135 то чип ничем кардинально от 7134 не отличается, а тюнер 63 от 37-го также.), тока вот с отображением секама без той строчки в конфиге не фига не выходит, что не ставь в прогах.

Однако есть трабл.. 1-й и 2-й канал в любой проге показывают отвратительно, 1-й вообще фарш, 2-й сильно зашумлен. В то время как в реальности синал на них отличный, и в нелюбимой тут системе все показывается на ура. Остальные метровые каналы и дециметровые показываются как положено..
Засада явно в настройках дров, не сталкивались ?

P.S. Зря тока вы в статейке назвали BeholdTV комлектный хламом.. Если бы под Линухом была такая же по качеству и функциональности прога - цены бы ей не было, под оффтопиком это лучший софт для тюнера, в Линухе увы такого просто нет.
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

cobold
Чувак, браток, выручай :)
Я тоже ложил патч на ядро, нихера не получается. Пишет Synchronization faukt мать его. Единственная вещь которую я пока не настроил..Помогите пожалста..Спасибо. :huh:
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
eduard_pustobaev
Сообщения: 2629
Статус: Ленивец
ОС: Arch/Debian.

Re: Тюнер Behold 407 FM

Сообщение eduard_pustobaev »

Talalayev писал(а):
31.07.2006 21:51
Доброго времени суток! Товарищи, подскажите где найти нормальные дрова под линукс для тюнера Behold 407 FM, нашел какие то на
http://www.beholder.ru/bb/viewtopic.php?t=1142
но они чего то не ставятся. Может у когонть есть? И как настроить тюнер? Большое спасибо. :ph34r: :(


О братан, а меня так в жизни зовут(ну погонялло типа) :)

Кстати только на днях подобрал комбинацию для своего Manli Home TV SAA7134: modprobe saa7134 card=12 tuner=43.
В дисгармонии со вселенной.
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

eduard_pustobaev
Кстати только на днях подобрал комбинацию для своего Manli Home TV SAA7134: modprobe saa7134 card=12 tuner=43.

У меня тож 407. Мне б так взять и подобрать..
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

А как быть с новым Behold 507 FM RDS?
Пробовал его как 409: проблемы со звуком и изображением... Ближе 409-го ничего нет.
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

Ну у меня 507. Вписал как 409. tvtime. Проблем нет.
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

cheer писал(а):
28.08.2006 17:43
Ну у меня 507. Вписал как 409. tvtime. Проблем нет.

Мне от этого не легче.

В том же tvtime ничего: изображение рябит во всю, звук шипит.
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

Ну так, возможно, вы приведёте хоть какие-нибудь данные? Как настраивали, система, ну и так далее?..
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

Добился некоторых результатов, но есть над чем еще работать.
1.За основу взял вот это http://www.beholder.ru/bb/viewtopic.php?t=...highlight=linux
Исходники v4l обновлял, как там написано.

2. Подправил исходники вручную. Скомпилировал, нормально встало.

3. После перезагрузки автоматом не подхватилось. В modules.conf прописал
alias char-major-81 saa7134
options saa7134 card=98

4. После этого dmesg|grep saa выдает:

Код: Выделить всё

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:02:05.0, rev: 240, irq: 153, latency: 32, mmio: 0xffdef000
saa7133[0]: subsystem: 0000:507b, board: Beholder BeholdTV 507 RDS [card=98,insmod option] //тут карта 98 потому, что в исходниках, которые правил сам, поставил под номером 98
saa7133[0]: board init: gpio is 200000
saa7133[0]: i2c eeprom 00: 00 00 7b 50 54 20 00 00 00 00 00 00 00 00 00 01
saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 2-0043: chip found @ 0x86 (saa7133[0])
tuner 2-0060: chip found @ 0xc0 (saa7133[0])
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0


5. Сканирую каналы tvtime-scanner. Каналы находит, но некоторые без звука, некотороы черно-белые, короче, результат оставляет желать лучшего. Радио работает.
Ставил опциою, чтоб был secam. Результата не дало.

PS ТВ кабельное. Антенну не пробовал.
Ядро 2.6.14. Система ASPLinux 11.
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

Мой путь:
1. Если ядро версии 2.6.14 и выше, то собирать video4linux не надо.
2. Прописать в /etc/modprobe.conf

Код: Выделить всё

options tuner secam=d
options tda9887 secam=d
options saa7134 tuner=38 card=67 gbuffers=4
alias char-major-89-* i2c-dev
options i2c-algo-bit bit_test=1

3. tvtime-scanner у меня нормально не работал. Я просто вписал свои частоты для телевидения в конфигурационный файл.
Сдаётся мне, что вы забыли параметр 'tuner' при загрузке saa7134. В сети, кстати, много более свежей документации, чем на форуме Beholder. Прошу прощения за 507 в теме про 407. Возможно, лучше перенести.
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

Спасибо, таких опций в modprobe.conf еще не видел (может, плохо искал :) ). Попробую.
А в сети, имхо, вся информация о настройке базируется на информации с форума Бехолдера. И общие настройки похожи.
Если вписать частоты, как вы, то с этим проблема. В кабельном все частоты передвинуты и они не совпадают с "общим" телевидением (не знаю, как правильно его назвать :) ).

PS Можно тему разделить, если модераторы не сочтут за труд. Немного ушли от первоначальной темы

Прописал все в modeprobe.conf. Результаты улучшились в несколько раз :)
Осталось только поднастроить каналы. Спасибо, cheer!

Но почему-то каналы не все находит...
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

Товарищи, спасибо всем, тюнер видео настроил, а как быть со звуком, которого в упор нету? Ктонть сталкивался? Спасибо большое.
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
Cyber_RAT
Сообщения: 142
Статус: Интересующийся
ОС: Gentoo

Re: Тюнер Behold 407 FM

Сообщение Cyber_RAT »

Бомба писал(а):
30.08.2006 12:41
Товарищи, спасибо всем, тюнер видео настроил, а как быть со звуком, которого в упор нету? Ктонть сталкивался? Спасибо большое.



а если воткнуть шнурок из тюнера в line-in звуковухи? а потом запустить alsamixer - при работающем тюнере и попробовать поиграться с уровнями?
Gentoo 2.6.26 , Satelite internet(SatGate). GPRS MTS-by. cdma Diallog.
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

В tvtime иногда нет звука у определённых каналов (например, в Slackware у меня ОРТ идёт без звука, а в ArchLinux - СТС), это, скорее всего, баг программы - у остальных каналов со звуком всё хорошо. Я пока с этим не разбирался.
Процитирую себя: "надо поставить ненулевую громкость на линейный вход".
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

Cyber_RAT
а если воткнуть шнурок из тюнера в line-in звуковухи? а потом запустить alsamixer - при работающем тюнере и попробовать поиграться с уровнями?

Про шнурок промолчу-ведь в винде работает-значит вторкнут :))
Звуковуха встроенная, и line-in насколько я понимаю это микрофон?Вряд ли.
Алсамиксер колбасил-без толку. Чоб еще сделать? Спасибо. :( :ph34r:
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

Ну если шнурок воткнут в микрофон, то ...
Я его втыкаю в line-in; звуковуха тоже встроенная.
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

Каналы нашлись все ;)
Пришлось руками делать: взял готовые частоты из BeholderTV и вписал вручную. И все появилось.

Теперь осталось пульт настроить. Еще две недели :D
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

Zueuk
А какую прогу юзаете? Скажите если не трудно куда вы вписывали эти частоты? Просто вот у меня каналы тож все появились но качество заметно хуже бехолдтв, это из за неправильных подстроек или того что я прописал свой 407 как 409? Я слышал тут люди 507 прописывали как 409, ну а разница между 407 и 409 еще меньше. Спасибо.
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

~/.tvtime/stationlist.xml
Точно подгружены модули с секамом?
Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

cheer
Точно подгружены модули с секамом?

alias char-major-81-* saa7134
options saa7134 card=67
options tuner secam=d radio_range=66
options tda9887 secam=d

Про станции.
~/.tvtime/stationlist.xml

<?xml version="1.0"?>
<!DOCTYPE stationlist PUBLIC "-//tvtime//DTD stationlist 1.0//EN" "http://tvtime.sourceforge.net/DTD/stationlist1.dtd">
<stationlist xmlns="http://tvtime.sourceforge.net/DTD/">
<list norm="SECAM" frequencies="russia" audio="dk">
<station name="49.75MHz" active="1" position="1" band="Custom" channel="143.50MHz" finetune="9" norm="PAL" audio="auto"/>
<station name="77.25MHz" active="1" position="2" band="Custom" channel="185.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="191.25MHz" active="1" position="3" band="Custom" channel="231.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="215.25MHz" active="1" position="4" band="Custom" channel="288.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="175.31MHz" active="1" position="5" band="Custom" channel="381.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="183.31MHz" active="1" position="6" band="Custom" channel="444.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="199.31MHz" active="1" position="7" band="Custom" channel="494.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="207.25MHz" active="1" position="8" band="Custom" channel="523.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="471.25MHz" active="1" position="9" band="Custom" channel="547.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="479.25MHz" active="1" position="10" band="Custom" channel="580.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="487.31MHz" active="1" position="11" band="Custom" channel="648.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="503.25MHz" active="1" position="12" band="Custom" channel="788.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="519.25MHz" active="1" position="13" band="Custom" channel="899.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="527.25MHz" active="1" position="14" band="Custom" channel="46.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="535.25MHz" active="1" position="15" band="Custom" channel="52.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="543.25MHz" active="1" position="88" band="Custom" channel="53.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="559.25MHz" active="1" position="17" band="Custom" channel="135.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="567.25MHz" active="1" position="18" band="Custom" channel="166.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="575.25MHz" active="1" position="19" band="Custom" channel="206.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="583.25MHz" active="1" position="20" band="Custom" channel="211.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="591.25MHz" active="1" position="21" band="Custom" channel="218.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="599.25MHz" active="1" position="22" band="Custom" channel="223.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="607.25MHz" active="1" position="23" band="Custom" channel="264.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="615.25MHz" active="1" position="24" band="Custom" channel="269.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="623.25MHz" active="1" position="25" band="Custom" channel="309.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="639.25MHz" active="1" position="26" band="Custom" channel="321.25MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="663.25MHz" active="1" position="27" band="Custom" channel="323.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="671.25MHz" active="1" position="28" band="Custom" channel="344.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="679.25MHz" active="1" position="29" band="Custom" channel="350.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="695.25MHz" active="1" position="30" band="Custom" channel="362.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="703.25MHz" active="1" position="31" band="Custom" channel="372.75MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="711.25MHz" active="1" position="32" band="Custom" channel="398.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="50.00MHz" active="1" position="89" band="Custom" channel="50.00MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="53.50MHz" active="1" position="90" band="Custom" channel="53.50MHz" finetune="0" norm="SECAM" audio="auto"/>
<station name="59.25MHz" active="1" position="91" band="Custom" channel="59.25MHz" finetune="0" norm="SECAM" audio="auto"/>
</list>
</stationlist>

Причем здесь я частоты вписал из BeholdTV прям взял и вбил. Так оно то не видит то ваще фигово показывает. Подскажите.Спасибо. :( :ph34r:
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

Спасибо сказали:

Аватара пользователя
Бомба
Сообщения: 156
ОС: Kubuntu 6.10 Edgy Eft

Re: Тюнер Behold 407 FM

Сообщение Бомба »

cheer
Последний абзац.

Интригующе... ;) а если перевести? что последний абзац?
Sempron 2500+ Palermo, Ga-K8NS, 160 Gb Seagate, 1 Gb RAM, LAN Ethernet, Kubuntu 6.10 Edgy Eft
Спасибо сказали:

Аватара пользователя
cheer
Сообщения: 729
Статус: Самовлюблённый сноб
ОС: archlinux i686-current

Re: Тюнер Behold 407 FM

Сообщение cheer »

"Сдаётся мне, что вы забыли параметр 'tuner' при загрузке saa7134":
"options saa7134 card=67"
Можно было просто подумать...
Спасибо сказали:

Zueuk
Сообщения: 94
ОС: Fedora

Re: Тюнер Behold 407 FM

Сообщение Zueuk »

Бомба писал(а):
31.08.2006 20:48
Zueuk
А какую прогу юзаете? Скажите если не трудно куда вы вписывали эти частоты? Просто вот у меня каналы тож все появились но качество заметно хуже бехолдтв, это из за неправильных подстроек или того что я прописал свой 407 как 409? Я слышал тут люди 507 прописывали как 409, ну а разница между 407 и 409 еще меньше. Спасибо.

Товарищ cheer уже ответил...
Я тоже отвечу :)
Использую tvtime.

Код: Выделить всё

<station name="49.75MHz" active="1" position="1" band="Custom" channel="143.50MHz" finetune="9" norm="PAL" audio="auto"/>
<station name="77.25MHz" active="1" position="2" band="Custom" channel="185.00MHz" finetune="0" norm="SECAM" audio="auto"/>

Здесь в поле name ставил название канала (например, ОРТ). В поле channel вписывал частоту, которую брал из BeholdTV. Еще правил поле norm (т.к. часть каналов в SECAM, часть в PAL, не знаю, бывает такое или нет, но у меня так :) ).
Я прописывал свой 507 как 409, но результаты были, мягко говоря, плохие. Если 407 прописать как 409, должно быть лучше.

PS Можно и на "ты". А то как-то сильно официально получается..

cheer
А устройство /dev/vbi0 - это что? Хочу настроить пульт, думаю, не это ли пульт?!
В /dev/input/ что есть:
event0 event1 mice mouse0
Как понимаю, пульта нет (event0 - это клавиатура, event1 - мышь).
Команда dmesg строки saa7134[0]: registered input device for IR не выдает.
Спасибо сказали:

RuVIrus
Сообщения: 6

Re: Тюнер Behold 407 FM

Сообщение RuVIrus »

Товарищи, я новичек в линуксе, пока... Можете по пунктам написать что делать чайнику....
Мандрива ПП+
Спасибо сказали:

Аватара пользователя
DaemonTux
Сообщения: 1480
Статус: Юный падаван
ОС: Gentoo

Re: Тюнер Behold 407 FM

Сообщение DaemonTux »

RuVIrus писал(а):
04.08.2007 14:15
Товарищи, я новичек в линуксе, пока... Можете по пунктам написать что делать чайнику....

1. Научится задавать вапросы и читать документацию.
2. Сказать что за дистр и какой именно тюнер.
Vladivostok Linux User Group
Спасибо сказали:

RuVIrus
Сообщения: 6

Re: Тюнер Behold 407 FM

Сообщение RuVIrus »

Я бы наверно зашел в другую тему если бы был у меня тюнер не той модели =)

Тюнер Beholder 407
Мандрива ПП+
Мандрива ПП+
Спасибо сказали: