Разные проблемы с установкой пакетов в OpenSUSE

openSUSE, SUSE Linux Enterprise

Модератор: Модераторы разделов

CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

xoomer писал(а):
04.05.2013 21:16
CAEman
Обновление ядра возможно, насколько я понимаю, только путём скачивания и записи на болванку дистр-а и загрузки с неё

Если я правильно понял задачу, то ядро можно обновить средствами YaST (zypper). Вот в поддерживаемых дистрибутивах есть новые ядра.

Поддерживаю вышеозвученные мнения форумчан по поводу Factory.
(http://ru.opensuse.org/Portal:Factory) писал(а):Поэтому репозиторий Factory, находясь в постоянном движении, может быть в любом состоянии, даже поломанном.


Я написал, что репозиториев с ПО под Factory несравненно больше, чем под Tumbleweed.

Простите, Вы что-то путаете. В этом репозитории ПО, которое Вы качаете оттуда и устанавливаете средствами YaST или zypper.

Если же я всё правильно понимаю, то до новой версии OpenSUSE ядро можно обновить только с помощью дистр-а.
Да я понимаю качество ПО для Factory.
Вот репозитории с ПО. Там больше всего ПО под Factory. А Tumbleweed рекомендовалось вместо последнего. Значит, напутал ещё тот, кто рекомендовал (на официальном сайте).

verg писал(а):
04.05.2013 21:16
CAEman писал(а):
04.05.2013 21:11
(рекомендуется там вместо Factory)
Фактори не может рекомендоваться ни в каких случаях, а Tumbleweed не является его заменой.
CAEman писал(а):
04.05.2013 21:11
Я написал, что репозиториев с ПО под Factory несравненно больше, чем под Tumbleweed.
У вас неверное понимание, что означают эти репозитории, хоть и приведена дополнительная цитата. и что сравнивать их нельзя.


CAEman писал(а):
04.05.2013 21:11
Всякое, какое может быть в университете: стандартное (в т.ч. разные утилиты), гуманитарное, математическое, CAD, CAM, CAE...
Нужны точные примеры, того что вы нашли в Фактори и того чего нет в обычных репах(сюда же дополнительные репы и пакман для текущей версии)

Цитата из приведённой Вами ссылки:
Если вы ищете более обновляемую версию openSUSE но без нестабильности Factory, попробуйте Tumbleweed.


Что мы могли найти в Фактори, если мы ещё не установили всё это?
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Но тематических значительно меньше.

А на 11.2 уже что-то даже устанавливалось из репозиториев с ПО под Factory...
Спасибо сказали:
Аватара пользователя
verg
Сообщения: 1299

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение verg »

CAEman писал(а):
04.05.2013 21:38
Вот репозитории с ПО. Там больше всего ПО под Factory.
Нужны конкретные примеры.
CAEman писал(а):
04.05.2013 21:38
А Tumbleweed рекомендовалось вместо последнего. Значит, напутал ещё тот, кто рекомендовал (на официальном сайте).
Не напутал, а предостерёг от пользования тем, кто понятия о нём не имеет и для тех кто ищет новьё и не знает, где его взять.
CAEman писал(а):
04.05.2013 21:38
Да я понимаю качество ПО для Factory.
Ещё нужно понять, что Factory вообще не рассматривается, как платформа для пользования, в частности в вашем примере, на рабочих местах в организациях. Да и в общем-то везде и имеет вполне конкретное предназначение.
CAEman писал(а):
04.05.2013 21:38
Если же я всё правильно понимаю, то до новой версии OpenSUSE ядро можно обновить только с помощью дистр-а.
Что такое "дистр-а"?
Спасибо сказали:
Аватара пользователя
xoomer
Сообщения: 201

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение xoomer »

Там больше всего ПО под Factory.

Не совсем понимаю это выражение.
Репозиторий - хранилище програм. Они отличаются друг от друга стабильностью лежащих там програм: и в стабильном. и в Фэктори может быть тот же пакет, но в Фэктори он будет обладать новыми возможностями и, заодно, новыми багами. По мере тестирования и устранения багов пакет попадает в более стабильные репозитории пока, наконец, не дойдет до репозитория стабильной ветки.

И, как я понял, Вы путаете понятие ядра ОС с самой ОС. Поэтому, что такое ядро: ссылка1, ссылка2. :-)
Вот здесь лежат скомпилированные ядра Linux, кстати: http://download.opensuse.org/repositories/Kernel:/ .


btw:
http://www.3ds.com/ru/products/draftsight/...oad-draftsight/
https://www.scilab.org/download/
Far behind the skies...
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Ладно. Мне сейчас некогда. Вернусь через пару недель и постараюсь всё объяснить, что я имел в виду...
Спасибо сказали:
Аватара пользователя
drBatty
Сообщения: 8735
Статус: GPG ID: 4DFBD1D6 дом горит, козёл не видит...
ОС: Slackware-current

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение drBatty »

CAEman писал(а):
04.05.2013 20:38
А что здесь сравнивать: на пол-DVD сотни ГБ не ужмутся...

а то, что дистрибутив может быть годным и без сотен ненужного дерьма.
CAEman писал(а):
04.05.2013 20:38
Поскольку до репозитория с KDE3 дело ещё далеко не дошло

оно давно УШЛО.
http://emulek.blogspot.ru/ Windows Must Die
Учебник по sed зеркало в github

Скоро придёт
Осень
Спасибо сказали:
Аватара пользователя
Фантом
Сообщения: 453
ОС: openSUSE

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение Фантом »

CAEman писал(а):
04.05.2013 20:12
Я в курсе, что такое Factory. Но в репозиториях больше всего ПО именно под него.

По-видимому, Вы что-то перепутали.

CAEman писал(а):
04.05.2013 20:12
Кстати, я, вроде, слыхал, что в дистр-ах 12.х вернули KDE3 (или это просто рекламный обман?).

Еще в 11.4. Другой вопрос - а зачем Вам это? Почему Вам вообще нужен именно KDE?

CAEman писал(а):
04.05.2013 20:38
Насчёт варианта не понял...

Предполагалось получить доказательство, что Вы в здравом уме. :)

CAEman писал(а):
04.05.2013 20:38
1) Это будет сделано на момент окончательной установки (предпочтение будет отдаваться дистр-у, содержащему KDE3).

Т.е. в принципе Вы согласны обойти препятствие, но сначала, тренировки ради, все же хотите прошибить лбом бетонную стену?
CAEman писал(а):
04.05.2013 20:38
2) О необходимости или отсутствия таковой можно будет судить только в конце построения учебных программ, основанного на наличии всего выбора ПО (проблемное будет исключено).

А что, предполагается, что учебные программы привязываются к имеющемуся софту? Именно так, а не наоборот?

CAEman писал(а):
04.05.2013 20:38
3) Обновление ядра возможно, насколько я понимаю, только путём скачивания и записи на болванку дистр-а и загрузки с неё, чем здесь никто заниматься не будет (по крайней мере, до 01.01.15, а дальше нужно будет быть готовым ко всему).

Вы понимаете неправильно. Обновление ядра - это одна команда из консоли или два щелчка мышью в YaST'е.

Так что могу только повторить еще раз: Вы занимаетесь бессмысленной деятельностью, и помощь в реализации намеченного Вам только повредит. Начните с формулировки того, что Вам действительно нужно: какие конкретно задачи Вы предполагаете решать на данных компьютерах и чему Вы собираетесь учить с их помощью студентов. Уже потом можно будет подумать о выборе дистрибутива под имеющиеся потребности и технику, и только потом - о том, как наиболее эффективно обновлять установленный софт.
Спасибо сказали:
Аватара пользователя
alv
Бывший модератор
Сообщения: 7275
Статус: Пенсионер в законе
ОС: Cintu

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение alv »

CAEman писал(а):
04.05.2013 19:03
Прошли недели обработки

Какие мелочи... До времени Ч, то есть
CAEman писал(а):
04.05.2013 20:38
до 01.01.15

у Вас почти полтора года. За это время можно успеть прочитать какую-нибудь толстую книжку про UNIX/Linux для общего понимания, документацию по openSUSE - для понимания специфики дистрибутива, тематические материалы по использованию Linux'а в учебном процессе (поверьте, не Вы первый этим делом занялись).
А числа так 30 декабря 2014 года выключить машину и начать всё по новой - уже по уму.
Потому что, извините, но всё, что Вы делаете сейчас - это такой бред, который обсуждать как-то неловко...
Впрочем, в политкорректной форме об этом уже сказали предыдущие ораторы.
Спасибо сказали:
Аватара пользователя
diesel
Бывший модератор
Сообщения: 5989
ОС: OS X, openSuSE, ROSA, Debian

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение diesel »

CAEman писал(а):
04.05.2013 17:26
diesel писал(а):
04.05.2013 16:45
CAEman писал(а):
04.05.2013 16:16
Убедительная просьба: если Вы в этом не уверены, то собщить об этой неуверенности...
Заранее благодарю.

Если мешает - пристрелите процесс, если не мешает - подождите день и пристрелите. Скорее всего если что-то поломается - оно уже поломалось, если не поломается - то велика вероятность что вам заново предложат пройти через апдейтер, с разрешением зависимостей и прочими плюшками.

Дело-то в том, что речь идёт не о днях, а неделях (репозиториев-то больше сотни). Это не апдейтер, а управление ПО на стадии определения конфликтов (после нажатия кнопки Принять).

тогда можно стрелять не думая.
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Спасибо всем, кто пытается помочь.
Попробую, как и обещал, объяснить ситуацию подробнее.

Сначала немного прелюдии, основанной на некоторых прочитанных рекомендациях. Никто никаких книг здесь читать не будет. Это бюджетный отстойник. Здесь остались люди, которые прочитали последнюю свою книгу ещё в советские времена, либо появились те, кто их не читал вообще. Единственное, что некоторые из них ещё соблаговалят сделать, это потыркаться на досуге с ПО по своей тематике, если оно будет установлено, и, может, что-нибудь выбрать, если будет похоже на то, к чему уже привыкли, после чего внесут это ПО в свои рабочие программы. И чем больше будет ПО по каждой тематике, тем больше вероятность того, что что-нибудь выберут. И тогда это ПО окажется среди установленного 01.01.15. А, вот, мысли о том, что здесь просто выключат комп-ы 31.12.14, а потом при включении всё будет по уму, действительно являются бредом. Здесь просто установят какие-нибудь дистр-ы Линукса с каким-нибудь набором ПО. И что будет, когда на всё это потом будут смотреть как бараны на новые ворота, мне кажется, не нужно объяснять. В качестве примера того, что здесь делают, могу сообщить, что когда ввели ODF в качестве ГОСТа, здесь снесли весь OpenOffice и обязали всем студентам этого технического университета выдавать сертификаты об умении работать в МС Офис (это при том, что, например, ни одного САЕ ПО здесь нет вообще).

Теперь же попробую сформулировать стоящую задачу.
Установить параллельно с установленным ПО безпроблемный Линукс с максимально возможным набором СПО по всем направлениям от гуманитарного до технического (без каких-либо компиляций).

Заранее благодарю всех, кто попытается помочь.
Спасибо сказали:
Аватара пользователя
jashaw5
Сообщения: 68

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение jashaw5 »

CAEman писал(а):
18.05.2013 21:27
Теперь же попробую сформулировать стоящую задачу.
Установить параллельно с установленным ПО безпроблемный Линукс с максимально возможным набором СПО по всем направлениям от гуманитарного до технического (без каких-либо компиляций).

Заранее благодарю всех, кто попытается помочь.

http://www.pclinuxos.com/?page_id=1413
Русский форум. Задаёшь вопрос, потом тебе долго рассказывают, какой ты м-к.
Спасибо сказали:
Аватара пользователя
Фантом
Сообщения: 453
ОС: openSUSE

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение Фантом »

CAEman писал(а):
18.05.2013 21:27
Установить параллельно с установленным ПО безпроблемный Линукс с максимально возможным набором СПО по всем направлениям от гуманитарного до технического (без каких-либо компиляций).

Ну так и ставьте OpenSuSE. Только современную версию (12.3), и подключайте к ней сначала только стандартные репозитории, потом - специальные, но не Factory.
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

jashaw5 писал(а):
18.05.2013 21:32
http://www.pclinuxos.com/?page_id=1413

А можно поподробнее: там подрубится большое количество сетевых репозиториев с более широким, чем у репозиториев OpenSUSE, набором ПО?

Фантом писал(а):
19.05.2013 00:46
CAEman писал(а):
18.05.2013 21:27
Установить параллельно с установленным ПО безпроблемный Линукс с максимально возможным набором СПО по всем направлениям от гуманитарного до технического (без каких-либо компиляций).

Ну так и ставьте OpenSuSE. Только современную версию (12.3), и подключайте к ней сначала только стандартные репозитории, потом - специальные, но не Factory.

Так этих репозиториев намного меньше, чем Factory. Как получить доступ к такому же большому набору ПО?
Спасибо сказали:
Аватара пользователя
Bizdelnick
Модератор
Сообщения: 20837
Статус: nulla salus bello
ОС: Debian GNU/Linux

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение Bizdelnick »

CAEman писал(а):
25.05.2013 12:32
Так этих репозиториев намного меньше, чем Factory.

Не верю. ©
Вам что конкретно нужно? Учебное/научное ПО? Вот и подключайте https://build.opensuse.org/project/reposito...y=openSUSE_12.3 и https://build.opensuse.org/project/reposito...y=openSUSE_12.3. Если подключите 100500 левых репов, даже не под Factory, а под 12.3 - угробите систему в момент.
И вообще не советую гоняться за количеством ПО. Когда действительно возникнет необходимость в чём-то - найдёте и поставите, а ставить всё подряд "чтобы было" - неблагодарное занятие. Как с точки зрения стабильности системы, так и с точки зрения юзеров, которые заглянут в раздутое меню, ужаснутся и перезагрузятся обратно в винду.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Bizdelnick писал(а):
25.05.2013 13:09
CAEman писал(а):
25.05.2013 12:32
Так этих репозиториев намного меньше, чем Factory.

Не верю. ©
Вам что конкретно нужно? Учебное/научное ПО? Вот и подключайте https://build.opensuse.org/project/reposito...y=openSUSE_12.3 и https://build.opensuse.org/project/reposito...y=openSUSE_12.3. Если подключите 100500 левых репов, даже не под Factory, а под 12.3 - угробите систему в момент.
И вообще не советую гоняться за количеством ПО. Когда действительно возникнет необходимость в чём-то - найдёте и поставите, а ставить всё подряд "чтобы было" - неблагодарное занятие. Как с точки зрения стабильности системы, так и с точки зрения юзеров, которые заглянут в раздутое меню, ужаснутся и перезагрузятся обратно в винду.

Пожалуйста (взял просто несколько первых попавшихся подряд): 1, 2, 3, ...
На комп-е, где я сейчас сижу, подключено более сотни реп-ев (в основном, Factory): система работает. Если юзеры не ужасаются тому меню, что в Винде и, вообще, ухитрились научиться работать в этой системе самостоятельно дома (а только такие могут перезагрузиться обратно в Винду при наличии Линукса), что например, мне не удалось, так как она вообще ничего не умеет без допилов-доустановок (даже установиться на комп. без бубна и напильника в виде дискеты для начала), то каким образом они могут ужаснуться понятному отсортированному (некоторые попадающиеся нелогичные размещения от разработчиков можно предварительно подправить, чтобы потом у всех пользователей было всё логично) меню KDE в классическом стиле? Просто преподаватели будут заходить только в те разделы, которые их могут заинтересовать, и разбираться с находящимся в них ПО. Главное, чтобы они за год успели выбрать себе ПО, с которым будут затем работать. А 01.01.15 всё это снесут и установят Линукс с выбранным ПО. Если же из-за недостатка выбора преподаватели определиться не сумеют, то установят какое-либо ПО по умолчанию с известными последствиями...
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Правильно я понял, что данный вопрос решить нельзя никак?
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

CAEman писал(а):
01.06.2013 11:48
Правильно я понял, что данный вопрос решить нельзя никак?

Неправильно. Допустим, возьмём показанный Вами Cloud:Eucalyptus. Опустим, зачем это необходимо. Здесь 2 варианта:
1. Открыть OBS данного проекта на вкладке Users и написать письмо мантейнерам с просьбой добавить openSUSE 12.3. По датам видно, что проект давно никто не трогал, не удивительно, что 12.3 нет. Кстати, сам eucalyptus для Factory не собран — ошибка сборки, так что счастья в репозитории Factory Вы не получите.
2. Клонировать данный проект в свой локальный и исправить ошибки компиляции.

А живых проектов без поддержки openSUSE 12.3 найти трудно.
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Значит, лучший вариант- это установить версию 12.3 (или последнюю на тот момент?) и подключить все репозитории. А не удаляются ли эти репозитории (для данной версии) через некоторое время?
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

Удаляются. Например, когда заканчивается время поддержки дистрибутива.
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

А как подключить те репозитории, которые 1) не удаляются; 2) не удалятся до 01.01.15 (кстати, одним из критериев выбора репозиториев для Factory был тот, что они почти не удаляются)? И каково это время поддержки?
Спасибо сказали:
Lazy_Kent
Сообщения: 709
Статус: Ленивый
ОС: openSUSE (Xfce)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение Lazy_Kent »

не удалятся до 01.01.15

Ждите следующей версии Evergreen.

одним из критериев выбора репозиториев для Factory был тот, что они почти не удаляются

Factory — это постоянно обновляемый нестабильный репозиторий.
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

CAEman писал(а):
01.06.2013 20:14
А как подключить те репозитории, которые 1) не удаляются; 2) не удалятся до 01.01.15

1) нет таких, которые не удаляются. Разве что Tubmleweed.
2) а смысл? в чём проблема перехода на новые версии дистрибутивов? Ну, или как сказали Evergreen.

CAEman писал(а):
01.06.2013 20:14
кстати, одним из критериев выбора репозиториев для Factory был тот, что они почти не удаляются

Давайте посмотрим на время сборки пакетов в репозитории 3, который Вы приводили. Там 2009 год. Эти пакеты были собраны для Factory 4 года назад. Это совершенно не тот Factory, который мы имеем сейчас. Так что "не удаляются" — совсем не критерий.

CAEman писал(а):
01.06.2013 20:14
И каково это время поддержки?

http://en.opensuse.org/Release_announcemen...release_process
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

NickLion писал(а):
02.06.2013 13:41
1) нет таких, которые не удаляются. Разве что Tubmleweed.
2) а смысл? в чём проблема перехода на новые версии дистрибутивов? Ну, или как сказали Evergreen.

http://en.opensuse.org/Release_announcemen...release_process


1) Под Tubmleweed репозиториев меньше, чем даже под 12.3.
2) Под Evergreen репозиториев нет совсем.

Мы не гуманитарии. Поняли из данного англоязычного ресурса, что, вроде, 8 месяцев время поддержки.


Можно уточнить следующее: если этим летом установить 12.3 и подключить все репозитории для неё и Tubmleweed, то до 01.01.15 многие ли и какие из них останутся?
Или лучше установить Tubmleweed и подключить те же репозитории?
Или нельзя перекрещивать ПО под Tubmleweed и 12.3 в принципе (не будет устанавливаться из-за своих зависимостей)?
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

CAEman писал(а):
08.06.2013 11:50
1) Под Tubmleweed репозиториев меньше, чем даже под 12.3.

Не сравнивал. Я смотрю только по тому ПО, которое меня интересует, а не абстрактное количество репозиториев.

CAEman писал(а):
08.06.2013 11:50
Мы не гуманитарии. Поняли из данного англоязычного ресурса, что, вроде, 8 месяцев время поддержки.

Мы тоже не гуманитарии. Как технарям можно не знать английский? Там написано, что время поддежки (хотя бы) = 2 цикла релизов + 2 месяца, а 8 месяцев — это примерно сколько займёт разработка 13.1. Т.е. текущий 12.3 будет поддерживаться после выпуск 13.2 ещё минимум 2 месяца. 8 * 2 + 2 = 18 месяцев — приблизительный срок поддержки.

CAEman писал(а):
08.06.2013 11:50
Или лучше установить Tubmleweed и подключить те же репозитории?

http://ru.opensuse.org/Portal:Tumbleweed
Раздел "Как попробовать Tumbleweed?"
Хотя я бы на английском читал, там обновляется чаще информация.

CAEman писал(а):
08.06.2013 11:50
Или нельзя перекрещивать ПО под Tubmleweed и 12.3 в принципе (не будет устанавливаться из-за своих зависимостей)?

Если использовать current версии, то всё должно быть норм.
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Вы не гуманитарии, но компьютерщики. И Вам действительно не знать английский нельзя...

Судя по описанию по приведённой Вами ссылке ("Удалите все репозитории для версии openSUSE 12.2 или старше "), будут только следующие репозитории:
http://download.opensuse.org/repositories/...eweed/standard/
http://download.opensuse.org/distribution/...rrent/repo/oss/
http://download.opensuse.org/distribution/...t/repo/non-oss/
http://download.opensuse.org/update/openSUSE-current/
http://download.opensuse.org/update/openSU...on-oss-current/
http://packman.inode.at/suse/openSUSE_Tumbleweed/
Причём: "Репозиторий Packman Tumbleweed Essential пытается, но не дает никаких гарантий работоспособности пакетов их этого репозитория в связи с постоянным обновлением ядра."
А об остальных репозиториях, вроде бы доступных для Tumbleweed, и говорить нечего...

Получается, что, по крайней мере, до 01.01.15 лучше использовать 12.3 и без каких-либо не для 12.3 репозиториев. Или мы опять что-нибудь не так поняли?
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Фантом писал(а):
05.05.2013 01:34
CAEman писал(а):
04.05.2013 20:12
Кстати, я, вроде, слыхал, что в дистр-ах 12.х вернули KDE3 (или это просто рекламный обман?).

Еще в 11.4...

Ничего подобного! Обновили систему из завалявшегося как-то здесь дистр-а 11.4. Никакого KDE3 нет и в помине! Зато, чтобы загрузился графический режим, пришлось восстановить исходный Xorg.conf c framebuffer, причём, всё равно не устанавливается nvidia, а грузится недоделанный nouveau, несмотря на то, что были удалены все файлы, содержащие в названии nouveau, удалены все соответствующие ссылки во всех файлах...

Если 12.3 (и др.) будет иметь такую же "поддержку" KDE3 и драйверов, то, вполне возможно, что OpenSUSE, вообще, будет невариант...
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

CAEman писал(а):
06.07.2013 18:31
Получается, что, по крайней мере, до 01.01.15 лучше использовать 12.3 и без каких-либо не для 12.3 репозиториев. Или мы опять что-нибудь не так поняли?

Да. По мере выхода новых версий можно переключаться на них.

CAEman писал(а):
06.07.2013 19:12
Фантом писал(а):
05.05.2013 01:34
CAEman писал(а):
04.05.2013 20:12
Кстати, я, вроде, слыхал, что в дистр-ах 12.х вернули KDE3 (или это просто рекламный обман?).

Еще в 11.4...

Ничего подобного! Обновили систему из завалявшегося как-то здесь дистр-а 11.4. Никакого KDE3 нет и в помине!

11.4 дропнули. В 12.3 есть kde3:

Код: Выделить всё

> zypper --no-refresh se -s kdelibs3 kde3-amarok
Завантаження даних сховища...
Читання встановлених пакунків...

S | Назва                        | Тип     | Версія        | Арх.   | Сховище
--+------------------------------+---------+---------------+--------+------------------
  | kde3-amarok                  | пакунок | 1.4.10-41.1.2 | x86_64 | openSUSE-12.3-1.7
  | kde3-amarok                  | пакунок | 1.4.10-41.1.2 | i586   | openSUSE-12.3-1.7
  | kde3-amarok-lang             | пакунок | 1.4.10-41.1.2 | noarch | openSUSE-12.3-1.7
  | kde3-amarok-libvisual        | пакунок | 1.4.10-41.1.2 | x86_64 | openSUSE-12.3-1.7
  | kde3-amarok-libvisual        | пакунок | 1.4.10-41.1.2 | i586   | openSUSE-12.3-1.7
  | kde3-amarok-xine             | пакунок | 1.4.10-41.1.2 | x86_64 | openSUSE-12.3-1.7
  | kde3-amarok-xine             | пакунок | 1.4.10-41.1.2 | i586   | openSUSE-12.3-1.7
  | kdelibs3                     | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3                     | пакунок | 3.5.10-67.3.1 | i586   | openSUSE-12.3-1.7
  | kdelibs3-32bit               | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-arts                | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-arts                | пакунок | 3.5.10-67.3.1 | i586   | openSUSE-12.3-1.7
  | kdelibs3-arts-32bit          | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-default-style       | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-default-style       | пакунок | 3.5.10-67.3.1 | i586   | openSUSE-12.3-1.7
  | kdelibs3-default-style-32bit | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-devel               | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-devel               | пакунок | 3.5.10-67.3.1 | i586   | openSUSE-12.3-1.7
  | kdelibs3-doc                 | пакунок | 3.5.10-67.3.1 | x86_64 | openSUSE-12.3-1.7
  | kdelibs3-doc                 | пакунок | 3.5.10-67.3.1 | i586   | openSUSE-12.3-1.7


CAEman писал(а):
06.07.2013 19:12
Зато, чтобы загрузился графический режим, пришлось восстановить исходный Xorg.conf c framebuffer, причём, всё равно не устанавливается nvidia, а грузится недоделанный nouveau, несмотря на то, что были удалены все файлы, содержащие в названии nouveau, удалены все соответствующие ссылки во всех файлах...

Если 12.3 (и др.) будет иметь такую же "поддержку" KDE3 и драйверов, то, вполне возможно, что OpenSUSE, вообще, будет невариант...

Вообще-то не было проблем с установкой драйверов nvidia ни в 11.4, ни в 12.3. Как устанавливали?
Спасибо сказали:
CAEman
Сообщения: 178
ОС: OpenSUSE (GNU/Linux)

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение CAEman »

Новые версии конкретно нас интересовать не будут. Нам главное, чтобы до 01.01.15 версия 12.3 была бы актуальна со всеми своими репозиториями.

И как же рабочее окружение KDE3 работает без своего kdebase? Вы сами проверяли: что там грузится и грузится ли вообще, и есть ли, вообще, выбор kde3 в списке сессий в окне входа kdm (или gdm, xdm)?

Программа установки:
sh NVIDIA-Linux-x86_64-256.44.run -aqX
которая писала, что с драйвером nouveau ничего поделать не может, хотя и добавила его в blacklist, хотя потом его добавили в параметр загрузки ядра rdblacklist, удалили все пакеты, где он упоминался...
Теперь приходится обходиться без привычного 3М рабочего стола. Прогресс налицо...
Спасибо сказали:
NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение NickLion »

CAEman писал(а):
20.07.2013 18:02
И как же рабочее окружение KDE3 работает без своего kdebase? Вы сами проверяли: что там грузится и грузится ли вообще, и есть ли, вообще, выбор kde3 в списке сессий в окне входа kdm (или gdm, xdm)?

Нет, не проверял, мне KDE SC 4 нравится. Но у нас на форуме есть как минимум Nxx и PVOzerski, которые используют KDE3 в openSUSE. Обратитесь к ним, если какие-то проблемы.

CAEman писал(а):
20.07.2013 18:02
Программа установки:
sh NVIDIA-Linux-x86_64-256.44.run -aqX

Что за страшные параметры. Всегда запускал без параметров и не запускал xconfig, всё работало. Но вообще, вопрос, зачем Вы используете установщик (да ещё и такой старой версии), а не репозиторий ftp://download.nvidia.com/opensuse/12.3/ ?
Спасибо сказали:
Аватара пользователя
MozgFx
Сообщения: 18
ОС: OpenSuse 11.1

Re: Разные проблемы с установкой пакетов в OpenSUSE

Сообщение MozgFx »

NickLion писал(а):
21.07.2013 11:37
CAEman писал(а):
20.07.2013 18:02
И как же рабочее окружение KDE3 работает без своего kdebase? Вы сами проверяли: что там грузится и грузится ли вообще, и есть ли, вообще, выбор kde3 в списке сессий в окне входа kdm (или gdm, xdm)?

Нет, не проверял, мне KDE SC 4 нравится. Но у нас на форуме есть как минимум Nxx и PVOzerski, которые используют KDE3 в openSUSE. Обратитесь к ним, если какие-то проблемы.

"Молча" (так кажется отвечают в подобных ситуациях) работает если его установить...
Пакет kdebase3 доступен для установки...
Если имеющихся пакетов недостаточно их можно взять из соответствующих репозитаериев...
http://ru.opensuse.org/KDE3
Краснодарский край On-Line
Спасибо сказали: