Не запускается X.Org после переключения на встроенную видеокарту

nVidia, ATI, SIS, VIA и др.

Модераторы: broom, Модераторы разделов

Аватара пользователя
iROOT
Сообщения: 9
ОС: Ubuntu 10.10 x64 and x32

Не запускается X.Org после переключения на встроенную видеокарту

Сообщение iROOT » 16.03.2011 22:35

Есть нетбук Asus Eee PC 1015PN.
Хотел сделать переключение между видеокартами Nvidia GTX 218 и Intel GMA 3150.
Выполнил все что написано в 3 посте этой темы.
После запуска скрипта переключения на видеокарту Intel и перезагрузки не загружается X.Org.
Скрипты я подправил и перевел с.м. в приложении. Там же надятся файлы xorg.conf. Cохранил их как "intel" и "nvidia" в "/usr/sbin".
Делаю так: запускаю скрипт "sudo intel" и перезагружаю компьютер и в итоге X.Org не запускается пишет про "fatal server error: no screen found".
Где хранятся логи X.Org что бы их сюда написать?
Как сделать так что бы запустился X.Org на видеокарте Intel?
Как можно сделать так что бы при выборе определенного пункта в Grub 2 запускался нужный скрипт до запуска X.Org?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Все мои сообщения являются моим личным мнением.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 16055
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: Не запускается X.Org после переключения на встроенную видеокарту

Сообщение Bizdelnick » 16.03.2011 22:45

iROOT писал(а):
16.03.2011 22:35
Где хранятся логи X.Org что бы их сюда написать?

/var/log/Xorg.0.log
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

NickLion
Сообщения: 3408
Статус: аватар-невидимка
ОС: openSUSE Tumbleweed x86_64

Re: Не запускается X.Org после переключения на встроенную видеокарту

Сообщение NickLion » 17.03.2011 08:53

iROOT писал(а):
16.03.2011 22:35
Как можно сделать так что бы при выборе определенного пункта в Grub 2 запускался нужный скрипт до запуска X.Org?

Для данной проблемы я бы сделал 2 run level'а, а в GRUB (неважно 2 или 0.97) добавил в конец число - номер соотв. run level'а.
Спасибо сказали:

Аватара пользователя
iROOT
Сообщения: 9
ОС: Ubuntu 10.10 x64 and x32

Re: Не запускается X.Org после переключения на встроенную видеокарту

Сообщение iROOT » 17.03.2011 13:16

Обновил файл text.tar.gz в 1 посте добавив в него /var/log/Xorg.0.log.
Добавил в /etc/sudoers следующую строку что бы не запрашивал пароль.

Код: Выделить всё

iroot    ALL=NOPASSWD: /usr/sbin/intel, /usr/sbin/nvidia

И вот какие права у файлов.

Код: Выделить всё

$ ls -l /usr/sbin/intel /usr/sbin/nvidia
-rwxr-x--- 1 root root 1573 2011-03-17 13:03 /usr/sbin/intel
-rwxr-x--- 1 root root 2505 2011-03-17 13:03 /usr/sbin/nvidia
Все мои сообщения являются моим личным мнением.
Спасибо сказали: