РЕШЕНО: Qt6 и QWT - проблема с запуском приложения

Модератор: Модераторы разделов

Аватара пользователя
devilr
Сообщения: 3675
ОС: Mandriva => Gentoo (~amd64)

РЕШЕНО: Qt6 и QWT - проблема с запуском приложения

Сообщение devilr »

Доброго времени суток!
Решил полностью перебраться на Qt6 (всё таки уже вышла версия 6.7.0).
Собрал простейший проект (во вложении).
Если переключить проект на "комплект Qt5" - после сборки и нажатии на единственную кнопку запустится окно графика QwtPlot.
Если переключить проект на "комплект Qt6" - после сборки и нажатии на единственную кнопку
программа упадёт.
Это только у меня так?

P.Ṡ. Если вдруг интересно QWT 6.2.0
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось devilr 22.04.2024 20:30, всего редактировалось 1 раз.
Мудрость приходит с возрастом.
Иногда возраст приходит один.
Эхо разума
Спасибо сказали:
Аватара пользователя
ormorph
Сообщения: 2712
ОС: Gentoo

Re: Qt6 и QWT - проблема с запуском приложения

Сообщение ormorph »

devilr писал:
22.04.2024 14:54
Это только у меня так?
Нет так будет у любого. У вас в проекте строчка: LIBS += -lqwt6-qt5
Spoiler

Shell

$ ldd /usr/lib64/libqwt6-qt5.so
linux-vdso.so.1 (0x00007fff6fb66000)
libQt5Svg.so.5 => /usr/lib64/libQt5Svg.so.5 (0x00007fd67edb7000)
libQt5OpenGL.so.5 => /usr/lib64/libQt5OpenGL.so.5 (0x00007fd67ed5c000)
libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007fd67e600000)
libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007fd67e000000)
libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007fd67da00000)
libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/13/libstdc++.so.6 (0x00007fd67d600000)
libm.so.6 => /usr/lib64/libm.so.6 (0x00007fd67ec7a000)
libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/13/libgcc_s.so.1 (0x00007fd67e5db000)
libc.so.6 => /usr/lib64/libc.so.6 (0x00007fd67d425000)
libz.so.1 => /usr/lib64/libz.so.1 (0x00007fd67ec60000)
libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007fd67df7a000)
libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007fd67d9c9000)
libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007fd67d899000)
libdouble-conversion.so.3 => /usr/lib64/libdouble-conversion.so.3 (0x00007fd67df64000)
libicui18n.so.74 => /usr/lib64/libicui18n.so.74 (0x00007fd67d000000)
libicuuc.so.74 => /usr/lib64/libicuuc.so.74 (0x00007fd67cc00000)
libpcre2-16.so.0 => /usr/lib64/libpcre2-16.so.0 (0x00007fd67d397000)
libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007fd67cebd000)
/lib64/ld-linux-x86-64.so.2 (0x00007fd67efe3000)
libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0 (0x00007fd67cb47000)
libGLX.so.0 => /usr/lib64/libGLX.so.0 (0x00007fd67d363000)
libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fd67ca7a000)
libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007fd67d873000)
libicudata.so.74 => /usr/lib64/libicudata.so.74 (0x00007fd67ac00000)
libpcre2-8.so.0 => /usr/lib64/libpcre2-8.so.0 (0x00007fd67ce21000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fd67aabe000)
libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00007fd67d350000)
libbrotlidec.so.1 => /usr/lib64/libbrotlidec.so.1 (0x00007fd67df56000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fd67ca4f000)
libbrotlicommon.so.1 => /usr/lib64/libbrotlicommon.so.1 (0x00007fd67ca2c000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fd67d86e000)
libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fd67d348000)
Решение проблемы:

Shell

# euse -p x11-libs/qwt -E qt6
# emerge x11-libs/qwt
И заменить на строчку: LIBS += -lqwt6-qt6
Пусть вас версия этого пакета не вводит в заблуждение, по умолчанию он собирается под Qt5.
Спасибо сказали:
Аватара пользователя
devilr
Сообщения: 3675
ОС: Mandriva => Gentoo (~amd64)

Re: Qt6 и QWT - проблема с запуском приложения

Сообщение devilr »

Хм, я почему то думал, что это
ormorph писал(а):
22.04.2024 17:40
LIBS += -lqwt6-qt5
скорее для совместимости. А оно вон как! :)
В любом случае, спасибо!
Мудрость приходит с возрастом.
Иногда возраст приходит один.
Эхо разума
Спасибо сказали: