Почему в Debian нет выбора версии ядра? (Пересобрать можно, а если мне нужно другое?)

Любые разговоры которые хоть как-то связаны с тематикой форума

Модератор: Модераторы разделов

Kopilov
Сообщения: 860
ОС: [K]Ubuntu, Debian

Почему в Debian нет выбора версии ядра?

Сообщение Kopilov »

Мы тут клином сошлись на внедрении Systemd в Debian и не только и на том, что нас лишают права выбора системы инициализации. Но есть ещё такая важная вещь, как ядро. Конечно, ставить GNU Hurd или BSD я не собираюсь, однако и Linux Kernel существует не единственной версии.

Недвно попробовал поставить Debian Jessie. (Помимо прочего, оно не встало на мою старую DOS-разметку, а на созданной инсталлятором GPT не удалось загрузить развёрнутый позже бекап Gentoo, но оставим это в стороне. Это был мой первой опыт с GPT.)
Главная проблема: перестали работать USB-порты. Вообще. А ещё при загрузке выскакивала какая-то ошибка про ACPI -- и при выключении приходилось удерживать кнопку Power.
Spoiler
На соседнем форуме это оказалось очень к месту: http://forum.sources.ru/index.php?showtopi...p;#entry3568965

Пишут, что проблема началась с версии ядра 3.14 и типа "Acer и AMD опять в своём репертуаре" (у меня Aspire 5560G).
Для исправления предлагают попробовать версию 3.17. В Debian её нет (даже в SID) -- ладно, ещё не внедрили. Но ПОЧЕМУ из более старых (что Image, что Source) есть только 3.2 из старого релиза? А если кому-то нужно поновее, но не самое последнее -- руками с kernel.org качать?
Вот в Gentoo есть из чего выбирать: только стабильных на сегодня 4 штуки. И, что символично, не только 3.2 (уже устарело), но и глючного 3.16 в списке нет вообще.

Что с моей системой (если кому интересно): собрал новую Gentoo на ядре 3.17, переразметив диск обратно в DOS -- всё работает. Заодно выкинул сразу два BLOB-драйвера: BroadcomSTA и FGLRX.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 19300
Статус: nulla salus bello
ОС: Debian GNU/Linux

Re: Почему в Debian нет выбора версии ядра?

Сообщение Bizdelnick »

Kopilov писал(а):
10.02.2015 13:41
ПОЧЕМУ из более старых (что Image, что Source) есть только 3.2 из старого релиза?

Ну так зеркала не резиновые, и поддержка бинарного пакета куда более трудозатратна, чем архива с исходниками в Gentoo.

Kopilov писал(а):
10.02.2015 13:41
3.2 (уже устарело)

Вообще-то оно ещё поддерживается. Причём оно даже не самое старое из поддерживаемых (есть ещё 2.6.32).
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали: